OSDN Git Service

import 0.9.4
[handbrake-jp/handbrake-jp.git] / gtk / ghb.spec
1 %define name HandBrake
2 %define release 1
3
4 Name:           %{name}
5 Version:        %{version}
6 Release:        %{release}%{?dist}
7 Summary:        A program to transcode DVDs and other sources to MPEG-4
8
9 Group:          Applications/Multimedia
10 License:        GPL
11 URL:            http://handbrake.fr/
12 Vendor:         The HandBrake Project
13 Source0:        %{name}-%{version}.tar.bz2
14 Prefix:         %{_prefix}
15 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
16 Requires:       glib2 >= 2.16, gtk2 >= 2.12, hal-libs, webkitgtk, gstreamer
17 Requires:       gstreamer-plugins-base
18
19 %description
20 HandBrake is an open-source, GPL-licensed, multiplatform, multithreaded 
21 transcoder, available for MacOS X, Linux and Windows.
22
23 %package gui
24 Summary:        A program to transcode DVDs and other sources to MPEG-4
25 Group:          Applications/Multimedia
26
27 %package cli
28 Summary:        A program to transcode DVDs and other sources to MPEG-4
29 Group:          Applications/Multimedia
30
31 %description gui
32 HandBrake is an open-source, GPL-licensed, multiplatform, multithreaded 
33 transcoder, available for MacOS X, Linux and Windows.
34
35 %description cli
36 HandBrake is an open-source, GPL-licensed, multiplatform, multithreaded 
37 transcoder, available for MacOS X, Linux and Windows.
38
39 %prep
40 %setup -n %{name}-%{version} -D -T
41 #%setup -q
42 #cd %{_builddir}/%{name}-%{version}
43
44
45 %build
46 #./configure --prefix=%{_prefix}
47 #make -C build
48
49
50 %install
51 #rm -rf $RPM_BUILD_ROOT
52 # I don't want to rebuild the world, so just install what I've prebuilt
53 make -C $RPM_BUILD_ROOT/../.. DESTDIR=$RPM_BUILD_ROOT install
54
55 ## blow away stuff we don't want
56 /bin/rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %post gui
62 touch --no-create %{_datadir}/icons/hicolor
63 if [ -x /usr/bin/gtk-update-icon-cache ]; then
64   gtk-update-icon-cache -q %{_datadir}/icons/hicolor
65 fi
66
67 %postun gui
68 touch --no-create %{_datadir}/icons/hicolor
69 if [ -x /usr/bin/gtk-update-icon-cache ]; then
70   gtk-update-icon-cache -q %{_datadir}/icons/hicolor
71 fi
72
73 %files gui
74 %defattr(-,root,root,-)
75 %doc NEWS AUTHORS CREDITS THANKS COPYING
76 %{_datadir}/icons
77 %{_datadir}/applications
78 %{_bindir}/ghb
79
80 %files cli
81 %defattr(-,root,root,-)
82 %doc NEWS AUTHORS CREDITS THANKS COPYING
83 %{_bindir}/HandBrakeCLI
84
85 %changelog
86 * Sat May 31 2008 John Stebbins <jstebbins@jetheaddev.com> 
87 - Initial release
88
89