OSDN Git Service

refactoring.
[kita/kita.git] / kita.spec
1 %define version 0.200.0
2
3 %define use_xdg_menu %{!?_with_xdg_menu:0}%{?_with_xdg_menu:1}
4
5 %define is_suse      %(if [ -e /etc/SuSE-release ]; then echo "yes"; else echo "no"; fi)
6 %if %{is_suse} == "yes"
7 %define _prefix /opt/kde3
8 %endif
9
10 %define is_x86_64 %(if [ "x86_64" == `uname -m` ]; then echo "yes"; else echo "no"; fi)
11
12 Summary: 2ch client for KDE
13 Name: kita
14 Version: %{version}
15 Release: 1
16 Source: kita-%{version}.tar.gz
17 License: GPL
18 URL: http://sourceforge.jp/projects/kita/
19 Group: Application/Internet
20 Packager: Hideki Ikemoto <ikemo@users.sourceforge.jp>
21 BuildRoot: %{_tmppath}/%{name}-%{version}-root
22
23 # TurboLinux uses 'Serial' field.
24 #Serial: 2004051601
25
26 %description
27 2ch client for KDE      
28
29 %prep
30 %setup -q
31
32 %build
33 ./configure --prefix=%{_prefix} \
34 %if %{is_x86_64} == "yes"
35  --enable-libsuffix=64 \
36  %if %{is_suse} == "yes"
37  --with-qt-libraries=/usr/lib64/qt-3.3/lib64 \
38  %else
39  --with-qt-libraries=/usr/lib64/qt-3.3/lib \
40  %endif
41 %endif
42 %if %{use_xdg_menu}
43   --enable-xdg-menu
44 %endif
45
46 make clean
47 make
48
49 %install
50 rm -rf %{buildroot}
51 %makeinstall
52
53 %clean
54 rm -rf %{buildroot}
55
56 %post -p /sbin/ldconfig
57 %postun -p /sbin/ldconfig
58 %files
59 %defattr(-, root, root)
60 %doc AUTHORS COPYING ChangeLog NEWS README README.2ch TODO
61 %{_bindir}/*
62 %{_libdir}/*.so*
63 %{_libdir}/*.la
64 #%{_libdir}/kde3/*.so
65 #%{_libdir}/kde3/*.la
66 %{_datadir}/apps/kita/*ui.rc
67 %{_datadir}/apps/kita/icons/*/*/*/*
68 #%{_datadir}/apps/konqsidebartng/*/*
69 %if %{use_xdg_menu}
70 %{_datadir}/applications/kita.desktop
71 %else
72 %{_datadir}/applnk/Internet/kita.desktop
73 %endif
74 #%{_datadir}/applnk/Settings/Network/kcm_k2ch.desktop
75 #%{_datadir}/config/kio_k2chrc
76 #%{_datadir}/services/*
77 #%{_datadir}/mimelnk/text/*
78 %{_datadir}/locale/ja/LC_MESSAGES/*
79 %{_datadir}/icons/*/*/*/*
80 %{_datadir}/doc/HTML/en/kita/*
81 %changelog
82 * Sun Nov 21 2004 Hideki Ikemoto<ikemo@users.sourceforge.jp>
83 - remove kitapart/kita*ui.rc
84
85 * Sat Oct 07 2004 Hideki Ikemoto<ikemo@users.sourceforge.jp>
86 - set %%{_prefix} if SuSE
87
88 * Sat May 15 2004 Hideki Ikemoto<ikemo@users.sourceforge.jp>
89 - add 'Serial' field (comment)
90
91 * Sat Dec 13 2003 Hideki Ikemoto<ikemo@users.sourceforge.jp>
92 - don't use %%configure
93
94 * Mon Oct 13 2003 Hideki Ikemoto<ikemo@users.sourceforge.jp>
95 - add files
96
97 * Wed Mar 03 2003 Hideki Ikemoto<ikemo@users.sourceforge.jp>
98 - initial release.