OSDN Git Service

Add *int64 and GLsync types and related functions
[android-x86/frameworks-native.git] / opengl / tools / glgen / specs / gles11 / GLES30.spec
1 //
2 // Inherited OpenGL ES 2.0 functions
3 //
4 void glActiveTexture ( GLenum texture )
5 void glAttachShader ( GLuint program, GLuint shader )
6 void glBindAttribLocation ( GLuint program, GLuint index, const char *name )
7 void glBindBuffer ( GLenum target, GLuint buffer )
8 void glBindFramebuffer ( GLenum target, GLuint framebuffer )
9 void glBindRenderbuffer ( GLenum target, GLuint renderbuffer )
10 void glBindTexture ( GLenum target, GLuint texture )
11 void glBlendColor ( GLfloat red, GLfloat green, GLfloat blue, GLfloat alpha )
12 void glBlendEquation ( GLenum mode )
13 void glBlendEquationSeparate ( GLenum modeRGB, GLenum modeAlpha )
14 void glBlendFunc ( GLenum sfactor, GLenum dfactor )
15 void glBlendFuncSeparate ( GLenum srcRGB, GLenum dstRGB, GLenum srcAlpha, GLenum dstAlpha )
16 void glBufferData ( GLenum target, GLsizeiptr size, const GLvoid *data, GLenum usage )
17 void glBufferSubData ( GLenum target, GLintptr offset, GLsizeiptr size, const GLvoid *data )
18 GLenum glCheckFramebufferStatus ( GLenum target )
19 void glClear ( GLbitfield mask )
20 void glClearColor ( GLfloat red, GLfloat green, GLfloat blue, GLfloat alpha )
21 void glClearDepthf ( GLfloat depth )
22 void glClearStencil ( GLint s )
23 void glColorMask ( GLboolean red, GLboolean green, GLboolean blue, GLboolean alpha )
24 void glCompileShader ( GLuint shader )
25 void glCompressedTexImage2D ( GLenum target, GLint level, GLenum internalformat, GLsizei width, GLsizei height, GLint border, GLsizei imageSize, const GLvoid *data )
26 void glCompressedTexSubImage2D ( GLenum target, GLint level, GLint xoffset, GLint yoffset, GLsizei width, GLsizei height, GLenum format, GLsizei imageSize, const GLvoid *data )
27 void glCopyTexImage2D ( GLenum target, GLint level, GLenum internalformat, GLint x, GLint y, GLsizei width, GLsizei height, GLint border )
28 void glCopyTexSubImage2D ( GLenum target, GLint level, GLint xoffset, GLint yoffset, GLint x, GLint y, GLsizei width, GLsizei height )
29 GLuint glCreateProgram ( void )
30 GLuint glCreateShader ( GLenum type )
31 void glCullFace ( GLenum mode )
32 void glDeleteBuffers ( GLsizei n, const GLuint *buffers )
33 void glDeleteFramebuffers ( GLsizei n, const GLuint *framebuffers )
34 void glDeleteProgram ( GLuint program )
35 void glDeleteRenderbuffers ( GLsizei n, const GLuint *renderbuffers )
36 void glDeleteShader ( GLuint shader )
37 void glDeleteTextures ( GLsizei n, const GLuint *textures )
38 void glDepthFunc ( GLenum func )
39 void glDepthMask ( GLboolean flag )
40 void glDepthRangef ( GLfloat n, GLfloat f )
41 void glDetachShader ( GLuint program, GLuint shader )
42 void glDisable ( GLenum cap )
43 void glDisableVertexAttribArray ( GLuint index )
44 void glDrawArrays ( GLenum mode, GLint first, GLsizei count )
45 void glDrawElements ( GLenum mode, GLsizei count, GLenum type, GLint offset )
46 void glDrawElements ( GLenum mode, GLsizei count, GLenum type, const GLvoid *indices )
47 void glEnable ( GLenum cap )
48 void glEnableVertexAttribArray ( GLuint index )
49 void glFinish ( void )
50 void glFlush ( void )
51 void glFramebufferRenderbuffer ( GLenum target, GLenum attachment, GLenum renderbuffertarget, GLuint renderbuffer )
52 void glFramebufferTexture2D ( GLenum target, GLenum attachment, GLenum textarget, GLuint texture, GLint level )
53 void glFrontFace ( GLenum mode )
54 void glGenBuffers ( GLsizei n, GLuint *buffers )
55 void glGenerateMipmap ( GLenum target )
56 void glGenFramebuffers ( GLsizei n, GLuint *framebuffers )
57 void glGenRenderbuffers ( GLsizei n, GLuint *renderbuffers )
58 void glGenTextures ( GLsizei n, GLuint *textures )
59 void glGetActiveAttrib ( GLuint program, GLuint index, GLsizei bufsize, GLsizei *length, GLint *size, GLenum *type, char *name )
60 void glGetActiveUniform ( GLuint program, GLuint index, GLsizei bufsize, GLsizei *length, GLint *size, GLenum *type, char *name )
61 void glGetAttachedShaders ( GLuint program, GLsizei maxcount, GLsizei *count, GLuint *shaders )
62 GLint glGetAttribLocation ( GLuint program, const char *name )
63 void glGetBooleanv ( GLenum pname, GLboolean *params )
64 void glGetBufferParameteriv ( GLenum target, GLenum pname, GLint *params )
65 GLenum glGetError ( void )
66 void glGetFloatv ( GLenum pname, GLfloat *params )
67 void glGetFramebufferAttachmentParameteriv ( GLenum target, GLenum attachment, GLenum pname, GLint *params )
68 void glGetIntegerv ( GLenum pname, GLint *params )
69 void glGetProgramiv ( GLuint program, GLenum pname, GLint *params )
70 void glGetProgramInfoLog ( GLuint program, GLsizei bufsize, GLsizei *length, char *infolog )
71 void glGetRenderbufferParameteriv ( GLenum target, GLenum pname, GLint *params )
72 void glGetShaderiv ( GLuint shader, GLenum pname, GLint *params )
73 void glGetShaderInfoLog ( GLuint shader, GLsizei bufsize, GLsizei *length, char *infolog )
74 void glGetShaderPrecisionFormat ( GLenum shadertype, GLenum precisiontype, GLint *range, GLint *precision )
75 void glGetShaderSource ( GLuint shader, GLsizei bufsize, GLsizei *length, char *source )
76 const GLubyte * glGetString ( GLenum name )
77 void glGetTexParameterfv ( GLenum target, GLenum pname, GLfloat *params )
78 void glGetTexParameteriv ( GLenum target, GLenum pname, GLint *params )
79 void glGetUniformfv ( GLuint program, GLint location, GLfloat *params )
80 void glGetUniformiv ( GLuint program, GLint location, GLint *params )
81 GLint glGetUniformLocation ( GLuint program, const char *name )
82 void glGetVertexAttribfv ( GLuint index, GLenum pname, GLfloat *params )
83 void glGetVertexAttribiv ( GLuint index, GLenum pname, GLint *params )
84 // void glGetVertexAttribPointerv ( GLuint index, GLenum pname, void **pointer )
85 void glHint ( GLenum target, GLenum mode )
86 GLboolean glIsBuffer ( GLuint buffer )
87 GLboolean glIsEnabled ( GLenum cap )
88 GLboolean glIsFramebuffer ( GLuint framebuffer )
89 GLboolean glIsProgram ( GLuint program )
90 GLboolean glIsRenderbuffer ( GLuint renderbuffer )
91 GLboolean glIsShader ( GLuint shader )
92 GLboolean glIsTexture ( GLuint texture )
93 void glLineWidth ( GLfloat width )
94 void glLinkProgram ( GLuint program )
95 void glPixelStorei ( GLenum pname, GLint param )
96 void glPolygonOffset ( GLfloat factor, GLfloat units )
97 void glReadPixels ( GLint x, GLint y, GLsizei width, GLsizei height, GLenum format, GLenum type, GLvoid *pixels )
98 void glReleaseShaderCompiler ( void )
99 void glRenderbufferStorage ( GLenum target, GLenum internalformat, GLsizei width, GLsizei height )
100 void glSampleCoverage ( GLfloat value, GLboolean invert )
101 void glScissor ( GLint x, GLint y, GLsizei width, GLsizei height )
102 void glShaderBinary ( GLsizei n, const GLuint *shaders, GLenum binaryformat, const GLvoid *binary, GLsizei length )
103 void glShaderSource ( GLuint shader )
104 void glStencilFunc ( GLenum func, GLint ref, GLuint mask )
105 void glStencilFuncSeparate ( GLenum face, GLenum func, GLint ref, GLuint mask )
106 void glStencilMask ( GLuint mask )
107 void glStencilMaskSeparate ( GLenum face, GLuint mask )
108 void glStencilOp ( GLenum fail, GLenum zfail, GLenum zpass )
109 void glStencilOpSeparate ( GLenum face, GLenum fail, GLenum zfail, GLenum zpass )
110 void glTexImage2D ( GLenum target, GLint level, GLint internalformat, GLsizei width, GLsizei height, GLint border, GLenum format, GLenum type, const GLvoid *pixels )
111 void glTexParameterf ( GLenum target, GLenum pname, GLfloat param )
112 void glTexParameterfv ( GLenum target, GLenum pname, const GLfloat *params )
113 void glTexParameteri ( GLenum target, GLenum pname, GLint param )
114 void glTexParameteriv ( GLenum target, GLenum pname, const GLint *params )
115 void glTexSubImage2D ( GLenum target, GLint level, GLint xoffset, GLint yoffset, GLsizei width, GLsizei height, GLenum format, GLenum type, const GLvoid *pixels )
116 void glUniform1f ( GLint location, GLfloat x )
117 void glUniform1fv ( GLint location, GLsizei count, const GLfloat *v )
118 void glUniform1i ( GLint location, GLint x )
119 void glUniform1iv ( GLint location, GLsizei count, const GLint *v )
120 void glUniform2f ( GLint location, GLfloat x, GLfloat y )
121 void glUniform2fv ( GLint location, GLsizei count, const GLfloat *v )
122 void glUniform2i ( GLint location, GLint x, GLint y )
123 void glUniform2iv ( GLint location, GLsizei count, const GLint *v )
124 void glUniform3f ( GLint location, GLfloat x, GLfloat y, GLfloat z )
125 void glUniform3fv ( GLint location, GLsizei count, const GLfloat *v )
126 void glUniform3i ( GLint location, GLint x, GLint y, GLint z )
127 void glUniform3iv ( GLint location, GLsizei count, const GLint *v )
128 void glUniform4f ( GLint location, GLfloat x, GLfloat y, GLfloat z, GLfloat w )
129 void glUniform4fv ( GLint location, GLsizei count, const GLfloat *v )
130 void glUniform4i ( GLint location, GLint x, GLint y, GLint z, GLint w )
131 void glUniform4iv ( GLint location, GLsizei count, const GLint *v )
132 void glUniformMatrix2fv ( GLint location, GLsizei count, GLboolean transpose, const GLfloat *value )
133 void glUniformMatrix3fv ( GLint location, GLsizei count, GLboolean transpose, const GLfloat *value )
134 void glUniformMatrix4fv ( GLint location, GLsizei count, GLboolean transpose, const GLfloat *value )
135 void glUseProgram ( GLuint program )
136 void glValidateProgram ( GLuint program )
137 void glVertexAttrib1f ( GLuint indx, GLfloat x )
138 void glVertexAttrib1fv ( GLuint indx, const GLfloat *values )
139 void glVertexAttrib2f ( GLuint indx, GLfloat x, GLfloat y )
140 void glVertexAttrib2fv ( GLuint indx, const GLfloat *values )
141 void glVertexAttrib3f ( GLuint indx, GLfloat x, GLfloat y, GLfloat z )
142 void glVertexAttrib3fv ( GLuint indx, const GLfloat *values )
143 void glVertexAttrib4f ( GLuint indx, GLfloat x, GLfloat y, GLfloat z, GLfloat w )
144 void glVertexAttrib4fv ( GLuint indx, const GLfloat *values )
145 void glVertexAttribPointer ( GLuint indx, GLint size, GLenum type, GLboolean normalized, GLsizei stride, GLint offset )
146 void glVertexAttribPointer ( GLuint indx, GLint size, GLenum type, GLboolean normalized, GLsizei stride, const GLvoid *ptr )
147 void glViewport ( GLint x, GLint y, GLsizei width, GLsizei height )
148 //
149 // New OpenGL ES 3.0 functions
150 //
151 void glReadBuffer ( GLenum mode )
152 void glDrawRangeElements ( GLenum mode, GLuint start, GLuint end, GLsizei count, GLenum type, const GLvoid *indices )
153 void glTexImage3D ( GLenum target, GLint level, GLint internalformat, GLsizei width, GLsizei height, GLsizei depth, GLint border, GLenum format, GLenum type, const GLvoid *pixels )
154 void glTexSubImage3D ( GLenum target, GLint level, GLint xoffset, GLint yoffset, GLint zoffset, GLsizei width, GLsizei height, GLsizei depth, GLenum format, GLenum type, const GLvoid *pixels )
155 void glCopyTexSubImage3D ( GLenum target, GLint level, GLint xoffset, GLint yoffset, GLint zoffset, GLint x, GLint y, GLsizei width, GLsizei height )
156 void glCompressedTexImage3D ( GLenum target, GLint level, GLenum internalformat, GLsizei width, GLsizei height, GLsizei depth, GLint border, GLsizei imageSize, const GLvoid *data )
157 void glCompressedTexSubImage3D ( GLenum target, GLint level, GLint xoffset, GLint yoffset, GLint zoffset, GLsizei width, GLsizei height, GLsizei depth, GLenum format, GLsizei imageSize, const GLvoid *data )
158 void glGenQueries ( GLsizei n, GLuint *ids )
159 void glDeleteQueries ( GLsizei n, const GLuint *ids )
160 GLboolean glIsQuery ( GLuint id )
161 void glBeginQuery ( GLenum target, GLuint id )
162 void glEndQuery ( GLenum target )
163 void glGetQueryiv ( GLenum target, GLenum pname, GLint *params )
164 void glGetQueryObjectuiv ( GLuint id, GLenum pname, GLuint *params )
165 GLboolean glUnmapBuffer ( GLenum target )
166 // void glGetBufferPointerv ( GLenum target, GLenum pname, GLvoid **params )
167 void glDrawBuffers ( GLsizei n, const GLenum *bufs )
168 void glUniformMatrix2x3fv ( GLint location, GLsizei count, GLboolean transpose, const GLfloat *value )
169 void glUniformMatrix3x2fv ( GLint location, GLsizei count, GLboolean transpose, const GLfloat *value )
170 void glUniformMatrix2x4fv ( GLint location, GLsizei count, GLboolean transpose, const GLfloat *value )
171 void glUniformMatrix4x2fv ( GLint location, GLsizei count, GLboolean transpose, const GLfloat *value )
172 void glUniformMatrix3x4fv ( GLint location, GLsizei count, GLboolean transpose, const GLfloat *value )
173 void glUniformMatrix4x3fv ( GLint location, GLsizei count, GLboolean transpose, const GLfloat *value )
174 void glBlitFramebuffer ( GLint srcX0, GLint srcY0, GLint srcX1, GLint srcY1, GLint dstX0, GLint dstY0, GLint dstX1, GLint dstY1, GLbitfield mask, GLenum filter )
175 void glRenderbufferStorageMultisample ( GLenum target, GLsizei samples, GLenum internalformat, GLsizei width, GLsizei height )
176 void glFramebufferTextureLayer ( GLenum target, GLenum attachment, GLuint texture, GLint level, GLint layer )
177 // GLvoid * glMapBufferRange ( GLenum target, GLintptr offset, GLsizeiptr length, GLbitfield access )
178 void glFlushMappedBufferRange ( GLenum target, GLintptr offset, GLsizeiptr length )
179 void glBindVertexArray ( GLuint array )
180 void glDeleteVertexArrays ( GLsizei n, const GLuint *arrays )
181 void glGenVertexArrays ( GLsizei n, GLuint *arrays )
182 GLboolean glIsVertexArray ( GLuint array )
183 void glGetIntegeri_v ( GLenum target, GLuint index, GLint *data )
184 void glBeginTransformFeedback ( GLenum primitiveMode )
185 void glEndTransformFeedback ( void )
186 void glBindBufferRange ( GLenum target, GLuint index, GLuint buffer, GLintptr offset, GLsizeiptr size )
187 void glBindBufferBase ( GLenum target, GLuint index, GLuint buffer )
188 // void glTransformFeedbackVaryings ( GLuint program, GLsizei count, const GLchar *const *varyings, GLenum bufferMode )
189 // void glGetTransformFeedbackVarying ( GLuint program, GLuint index, GLsizei bufSize, GLsizei *length, GLsizei *size, GLenum *type, GLchar *name )
190 // void glVertexAttribIPointer ( GLuint index, GLint size, GLenum type, GLsizei stride, const GLvoid *pointer )
191 void glGetVertexAttribIiv ( GLuint index, GLenum pname, GLint *params )
192 void glGetVertexAttribIuiv ( GLuint index, GLenum pname, GLuint *params )
193 void glVertexAttribI4i ( GLuint index, GLint x, GLint y, GLint z, GLint w )
194 void glVertexAttribI4ui ( GLuint index, GLuint x, GLuint y, GLuint z, GLuint w )
195 void glVertexAttribI4iv ( GLuint index, const GLint *v )
196 void glVertexAttribI4uiv ( GLuint index, const GLuint *v )
197 void glGetUniformuiv ( GLuint program, GLint location, GLuint *params )
198 GLint glGetFragDataLocation ( GLuint program, const GLchar *name )
199 void glUniform1ui ( GLint location, GLuint v0 )
200 void glUniform2ui ( GLint location, GLuint v0, GLuint v1 )
201 void glUniform3ui ( GLint location, GLuint v0, GLuint v1, GLuint v2 )
202 void glUniform4ui ( GLint location, GLuint v0, GLuint v1, GLuint v2, GLuint v3 )
203 void glUniform1uiv ( GLint location, GLsizei count, const GLuint *value )
204 void glUniform2uiv ( GLint location, GLsizei count, const GLuint *value )
205 void glUniform3uiv ( GLint location, GLsizei count, const GLuint *value )
206 void glUniform4uiv ( GLint location, GLsizei count, const GLuint *value )
207 void glClearBufferiv ( GLenum buffer, GLint drawbuffer, const GLint *value )
208 void glClearBufferuiv ( GLenum buffer, GLint drawbuffer, const GLuint *value )
209 void glClearBufferfv ( GLenum buffer, GLint drawbuffer, const GLfloat *value )
210 void glClearBufferfi ( GLenum buffer, GLint drawbuffer, GLfloat depth, GLint stencil )
211 // const GLubyte * glGetStringi ( GLenum name, GLuint index )
212 void glCopyBufferSubData ( GLenum readTarget, GLenum writeTarget, GLintptr readOffset, GLintptr writeOffset, GLsizeiptr size )
213 // void glGetUniformIndices ( GLuint program, GLsizei uniformCount, const GLchar *const *uniformNames, GLuint *uniformIndices )
214 void glGetActiveUniformsiv ( GLuint program, GLsizei uniformCount, const GLuint *uniformIndices, GLenum pname, GLint *params )
215 GLuint glGetUniformBlockIndex ( GLuint program, const GLchar *uniformBlockName )
216 void glGetActiveUniformBlockiv ( GLuint program, GLuint uniformBlockIndex, GLenum pname, GLint *params )
217 // void glGetActiveUniformBlockName ( GLuint program, GLuint uniformBlockIndex, GLsizei bufSize, GLsizei *length, GLchar *uniformBlockName )
218 void glUniformBlockBinding ( GLuint program, GLuint uniformBlockIndex, GLuint uniformBlockBinding )
219 void glDrawArraysInstanced ( GLenum mode, GLint first, GLsizei count, GLsizei instanceCount )
220 void glDrawElementsInstanced ( GLenum mode, GLsizei count, GLenum type, const GLvoid *indices, GLsizei instanceCount )
221 GLsync glFenceSync ( GLenum condition, GLbitfield flags )
222 GLboolean glIsSync ( GLsync sync )
223 void glDeleteSync ( GLsync sync )
224 GLenum glClientWaitSync ( GLsync sync, GLbitfield flags, GLuint64 timeout )
225 void glWaitSync ( GLsync sync, GLbitfield flags, GLuint64 timeout )
226 void glGetInteger64v ( GLenum pname, GLint64 *params )
227 void glGetSynciv ( GLsync sync, GLenum pname, GLsizei bufSize, GLsizei *length, GLint *values )
228 void glGetInteger64i_v ( GLenum target, GLuint index, GLint64 *data )
229 void glGetBufferParameteri64v ( GLenum target, GLenum pname, GLint64 *params )
230 void glGenSamplers ( GLsizei count, GLuint *samplers )
231 void glDeleteSamplers ( GLsizei count, const GLuint *samplers )
232 GLboolean glIsSampler ( GLuint sampler )
233 void glBindSampler ( GLuint unit, GLuint sampler )
234 void glSamplerParameteri ( GLuint sampler, GLenum pname, GLint param )
235 void glSamplerParameteriv ( GLuint sampler, GLenum pname, const GLint *param )
236 void glSamplerParameterf ( GLuint sampler, GLenum pname, GLfloat param )
237 void glSamplerParameterfv ( GLuint sampler, GLenum pname, const GLfloat *param )
238 void glGetSamplerParameteriv ( GLuint sampler, GLenum pname, GLint *params )
239 void glGetSamplerParameterfv ( GLuint sampler, GLenum pname, GLfloat *params )
240 void glVertexAttribDivisor ( GLuint index, GLuint divisor )
241 void glBindTransformFeedback ( GLenum target, GLuint id )
242 void glDeleteTransformFeedbacks ( GLsizei n, const GLuint *ids )
243 void glGenTransformFeedbacks ( GLsizei n, GLuint *ids )
244 GLboolean glIsTransformFeedback ( GLuint id )
245 void glPauseTransformFeedback ( void )
246 void glResumeTransformFeedback ( void )
247 void glGetProgramBinary ( GLuint program, GLsizei bufSize, GLsizei *length, GLenum *binaryFormat, GLvoid *binary )
248 void glProgramBinary ( GLuint program, GLenum binaryFormat, const GLvoid *binary, GLsizei length )
249 void glProgramParameteri ( GLuint program, GLenum pname, GLint value )
250 void glInvalidateFramebuffer ( GLenum target, GLsizei numAttachments, const GLenum *attachments )
251 void glInvalidateSubFramebuffer ( GLenum target, GLsizei numAttachments, const GLenum *attachments, GLint x, GLint y, GLsizei width, GLsizei height )
252 void glTexStorage2D ( GLenum target, GLsizei levels, GLenum internalformat, GLsizei width, GLsizei height )
253 void glTexStorage3D ( GLenum target, GLsizei levels, GLenum internalformat, GLsizei width, GLsizei height, GLsizei depth )
254 void glGetInternalformativ ( GLenum target, GLenum internalformat, GLenum pname, GLsizei bufSize, GLint *params )