OSDN Git Service

* cgen-cpu.h: Update for new location of cgen/bitset.h.
[pf3gnuchains/pf3gnuchains4x.git] / sid / sid.spec
1 # -*- Mode:rpm-spec -*-
2 # sid.spec
3 #
4 # RPM build instructions (assuming rpm 4.0 or greater):
5 #
6 # In your home directory:
7 # =======================
8 #
9 # 1) Create a directory, rpm-build, containing the following sub-directories:
10 #
11 #       BUILD INSTALL RPMS SOURCES SPECS SRPMS
12 #
13 # 2) Create or modify the ~/.rpmmacros file, adding the following lines:
14 #
15 #       %_topdir                $(absolute path of your home dir)/rpm-build
16 #    
17 #    This tells rpm to use ~/rpm-build as its "home base" rather than the default
18 #    /usr/src/redhat.  Otherwise, you'd have to be root to build the rpms.
19 #
20 # In the SOURCES sub-directory:
21 # =============================
22 #
23 # 3) Check out the sid-without-tcl module from CVS.
24 #
25 # 4) Create a tarball named sid.tar.gz from the CVS tree:
26 #
27 #       tar --create --file=sid.tar src
28 #       gzip sid.tar
29 #
30 # 5) Copy this spec file (sid/sid.spec) into the SPECS sub-directory.
31 #
32 # In the spec file:
33 # =================
34 #
35 # 6) Change the homedir definition to point to your home directory.
36 #
37 # 7) Modify the BuildArchitectures tag and the build commands to reflect
38 #    the host and target for which you're building.
39 #
40 # In the SPECS sub-directory:
41 # ===========================
42 #
43 # 8) Build the RPM:
44 #
45 #       rpm -ba sid.spec
46 #
47 # The resulting RPM and source RPM will be in the RPMS and SRPMS sub-directories respectively.
48 #
49
50 %define homedir /home/fitzsim
51 %define sourcesdir src
52
53 Summary: SID is a framework for building computer system simulations.
54 Name: sid
55 Version: 0.1
56 Release: 1
57 Copyright: GPL
58 Group: Development/Simulators
59 Source: sid.tar.gz
60 URL: http://sources.redhat.com/sid
61 Prefix: /usr
62 BuildRoot: %{homedir}/rpm-build/INSTALL
63 BuildArchitectures: i686
64 BuildRequires: tcl >= 8.0, tk >= 8.0
65 Requires: tcl >= 8.0, tk >= 8.0
66 Packager: Thomas Fitzsimmons <fitzsim@redhat.com>
67 %description 
68 SID is a framework for building computer system simulations.
69 Specifically, a simulation is comprised of a collection of loosely
70 coupled components. Simulated systems may range from a CPU's
71 instruction set to a large multi-processor embedded system.
72
73 SID defines a small component interface which serves to tightly
74 encapsulate components.  Components may be written in C++, C, Tcl or
75 any other language to which the API is bound.  Typically, components
76 are separately compiled and packaged into shared libraries.  A
77 standard run-time linking/loading interface is defined for these.
78
79 %prep
80 %setup -n %{sourcesdir}
81
82 %build
83 cd ..
84 rm -rf bld
85 mkdir bld
86 cd bld
87 ../%{sourcesdir}/configure --prefix=$RPM_BUILD_ROOT/usr
88 make
89
90 %install
91 # To make things work with BUILDROOT
92 if [ "$RPM_BUILD_ROOT" != "%{homedir}/rpm-build/INSTALL" ]
93 then
94   echo
95   echo @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
96   echo @                                                                    @
97   echo @  RPM_BUILD_ROOT is not what I expected.  Please clean it yourself. @
98   echo @                                                                    @
99   echo @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
100   echo
101 else
102   echo Cleaning RPM_BUILD_ROOT: "$RPM_BUILD_ROOT"
103   rm -rf $RPM_BUILD_ROOT
104 fi
105 cd ..
106 cd bld
107 make install
108
109 %files
110 %defattr(-,root,root)
111 /usr/bin/arm-elf-sid
112 /usr/bin/i386-elf-sid
113 /usr/bin/configrun-sid
114 /usr/bin/m68k-elf-sid
115 /usr/bin/m32r-elf-sid
116 /usr/bin/mt-elf-sid
117 /usr/bin/sh-elf-sid
118 /usr/bin/sh5-elf-sid
119 /usr/bin/sh64-elf-sid
120 /usr/bin/xstormy16-elf-sid
121 /usr/bin/sid
122 /usr/bin/siddoc
123
124 /usr/include/sidcomp.h
125 /usr/include/sidso.h
126 /usr/include/sidtypes.h
127
128 /usr/lib/sidcomp
129 /usr/lib/sidsamples
130
131 /usr/share/sid
132
133 /usr/share/sidcomp
134
135 /usr/share/sidsamples
136
137 %doc ../%{sourcesdir}/sid/COPYING
138 %doc ../%{sourcesdir}/sid/COPYING.SID