OSDN Git Service

Fix no pic
[uclinux-h8/uClinux-dist.git] / user / logrotate / logrotate.spec
1 Summary: Rotates, compresses, removes and mails system log files
2 Name: logrotate
3 Version: 3.7.7
4 Release: 1
5 License: GPL+
6 Group: System Environment/Base
7 Source: https://fedorahosted.org/releases/l/o/logrotate/logrotate-%{version}.tar.gz
8 Requires: coreutils >= 5.92 libsepol libselinux popt
9 BuildRequires: libselinux-devel popt-devel
10 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
11
12 %description
13 The logrotate utility is designed to simplify the administration of
14 log files on a system which generates a lot of log files.  Logrotate
15 allows for the automatic rotation compression, removal and mailing of
16 log files.  Logrotate can be set to handle a log file daily, weekly,
17 monthly or when the log file gets to a certain size.  Normally,
18 logrotate runs as a daily cron job.
19
20 Install the logrotate package if you need a utility to deal with the
21 log files on your system.
22
23 %prep
24 %setup -q
25
26 %build
27 make %{?_smp_mflags} RPM_OPT_FLAGS="$RPM_OPT_FLAGS" WITH_SELINUX=yes
28
29 %install
30 rm -rf $RPM_BUILD_ROOT
31 make PREFIX=$RPM_BUILD_ROOT MANDIR=%{_mandir} install
32 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d
33 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/cron.daily
34 mkdir -p $RPM_BUILD_ROOT/%{_localstatedir}/lib
35
36 install -p -m 644 examples/logrotate-default $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.conf
37 install -p -m 755 examples/logrotate.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.daily/logrotate
38 touch $RPM_BUILD_ROOT/%{_localstatedir}/lib/logrotate.status
39
40 %clean
41 rm -rf $RPM_BUILD_ROOT
42
43 %files
44 %defattr(-,root,root)
45 %doc CHANGES COPYING
46 %attr(0755, root, root) %{_sbindir}/logrotate
47 %attr(0644, root, root) %{_mandir}/man8/logrotate.8*
48 %attr(0755, root, root) %{_sysconfdir}/cron.daily/logrotate
49 %attr(0644, root, root) %config(noreplace) %{_sysconfdir}/logrotate.conf
50 %attr(0755, root, root) %dir %{_sysconfdir}/logrotate.d
51 %attr(0644, root, root) %verify(not size md5 mtime) %config(noreplace) %{_localstatedir}/lib/logrotate.status
52
53 %changelog
54 * Wed May 14 2008 Tomas Smetana <tsmetana@redhat.com> 3.7.7-1
55 - new upstream version
56
57 * Tue Aug 07 2007 Tomas Smetana <tsmetana@redhat.com> 3.7.6-1
58 - new upstream version
59
60 * Thu Mar 01 2007 Peter Vrabec <pvrabec@redhat.com> 3.7.5-1
61 - new upstream release.
62
63 * Fri Feb 09 2007 Peter Vrabec <pvrabec@redhat.com> 3.7.4-13
64 - another spec file fixes (#226104)
65
66 * Thu Feb 08 2007 Peter Vrabec <pvrabec@redhat.com> 3.7.4-12
67 - fix problem with compress_options_list (#227706)
68 - fix spec file to meet Fedora standards (#226104)
69
70 * Tue Jan 23 2007 Peter Vrabec <pvrabec@redhat.com> 3.7.4-11
71 - logrotate won't stop if there are some errors in configuration
72   or glob failures (#166510, #182062)
73
74 * Wed Jan 10 2007 Peter Vrabec <pvrabec@redhat.com> 3.7.4-10
75 - fix some rpmlint issues
76
77 * Tue Jan 09 2007 Peter Vrabec <pvrabec@redhat.com> 3.7.4-9
78 - allow multibyte characters in readPath() (#122145)
79
80 * Fri Jan 05 2007 Peter Vrabec <pvrabec@redhat.com> 3.7.4-8
81 - "size" option was ignored in config files (#221341)
82
83 * Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 3.7.4-7
84 - rebuilt for unwind info generation, broken in gcc-4.1.1-21
85
86 * Tue Sep 26 2006 Peter Vrabec <pvrabec@redhat.com> 3.7.4-6
87 - fix leaking file descriptor (#205072)
88
89 * Wed Aug 09 2006 Dan Walsh <dwalsh@redhat.com> 3.7.4-5
90 - Use selinux raw functions
91
92 * Mon Jul 24 2006 Peter Vrabec <pvrabec@redhat.com> 3.7.4-4
93 - make error message, about ignoring certain config files,
94   a debug message instead (#196052)
95
96 * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 3.7.4-3.1
97 - rebuild
98
99 * Tue Jun 13 2006 Peter Vrabec <pvrabec@redhat.com> 3.7.4-3
100 - rename ENOSUP to ENOTSUP
101
102 * Tue Jun 13 2006 Peter Vrabec <pvrabec@redhat.com> 3.7.4-2
103 - clean up a couple of SELinux problems. Patch from Daniel J. Walsh.
104
105 * Wed May 17 2006 Peter Vrabec <pvrabec@redhat.com> 3.7.4-1
106 - add new "minsize" option (#173088)
107
108 * Tue Mar 28 2006 Peter Vrabec <pvrabec@redhat.com> 3.7.3-3
109 - correct man page "extension" option description  (#185318)
110
111 * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 3.7.3-2.2.1
112 - bump again for double-long bug on ppc(64)
113
114 * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 3.7.3-2.2
115 - rebuilt for new gcc4.1 snapshot and glibc changes
116
117 * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
118 - rebuilt
119
120 * Sun Nov 13 2005 Peter Vrabec <pvrabec@redhat.com> 3.7.3-2
121 - fix_free_segfaults (#172918)
122
123 * Sat Nov 12 2005 Peter Vrabec <pvrabec@redhat.com> 3.7.3-1
124 - new upstream release
125 - indent sources
126
127 * Fri Nov 11 2005 Peter Vrabec <pvrabec@redhat.com> 3.7.2-12
128 - fix_free_segfaults (#172918)
129
130 * Mon Nov 07 2005 Peter Vrabec <pvrabec@redhat.com> 3.7.2-11
131 - man description for "nodateext" option (#171577)
132 - remove not working "pattern" option (#171577)
133
134 * Tue Oct 25 2005 Peter Vrabec <pvrabec@redhat.com> 3.7.2-10
135 - some more clean up (#171587)
136
137 * Thu Oct 20 2005 Peter Vrabec <pvrabec@redhat.com> 3.7.2-9
138 - fix_free_segfaults (#171093)
139
140 * Tue Oct 18 2005 Peter Vrabec <pvrabec@redhat.com> 3.7.2-8
141 - fix leaks of tabooExts
142
143 * Sat Oct 15 2005 Peter Vrabec <pvrabec@redhat.com> 3.7.2-7
144 - fix_free_segfaults (#170904)
145
146 * Wed Oct 12 2005 Peter Vrabec <pvrabec@redhat.com> 3.7.2-6
147 - code clean up (#169885)
148
149 * Mon Oct 10 2005 Peter Vrabec <pvrabec@redhat.com> 3.7.2-5
150 - fix bug introduced in logrotate 3.7.2-3(#169858)
151 - fix some memory leaks (#169888)
152
153 * Fri Sep 23 2005 Peter Vrabec <pvrabec@redhat.com> 3.7.2-4
154 - do not run compression program in debug mode (#166912)
155
156 * Wed Sep 07 2005 Peter Vrabec <pvrabec@redhat.com> 3.7.2-3
157 - even when sharedscript option used, do postrotate 
158   script before compress (#167575)
159
160 * Wed Aug 17 2005 Peter Vrabec <pvrabec@redhat.com> 3.7.2-2
161 - allow yearly rotations(#134612)
162
163 * Mon Aug 01 2005 Peter Vrabec <pvrabec@redhat.com> 3.7.2-1
164 - new upstream release
165
166 * Tue Jul 26 2005 Peter Vrabec <pvrabec@redhat.com> 3.7.1-14
167 - fix some "error running script" messages
168
169 * Tue Jul 26 2005 Peter Vrabec <pvrabec@redhat.com> 3.7.1-13
170 - fix man page (#163458,#163366)
171
172 * Wed Jun 22 2005 Peter Vrabec <pvrabec@redhat.com> 3.7.1-12
173 - enhance logrotate with "dateext", "maxage"
174
175 * Thu Mar 31 2005 Dan Walsh <dwalsh@redhat.com> 3.7.1-10
176 - use security_getenforce() instead of selinux_getenforcemode
177
178 * Thu Mar 17 2005 Dan Walsh <dwalsh@redhat.com> 3.7.1-9
179 - Add selinux_getenforce() calls to work when not in enforcing mode
180
181 * Thu Mar 17 2005 Peter Vrabec <pvrabec@redhat.com> 3.7.1-8
182 - rebuild
183
184 * Tue Feb 22 2005 Peter Vrabec <pvrabec@redhat.com>
185 - do not use tmpfile to run script anymore (#149270)
186
187 * Fri Feb 18 2005 Peter Vrabec <pvrabec@redhat.com>
188 - remove logrotate-3.7.1-share.patch, it doesn't solve (#140353)
189
190 * Mon Dec 13 2004 Peter Vrabec <pvrabec@redhat.com> - 3.7.1-5
191 - Add section to logrotate.conf for "/var/log/btmp" (#117844)
192
193 * Mon Dec 13 2004 Peter Vrabec <pvrabec@redhat.com> - 3.7.1-4
194 - Typo and missing information in man page (#139346)
195
196 * Mon Dec 06 2004 Peter Vrabec <pvrabec@redhat.com> - 3.7.1-3
197 - compressed logfiles and logrotate (#140353)
198
199 * Tue Oct 19 2004 Miloslav Trmac <mitr@redhat.com> - 3.7.1-2
200 - Fix sending mails (#131583)
201 - Preserve file attributes when compressing files (#121523, original patch by
202   Daniel Himler)
203
204 * Fri Jul 16 2004 Elliot Lee <sopwith@redhat.com> 3.7.1-1
205 - Fix #126490 typo
206
207 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
208 - rebuilt
209
210 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
211 - rebuilt
212
213 * Mon Jan 26 2004 Dan Walsh <dwalsh@redhat.com> 3.6.10-4
214 - fix is_selinux_enabled call
215
216 * Fri Sep 5 2003 Dan Walsh <dwalsh@redhat.com> 3.6.10-3
217 - Turn off selinux
218
219 * Fri Sep 5 2003 Dan Walsh <dwalsh@redhat.com> 3.6.10-2.sel
220 - Turn on selinux
221
222 * Wed Aug 06 2003 Erik Troan <ewt@redhat.com>
223 - always use compressext for the extension for compressed
224   files; before compresscmd and compressext had to agree
225 - moved all compression to one code block
226 - compression, scripts don't use system() anymore
227 - compress and maillast didn't work together properly
228 - delaycompress and mailfirst didn't work properly
229 - don't use system() for mailing (or uncompressing) logs anymore
230 - use "-s" for speciying the subjected of mailed logs
231
232 * Thu Jul 24 2003 Elliot Lee <sopwith@redhat.com> 3.6.10-1
233 - Fix #100546, change selinux port.
234
235 * Wed Jul 18 2003 Dan Walsh <dwalsh@redhat.com> 3.6.9-2
236 - Port to SELinux 2.5
237
238 * Wed Jul 09 2003 Elliot Lee <sopwith@redhat.com> 3.6.9-1
239 - Fix #90229, #90274, #89458, #91408
240
241 * Mon Jan 20 2003 Elliot Lee <sopwith@redhat.com> 3.6.8-1
242 - Old patch from pm@debian.org
243
244 * Tue Jan 14 2003 Elliot Lee <sopwith@redhat.com> 3.6.7-1
245 - Fixes from bugzilla
246
247 * Fri Nov 15 2002 Elliot Lee <sopwith@redhat.com> 3.6.6-1
248 - Commit patch from Fidelis Assis <fidelis@embratel.net.br>
249
250 * Thu Jun 20 2002 Elliot Lee <sopwith@redhat.com> 3.6.5-1
251 - Commit fix for #65299
252
253 * Mon Apr 15 2002 Elliot Lee <sopwith@redhat.com> 3.6.4-1
254 - Commit fix for #62560
255
256 * Wed Mar 13 2002 Elliot Lee <sopwith@redhat.com> 3.6.3-1
257 - Apply various bugfix patches from the openwall people
258
259 * Tue Jan 29 2002 Elliot Lee <sopwith@redhat.com> 3.6.2-1
260 - Fix bug #55809 (include logrotate.status in "files")
261 - Fix bug #58328 (incorrect error detection when reading state file)
262 - Allow 'G' size specifier from bug #57242
263
264 * Mon Dec 10 2001 Preston Brown <pbrown@redhat.com>
265 - noreplace config file
266
267 * Wed Nov 28 2001 Preston Brown <pbrown@redhat.com> 3.6-1
268 - patch from Alexander Kourakos <awk@awks.org> to stop the shared
269   postrotate/prerotate scripts from running if none of the log(s) need
270   rotating.  All log files are now checked for rotation in one batch,
271   rather than sequentially.
272 - more fixes from Paul Martin <pm@debian.org>
273
274 * Thu Nov  8 2001 Preston Brown <pbrown@redhat.com> 3.5.10-1
275 - fix from paul martin <pm@debian.org> for zero-length state files
276
277 * Tue Sep  4 2001 Preston Brown <pbrown@redhat.com>
278 - fix segfault when logfile is in current directory.
279
280 * Tue Aug 21 2001 Preston Brown <pbrown@redhat.com>
281 - fix URL for source location
282
283 * Thu Aug  2 2001 Preston Brown <pbrown@redhat.com>
284 - man page cleanups, check for negative rotation counts
285
286 * Mon Jul  2 2001 Preston Brown <pbrown@redhat.com>
287 - more minor manpage updates (#45625)
288
289 * Thu Jun 21 2001 Preston Brown <pbrown@redhat.com> 3.5.6-1
290 - enable LFS support (debian bug #100810)
291 - quote filenames for running compress commands or pre/postrotate cmds (#21348)
292 - deprecate "errors" directive (see bug #16544 for explanation)
293 - update man page
294 - configurable compression command by Colm Buckley <colm@tuatha.org>
295
296 * Fri Jun  1 2001 Preston Brown <pbrown@redhat.com> 3.5.5-1
297 - be less strict about whitespace near filenames.  Patch from Paul Martin <pm@debian.org>.
298
299 * Thu Jan  4 2001 Bill Nottingham <notting@redhat.com>
300 - %%defattr
301
302 * Wed Jan 03 2001 Preston Brown <pbrown@redhat.com>
303 - see CHANGES
304
305 * Tue Aug 15 2000 Erik Troan <ewt@redhat.com>
306 - see CHANGES
307
308 * Sun Jul 23 2000 Erik Troan <ewt@redhat.com>
309 - see CHANGES
310
311 * Tue Jul 11 2000 Erik Troan <ewt@redhat.com>
312 - support spaces in filenames
313 - added sharedscripts
314
315 * Sun Jun 18 2000 Matt Wilson <msw@redhat.com>
316 - use %%{_mandir} for man pages
317
318 * Thu Feb 24 2000 Erik Troan <ewt@redhat.com>
319 - don't rotate lastlog
320
321 * Thu Feb 03 2000 Erik Troan <ewt@redhat.com>
322 - gzipped manpages