OSDN Git Service

import original 0.9.5 release
[handbrake-jp/handbrake-jp.git] / gtk / ghb.spec
index 5b83853..d217903 100644 (file)
@@ -1,5 +1,3 @@
-%define name HandBrake
-%define release 1
 
 Name:          %{name}
 Version:       %{version}
@@ -7,17 +5,19 @@ Release:      %{release}%{?dist}
 Summary:       A program to transcode DVDs and other sources to MPEG-4
 
 Group:         Applications/Multimedia
-License:       GPL
+License:       GPLv2
 URL:           http://handbrake.fr/
-Vendor:                The HandBrake Project
 Source0:       %{name}-%{version}.tar.bz2
 Prefix:                %{_prefix}
-BuildRoot:     %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-Requires:      glib2 >= 2.16, gtk2 >= 2.12, hal-libs, webkitgtk, gstreamer
-Requires:      gstreamer-plugins-base
+BuildRoot:     %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
+BuildRequires: glib2-devel, gtk2-devel, webkitgtk-devel
+BuildRequires: gstreamer-devel, gstreamer-plugins-base-devel, libgudev1-devel
+Requires:      gtk2, coreutils
+
+%define debug_package %{nil}
 
 %description
-HandBrake is an open-source, GPL-licensed, multiplatform, multithreaded 
+HandBrake is an open-source, GPL-licensed, multi-platform, multi-threaded 
 transcoder, available for MacOS X, Linux and Windows.
 
 %package gui
@@ -29,34 +29,31 @@ Summary:    A program to transcode DVDs and other sources to MPEG-4
 Group:         Applications/Multimedia
 
 %description gui
-HandBrake is an open-source, GPL-licensed, multiplatform, multithreaded 
+HandBrake is an open-source, GPL-licensed, multi-platform, multi-threaded 
 transcoder, available for MacOS X, Linux and Windows.
 
 %description cli
-HandBrake is an open-source, GPL-licensed, multiplatform, multithreaded 
+HandBrake is an open-source, GPL-licensed, multi-platform, multi-threaded 
 transcoder, available for MacOS X, Linux and Windows.
 
 %prep
-%setup -n %{name}-%{version} -D -T
-#%setup -q
-#cd %{_builddir}/%{name}-%{version}
+%setup -q
+cd %{_builddir}/%{name}-%{version}
 
 
 %build
-#./configure --prefix=%{_prefix}
-#make -C build
+./configure --debug=std --prefix=%{_prefix}
+make %{?_smp_mflags} -C build
 
 
 %install
-#rm -rf $RPM_BUILD_ROOT
-# I don't want to rebuild the world, so just install what I've prebuilt
-make -C $RPM_BUILD_ROOT/../.. DESTDIR=$RPM_BUILD_ROOT install
+make -C build DESTDIR=$RPM_BUILD_ROOT install-strip
 
 ## blow away stuff we don't want
 /bin/rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
 
 %clean
-rm -rf $RPM_BUILD_ROOT
+rm -rf %{buildroot}
 
 %post gui
 touch --no-create %{_datadir}/icons/hicolor
@@ -73,7 +70,7 @@ fi
 %files gui
 %defattr(-,root,root,-)
 %doc NEWS AUTHORS CREDITS THANKS COPYING
-%{_datadir}/icons
+%{_datadir}/icons/hicolor
 %{_datadir}/applications
 %{_bindir}/ghb
 
@@ -83,7 +80,7 @@ fi
 %{_bindir}/HandBrakeCLI
 
 %changelog
-* Sat May 31 2008 John Stebbins <jstebbins@jetheaddev.com> 
-- Initial release
+* Sun Apr 11 2010 John Stebbins <jstebbins@jetheaddev.com> - svn
+- Snapshot release