OSDN Git Service

xray-core: Update to 1.5.1 xray-1.5.1
authorTianling Shen <cnsztl@immortalwrt.org>
Sat, 18 Dec 2021 19:09:53 +0000 (03:09 +0800)
committerTianling Shen <cnsztl@immortalwrt.org>
Sat, 18 Dec 2021 20:24:03 +0000 (04:24 +0800)
Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
xray-core/Makefile
xray-core/patches/010-fix-unsupported-cipher-method-xChaCha20-IETF-Poly1305.patch [new file with mode: 0644]

index eaf77d3..3172b75 100644 (file)
@@ -5,12 +5,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=Xray-core
-PKG_VERSION:=1.4.5
+PKG_VERSION:=1.5.1
 PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/XTLS/Xray-core/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=54c6a687dd463b25afe8d8eb44d37e18b8177f58308207cd1d74f6cd04619854
+PKG_HASH:=11b01de5da7efed2a5f066b14bfe5e0299071dc8c32b7f64af5c51daf3abc6c2
 
 PKG_MAINTAINER:=Tianling Shen <cnsztl@immortalwrt.org>
 PKG_LICENSE:=MPL-2.0
diff --git a/xray-core/patches/010-fix-unsupported-cipher-method-xChaCha20-IETF-Poly1305.patch b/xray-core/patches/010-fix-unsupported-cipher-method-xChaCha20-IETF-Poly1305.patch
new file mode 100644 (file)
index 0000000..c535b4c
--- /dev/null
@@ -0,0 +1,20 @@
+From c8e2a99e68109b386c541dcc157f1f64ca8cbd17 Mon Sep 17 00:00:00 2001
+From: xqzr <34030394+xqzr@users.noreply.github.com>
+Date: Fri, 17 Dec 2021 00:25:16 +0800
+Subject: [PATCH] fix unsupported cipher method: xChaCha20-IETF-Poly1305
+
+---
+ infra/conf/shadowsocks.go | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/infra/conf/shadowsocks.go
++++ b/infra/conf/shadowsocks.go
+@@ -59,7 +59,7 @@ func (v *ShadowsocksServerConfig) Build(
+                               return nil, newError("Shadowsocks password is not specified.")
+                       }
+                       if account.CipherType < shadowsocks.CipherType_AES_128_GCM ||
+-                              account.CipherType > shadowsocks.CipherType_CHACHA20_POLY1305 {
++                              account.CipherType > shadowsocks.CipherType_XCHACHA20_POLY1305 {
+                               return nil, newError("unsupported cipher method: ", user.Cipher)
+                       }
+                       config.Users = append(config.Users, &protocol.User{