OSDN Git Service

v2raya: drop redudant patches
authorTianling Shen <cnsztl@immortalwrt.org>
Fri, 3 Mar 2023 03:51:31 +0000 (11:51 +0800)
committerTianling Shen <cnsztl@immortalwrt.org>
Fri, 3 Mar 2023 03:51:45 +0000 (11:51 +0800)
Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
v2raya/Makefile
v2raya/patches/010-fixed-for-Docker-Compose.patch [deleted file]
v2raya/patches/011-cleaned-up.patch [deleted file]
v2raya/patches/012-improved.patch [deleted file]
v2raya/patches/013-fix-we-should-skip-interface-ppp-to-avoid-to-break-net.patch
v2raya/patches/019-fix-tproxy-cannot-work-on-openwrt-ifname-is-br-lan.patch [deleted file]

index a6c5e67..fd6788f 100644 (file)
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=v2rayA
 PKG_VERSION:=1.5.9.1698.1
-PKG_RELEASE:=7
+PKG_RELEASE:=8
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/v2rayA/v2rayA/tar.gz/v$(PKG_VERSION)?
diff --git a/v2raya/patches/010-fixed-for-Docker-Compose.patch b/v2raya/patches/010-fixed-for-Docker-Compose.patch
deleted file mode 100644 (file)
index 8461660..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
-From 78336e55a31db578c139a5bb472aa0fc219c169d Mon Sep 17 00:00:00 2001
-From: Xiaoxu Guo <ftiasch0@gmail.com>
-Date: Thu, 4 Aug 2022 16:24:04 +0800
-Subject: [PATCH] fixed for Docker Compose
-
----
- service/core/iptables/tproxy.go | 7 +++++--
- 1 file changed, 5 insertions(+), 2 deletions(-)
-
---- a/core/iptables/tproxy.go
-+++ b/core/iptables/tproxy.go
-@@ -65,6 +65,7 @@ iptables -w 2 -t mangle -A TP_PRE -p udp
- iptables -w 2 -t mangle -A TP_RULE -j CONNMARK --restore-mark
- iptables -w 2 -t mangle -A TP_RULE -m mark --mark 0x40/0xc0 -j RETURN
-+iptables -w 2 -t mangle -A TP_RULE -i br+ -j RETURN
- iptables -w 2 -t mangle -A TP_RULE -i docker+ -j RETURN
- iptables -w 2 -t mangle -A TP_RULE -i veth+ -j RETURN
- `
-@@ -123,6 +124,8 @@ ip6tables -w 2 -t mangle -A TP_PRE -p ud
- ip6tables -w 2 -t mangle -A TP_RULE -j CONNMARK --restore-mark
- ip6tables -w 2 -t mangle -A TP_RULE -m mark --mark 0x40/0xc0 -j RETURN
-+ip6tables -w 2 -t mangle -A TP_RULE -m mark --mark 0x40/0xc0 -j RETURN
-+ip6tables -w 2 -t mangle -A TP_RULE -i br+ -j RETURN
- ip6tables -w 2 -t mangle -A TP_RULE -i docker+ -j RETURN
- ip6tables -w 2 -t mangle -A TP_RULE -i veth+ -j RETURN
- `
-@@ -156,7 +159,7 @@ ip6tables -w 2 -t mangle -A TP_MARK -j C
- func (t *tproxy) GetCleanCommands() Setter {
-       commands := `
--ip rule del fwmark 0x40/0xc0 table 100 
-+ip rule del fwmark 0x40/0xc0 table 100
- ip route del local 0.0.0.0/0 dev lo table 100
- iptables -w 2 -t mangle -F TP_OUT
-@@ -172,7 +175,7 @@ iptables -w 2 -t mangle -X TP_MARK
- `
-       if IsIPv6Supported() {
-               commands += `
--ip -6 rule del fwmark 0x40/0xc0 table 100 
-+ip -6 rule del fwmark 0x40/0xc0 table 100
- ip -6 route del local ::/0 dev lo table 100
- ip6tables -w 2 -t mangle -F TP_OUT
diff --git a/v2raya/patches/011-cleaned-up.patch b/v2raya/patches/011-cleaned-up.patch
deleted file mode 100644 (file)
index 74dc502..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-From 0db405f50fd652d494f2066fc5e47c41666c96db Mon Sep 17 00:00:00 2001
-From: Xiaoxu Guo <ftiasch0@gmail.com>
-Date: Thu, 4 Aug 2022 16:32:42 +0800
-Subject: [PATCH] cleaned up
-
----
- service/core/iptables/tproxy.go | 5 ++---
- 1 file changed, 2 insertions(+), 3 deletions(-)
-
---- a/core/iptables/tproxy.go
-+++ b/core/iptables/tproxy.go
-@@ -124,7 +124,6 @@ ip6tables -w 2 -t mangle -A TP_PRE -p ud
- ip6tables -w 2 -t mangle -A TP_RULE -j CONNMARK --restore-mark
- ip6tables -w 2 -t mangle -A TP_RULE -m mark --mark 0x40/0xc0 -j RETURN
--ip6tables -w 2 -t mangle -A TP_RULE -m mark --mark 0x40/0xc0 -j RETURN
- ip6tables -w 2 -t mangle -A TP_RULE -i br+ -j RETURN
- ip6tables -w 2 -t mangle -A TP_RULE -i docker+ -j RETURN
- ip6tables -w 2 -t mangle -A TP_RULE -i veth+ -j RETURN
-@@ -159,7 +158,7 @@ ip6tables -w 2 -t mangle -A TP_MARK -j C
- func (t *tproxy) GetCleanCommands() Setter {
-       commands := `
--ip rule del fwmark 0x40/0xc0 table 100
-+ip rule del fwmark 0x40/0xc0 table 100 
- ip route del local 0.0.0.0/0 dev lo table 100
- iptables -w 2 -t mangle -F TP_OUT
-@@ -175,7 +174,7 @@ iptables -w 2 -t mangle -X TP_MARK
- `
-       if IsIPv6Supported() {
-               commands += `
--ip -6 rule del fwmark 0x40/0xc0 table 100
-+ip -6 rule del fwmark 0x40/0xc0 table 100 
- ip -6 route del local ::/0 dev lo table 100
- ip6tables -w 2 -t mangle -F TP_OUT
diff --git a/v2raya/patches/012-improved.patch b/v2raya/patches/012-improved.patch
deleted file mode 100644 (file)
index 1c755d0..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-From 4a87a6fc9a17939cc0fc54058b2128b1f688045a Mon Sep 17 00:00:00 2001
-From: Xiaoxu Guo <ftiasch0@gmail.com>
-Date: Thu, 4 Aug 2022 22:56:46 +0800
-Subject: [PATCH] improved
-
----
- service/core/iptables/tproxy.go | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
---- a/core/iptables/tproxy.go
-+++ b/core/iptables/tproxy.go
-@@ -16,7 +16,7 @@ var Tproxy tproxy
- func (t *tproxy) AddIPWhitelist(cidr string) {
-       // avoid duplication
-       t.RemoveIPWhitelist(cidr)
--      pos := 5
-+      pos := 6
-       if configure.GetSettingNotNil().AntiPollution != configure.AntipollutionClosed {
-               pos += 3
-       }
-@@ -65,7 +65,7 @@ iptables -w 2 -t mangle -A TP_PRE -p udp
- iptables -w 2 -t mangle -A TP_RULE -j CONNMARK --restore-mark
- iptables -w 2 -t mangle -A TP_RULE -m mark --mark 0x40/0xc0 -j RETURN
--iptables -w 2 -t mangle -A TP_RULE -i br+ -j RETURN
-+iptables -w 2 -t mangle -A TP_RULE -i br-+ -j RETURN
- iptables -w 2 -t mangle -A TP_RULE -i docker+ -j RETURN
- iptables -w 2 -t mangle -A TP_RULE -i veth+ -j RETURN
- `
-@@ -124,7 +124,7 @@ ip6tables -w 2 -t mangle -A TP_PRE -p ud
- ip6tables -w 2 -t mangle -A TP_RULE -j CONNMARK --restore-mark
- ip6tables -w 2 -t mangle -A TP_RULE -m mark --mark 0x40/0xc0 -j RETURN
--ip6tables -w 2 -t mangle -A TP_RULE -i br+ -j RETURN
-+ip6tables -w 2 -t mangle -A TP_RULE -i br-+ -j RETURN
- ip6tables -w 2 -t mangle -A TP_RULE -i docker+ -j RETURN
- ip6tables -w 2 -t mangle -A TP_RULE -i veth+ -j RETURN
- `
index 0ff5f6a..5de1a86 100644 (file)
@@ -13,13 +13,13 @@ Subject: [PATCH] fix: we should skip interface ppp+ to avoid to break net
  func (t *tproxy) AddIPWhitelist(cidr string) {
        // avoid duplication
        t.RemoveIPWhitelist(cidr)
--      pos := 6
-+      pos := 8
+-      pos := 5
++      pos := 7
        if configure.GetSettingNotNil().AntiPollution != configure.AntipollutionClosed {
                pos += 3
        }
-@@ -68,6 +68,8 @@ iptables -w 2 -t mangle -A TP_RULE -m ma
- iptables -w 2 -t mangle -A TP_RULE -i br-+ -j RETURN
+@@ -67,6 +67,8 @@ iptables -w 2 -t mangle -A TP_RULE -j CO
+ iptables -w 2 -t mangle -A TP_RULE -m mark --mark 0x40/0xc0 -j RETURN
  iptables -w 2 -t mangle -A TP_RULE -i docker+ -j RETURN
  iptables -w 2 -t mangle -A TP_RULE -i veth+ -j RETURN
 +iptables -w 2 -t mangle -A TP_RULE -i ppp+ -j RETURN
@@ -27,8 +27,8 @@ Subject: [PATCH] fix: we should skip interface ppp+ to avoid to break net
  `
        if configure.GetSettingNotNil().AntiPollution != configure.AntipollutionClosed {
                commands += `
-@@ -127,6 +129,8 @@ ip6tables -w 2 -t mangle -A TP_RULE -m m
- ip6tables -w 2 -t mangle -A TP_RULE -i br-+ -j RETURN
+@@ -125,6 +127,8 @@ ip6tables -w 2 -t mangle -A TP_RULE -j C
+ ip6tables -w 2 -t mangle -A TP_RULE -m mark --mark 0x40/0xc0 -j RETURN
  ip6tables -w 2 -t mangle -A TP_RULE -i docker+ -j RETURN
  ip6tables -w 2 -t mangle -A TP_RULE -i veth+ -j RETURN
 +ip6tables -w 2 -t mangle -A TP_RULE -i ppp+ -j RETURN
diff --git a/v2raya/patches/019-fix-tproxy-cannot-work-on-openwrt-ifname-is-br-lan.patch b/v2raya/patches/019-fix-tproxy-cannot-work-on-openwrt-ifname-is-br-lan.patch
deleted file mode 100644 (file)
index d60074b..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
-From 8325b18738061f16eeeef13a2cbe39f9f5cfec91 Mon Sep 17 00:00:00 2001
-From: mzz2017 <2017@duck.com>
-Date: Sat, 11 Feb 2023 22:54:40 +0800
-Subject: [PATCH] fix: tproxy cannot work on openwrt (ifname is br-lan)
-
----
- service/core/iptables/tproxy.go | 4 +---
- 1 file changed, 1 insertion(+), 3 deletions(-)
-
---- a/core/iptables/tproxy.go
-+++ b/core/iptables/tproxy.go
-@@ -16,7 +16,7 @@ var Tproxy tproxy
- func (t *tproxy) AddIPWhitelist(cidr string) {
-       // avoid duplication
-       t.RemoveIPWhitelist(cidr)
--      pos := 8
-+      pos := 7
-       if configure.GetSettingNotNil().AntiPollution != configure.AntipollutionClosed {
-               pos += 3
-       }
-@@ -65,7 +65,6 @@ iptables -w 2 -t mangle -A TP_PRE -p udp
- iptables -w 2 -t mangle -A TP_RULE -j CONNMARK --restore-mark
- iptables -w 2 -t mangle -A TP_RULE -m mark --mark 0x40/0xc0 -j RETURN
--iptables -w 2 -t mangle -A TP_RULE -i br-+ -j RETURN
- iptables -w 2 -t mangle -A TP_RULE -i docker+ -j RETURN
- iptables -w 2 -t mangle -A TP_RULE -i veth+ -j RETURN
- iptables -w 2 -t mangle -A TP_RULE -i ppp+ -j RETURN
-@@ -126,7 +125,6 @@ ip6tables -w 2 -t mangle -A TP_PRE -p ud
- ip6tables -w 2 -t mangle -A TP_RULE -j CONNMARK --restore-mark
- ip6tables -w 2 -t mangle -A TP_RULE -m mark --mark 0x40/0xc0 -j RETURN
--ip6tables -w 2 -t mangle -A TP_RULE -i br-+ -j RETURN
- ip6tables -w 2 -t mangle -A TP_RULE -i docker+ -j RETURN
- ip6tables -w 2 -t mangle -A TP_RULE -i veth+ -j RETURN
- ip6tables -w 2 -t mangle -A TP_RULE -i ppp+ -j RETURN