OSDN Git Service

v2ray-v5-core: add new package
authorTianling Shen <cnsztl@immortalwrt.org>
Mon, 12 Dec 2022 03:31:31 +0000 (11:31 +0800)
committerTianling Shen <cnsztl@immortalwrt.org>
Mon, 12 Dec 2022 03:31:31 +0000 (11:31 +0800)
Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
v2ray-v5-core/Makefile [new file with mode: 0644]
v2ray-v5-core/test.sh [new file with mode: 0644]

diff --git a/v2ray-v5-core/Makefile b/v2ray-v5-core/Makefile
new file mode 100644 (file)
index 0000000..ee5d0b8
--- /dev/null
@@ -0,0 +1,82 @@
+# SPDX-License-Identifier: GPL-3.0-only
+#
+# Copyright (C) 2021 ImmortalWrt.org
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=v2ray-core
+PKG_VERSION:=5.1.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/v2fly/v2ray-core/tar.gz/v$(PKG_VERSION)?
+PKG_HASH:=b3dbd2bbee9486999b81d1968545c5a6caa7b0f4726a7259939f1bda54fcf5ea
+
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+PKG_MAINTAINER:=Tianling Shen <cnsztl@immortalwrt.org>
+
+PKG_BUILD_DEPENDS:=golang/host
+PKG_BUILD_PARALLEL:=1
+PKG_USE_MIPS16:=0
+
+GO_PKG:=github.com/v2fly/v2ray-core/v5
+GO_PKG_BUILD_PKG:=$(GO_PKG)/main
+GO_PKG_LDFLAGS_X:= \
+       $(GO_PKG).build=OpenWrt \
+       $(GO_PKG).version=$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+include $(TOPDIR)/feeds/packages/lang/golang/golang-package.mk
+
+GO_PKG_TARGET_VARS:=$(filter-out CGO_ENABLED=%,$(GO_PKG_TARGET_VARS)) CGO_ENABLED=0
+
+define Package/v2ray-v5/template
+  TITLE:=A platform for building proxies to bypass network restrictions
+  SECTION:=net
+  CATEGORY:=Network
+  URL:=https://www.v2fly.org
+endef
+
+define Package/v2ray-v5-core
+  $(call Package/v2rayv-5/template)
+  DEPENDS:=$(GO_ARCH_DEPENDS) +ca-bundle
+  CONFLICTS:=v2ray-core
+endef
+
+define Package/v2ray-v5-extra
+  $(call Package/v2ray-v5/template)
+  TITLE+= (extra resources)
+  DEPENDS:=v2ray-core
+  PKGARCH:=all
+  CONFLICTS:=v2ray-extra
+endef
+
+define Package/v2ray-v5/description
+  Project V is a set of network tools that help you to build your own computer network.
+  It secures your network connections and thus protects your privacy.
+endef
+
+define Package/v2ray-v5-core/description
+  $(call Package/v2ray-v5/description)
+endef
+
+define Package/v2ray-v5-extra/description
+  $(call Package/v2ray-v5/description)
+
+  This includes extra resources for v2ray-core.
+endef
+
+define Package/v2ray-v5-core/install
+       $(call GoPackage/Package/Install/Bin,$(PKG_INSTALL_DIR))
+       $(INSTALL_DIR) $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/main $(1)/usr/bin/v2ray
+endef
+
+define Package/v2ray-v5-extra/install
+       $(INSTALL_DIR) $(1)/usr/share/v2ray/
+       $(CP) $(PKG_BUILD_DIR)/release/extra/* $(1)/usr/share/v2ray/
+endef
+
+$(eval $(call BuildPackage,v2ray-v5-core))
+$(eval $(call BuildPackage,v2ray-v5-extra))
diff --git a/v2ray-v5-core/test.sh b/v2ray-v5-core/test.sh
new file mode 100644 (file)
index 0000000..ef751a9
--- /dev/null
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+case "$1" in
+       "v2ray-core")
+               v2ray version 2>&1 | grep "$PKG_VERSION"
+               ;;
+esac