OSDN Git Service

v2raya: disable CGO to be compatible with different musl library
authorTianling Shen <cnsztl@immortalwrt.org>
Sun, 19 Dec 2021 16:51:41 +0000 (00:51 +0800)
committerTianling Shen <cnsztl@immortalwrt.org>
Sun, 19 Dec 2021 16:51:41 +0000 (00:51 +0800)
Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
v2raya/Makefile

index 436ba82..feef4b0 100644 (file)
@@ -55,6 +55,8 @@ define Package/v2raya/conffiles
 /etc/config/v2raya
 endef
 
+GO_PKG_TARGET_VARS:=$(filter-out CGO_ENABLED=%,$(GO_PKG_TARGET_VARS)) CGO_ENABLED=0
+
 define Build/Compile
        ( \
                pushd $(PKG_BUILD_DIR)/../gui ; \