OSDN Git Service

Update copyright years.
[android-x86/external-exfat.git] / mkfs / Makefile.am
index d1af1f1..4d3c9d6 100644 (file)
@@ -3,7 +3,7 @@
 #      Automake source.
 #
 #      Free exFAT implementation.
-#      Copyright (C) 2011-2015  Andrew Nayenko
+#      Copyright (C) 2011-2018  Andrew Nayenko
 #
 #      This program is free software; you can redistribute it and/or modify
 #      it under the terms of the GNU General Public License as published by
@@ -21,6 +21,7 @@
 #
 
 sbin_PROGRAMS = mkexfatfs
+dist_man8_MANS = mkexfatfs.8
 mkexfatfs_SOURCES = \
        cbm.c \
        cbm.h \
@@ -39,3 +40,9 @@ mkexfatfs_SOURCES = \
        vbr.h
 mkexfatfs_CPPFLAGS = -I$(top_srcdir)/libexfat
 mkexfatfs_LDADD = ../libexfat/libexfat.a
+
+install-exec-hook:
+       ln -sf $(sbin_PROGRAMS) $(DESTDIR)$(sbindir)/mkfs.exfat
+
+uninstall-hook:
+       rm -f $(DESTDIR)$(sbindir)/mkfs.exfat