はじめに
はじめに

DTXCreatorとは？

  DTXCreator は、DTXファイルを作成するためのGUIエディタです。
   BMSCreator や GDACreator とよく似た操作方法を保ちながら、DTXファイル特有の性質にあわせた効果的な編集が可能です。

DTXCreator の概観

動作環境

  • .NET Framework 2.0 以上とManaged DirectX 1.1 が必須。
  • DTXViewer があると、DTXCreator からテスト再生が可能になります。なくても動作します。

インストールとアンインストール

  • インストール作業は特に必要ありません。そのままご使用下さい。
  • アンインストール時はそのままファイル一式を削除して下さい。レジストリは使用していません。


DTXCreator Reference Manual

画面構成
画面構成

DTXCreator の画面構成

譜面

  ここにチップを配置することで、譜面を作りあげます。

  • 譜面

編集タブ

  曲データに関する基本情報タブ、譜面で使用するサウンドの一覧を持つWAVタブ, 画像の一覧を持つBMPタブ, 動画の一覧を持つAVI タグ、ならびに自由にテキストを入力できる自由入力欄 タブがあります。

  • [基本情報] タブ
  • [WAV] タブ
  • [BMP] タブ
  • [AVI] タブ
  • [自由入力] タブ

メニューバー、ツールバー

  様々な基本機能が並んでいます。

  • メニューバー
  • ツールバー


画面構成
譜面

  譜面では、チップを配置することで演奏データを作り上げます。

画面構成

レーン、レーン名

  チップを配置する列とその名前です。各レーンは、DTXファイルフォーマットの「チャンネル」に対応しています。たとえば、スネアドラムレーン（SD）は、DTXファイルフォーマットのスネアドラムチャンネル（12）に対応しており、ここに配置されたチップはチャンネル12のオブジェクトとして出力されます。

  • BPM - BPMを指定するレーンです。
  • LC, HH, SD, BD, HT, LT, FT, CY - ドラムレーンです。順番に、左シンバル、ハイハットClose、スネア、バス、ハイタム、ロータム、フロアタム、シンバルのチップを配置します。
  • FI - フィルインレーンです。01 のチップを置くとフィルイン開始、02のチップを置くとフィルイン終了を意味します。
  • BGM - BGMレーンです。BGM用のサウンドチップを配置します。チップの発声の前にはそれまで再生されていた直前のサウンドが自動的に消音されます。
  • SE1～SE5 - 効果音レーンです。効果音として鳴らしたいサウンドチップを配置します。チップの発生時にはそれまで再生されていたサウンドを消音しません。（ただし多重再生は１レーン２音まで）
  • AVI - 動画レーンです。動画チップを配置します。
  • BG1～8 - BGAレーンです。それぞれ、８つのBGAレイヤに相当します（BG1が一番下、BG8が一番上のレイヤ）。裏チャンネルはスコープ変更チャンネルに割り当てられています。

  また各レーンは、表チャンネルと裏チャンネルの２種類に対応しており、通常のチップ配置では表チャンネルの、裏チップ配置（Ctrl を押しながらチップを配置する）では裏チャンネルのオブジェクトとして出力されます。

  各レーンの表チャンネルと裏チャンネルの割当は以下のようになります。

 | BPM | LC | HH | SD | BD | HT | LT | FT | CY | FI | BGM | SE1～5 | AVI | BG1 | BG2 | BG3～BG7 | BG8
表Ch. | 08 | 1A | 11 | 12 | 13 | 14 | 15 | 17 | 16 | 53 | 01 | 61～65 | 54 | 04 | 07 | 55～59 | 60
裏Ch. | 08 | 1A | 18 | 12 | 13 | 14 | 15 | 17 | 19 | 53 | 01 | 61～65 | 54 | C4 | C7 | D5～D9 | E0

主なポイント：

  • ハイハットレーン（HH）の表が HH-Close、裏が HH-Open になっています。
  • シンバルレーン（CY）の表が Cymbal 、裏が Ride-Cymbal になっています。
  • BGレーン（BG1～8）の表がレイヤチャンネル、裏がスコープ画像置き換えチャンネルになっています。

小節番号

  小節の番号を示します。小節番号は、000～Z99 まで使用できます。

小節線

  小節同士を区切る線です。

拍線

  １拍（４分音符）に相当する間隔で引かれる線です。小節長が変更された場合も、拍線の表示間隔は変わらず一定です。

ガイド線

  現在の入力解像度を表す線です。チップが配置されるときはガイド線に沿って配置されます。ガイド線の間隔は、メニューバー（[表示(V)]→[ガイド間隔(G)]→…）またはツールバーから変更できます。小節長が変更された場合も、ガイド線の表示間隔は変わらず一定です。


画面構成
[基本情報]タブ

  曲データに関する諸情報の設定を行います。

画面構成

曲名、製作者、コメント
BMP
DrumLv., GuitarLv., BassLv
パネル
プレビュー音
選曲画像
Loading 画像
背景画像
結果画像

曲名、製作者、コメント

  曲データの曲名、製作者名、ならびにコメント文を記述します。
  これらは、DTXManiaの選曲画面で表示されます。

  製作者名としては、DTXファイルの作者ではなく、元になった曲のアーティストの名前（歌手名等）を書くことが主流ですが、別にどっちでもいいです。

BPM

  曲データの演奏速度を BPM (Beats/Minute）で指定します。BPM は”１分間における拍（４分音符）の数”を意味し、数値が大きいほど速い曲になります。
  BPM はここで指定した値が初期値となりますが、譜面の BPx レーンでこれを変更することが出来ます。

DrumLv., GuitarLv., BassLv.

  ドラム、ギター、ベースの難易度を、（易しい）1～100 （難しい）の数値で指定します。
  DTXManiaでは、この数値を設定しなければ演奏可能な譜面として認識されません。

パネル

  DTXMania の演奏画面に表示するコメントを記述します。

  パネル文を記述しなかった場合は、曲名がそのままパネル文として表示されます。

プレビュー音

  選曲画面で曲が選択されているときに演奏される音声ファイル（WAV,XA,MP3,Oggファイル）を指定します。

選曲画像

  選曲画面で曲が選択されているときに表示される画像ファイル（204x269ドットのBMP, PNG, JPEGファイル）を指定します。

Loading画像

  曲が選択されて演奏データがロードされている間に表示する画像（640x480ドットのBMP, JPEG, PNGファイル；それ以上のサイズは右下方からカット）を指定します。

背景画像

  演奏画面の背景となる画像（640x480ドットの BMP, PNG, JPEG ファイル）を指定します。 この画像は、DTXMania の演奏画面と半透明合成されて表示されます。画像サイズが 640x480 より小さい場合には、同じ画像が繰り返し並べて（タイル並びで）表示されます。

結果画像

  結果表示画面で表示する画像（204x269ドットの BMP, PNG, JPEG ファイル）を指定します。これが指定されない時は、選曲画像で指定した画像が表示されます。


画面構成
[WAV]タブ

  WAVタブでは、譜面で使用するサウンドの一覧（WAVリスト）を管理します。
  WAVリストには最大 1295個のサウンド（WAVセル）を含めることができます。WAVセルは 01 ～ ZZ （36進数表記）の番号（No）で区別され、１つのラベル名とファイル名、音量、位置を指定することができます。

  WAVセルのこれらの値の設定方法については、「サウンドプロパティ」の項を参照して下さい。

画面構成

ラベル
No
ファイル
音量
位置
BGM
上移動（ [image] ）
下移動（ [image] ）
試聴（ [image] ）
試聴停止（ [image] ）
試聴有効・無効（ [image] ）

ラベル

  WAVセルに対して付けられている名前（ラベル）を表示します。
  DTXファイルでは、ラベル文字列は、対応する #WAV 命令へのコメント文として出力されます。

No

  WAVセルの番号です。36進数表記で 01～ZZ と表示されます。
  譜面上に描かれるチップは、この番号により区別されます。

ファイル

  WAVセルに対応するサウンドファイル名です。
  作成しているDTXファイルに対する相対パスで表示されます。

音量

  WAVセルの音量をパーセンテージ（0～100 [%]）で指定します。
  サウンドファイルの持つ本来の音量（原音量）を 100% とし、それを越える音量は設定できません。

位置

  WAVセルの再生位置（左；-100 ～ 中央；0 ～ 右；100）を指定します。
  DirectSound を使用しているDTXManiaでは、再生位置の変更は左右のサウンド出力の音量を単純に増減するだけで実現されることにご注意下さい。

BGM

  WAVセルをBGMサウンドとして扱う場合、ここに「○」印が表示されます。

上移動（ ）、下移動（ ）

  現在選択中のWAVセルを、１行上または下へ移動します。
  このとき、そのWAVセルの番号（No）は１つ増加または減少し、同時に、譜面上に配置済みのチップの番号も自動的に修正され、セルの移動に追従します。

試聴（ ）、試聴停止（ ）、試聴有効・無効（ ）

  任意のWAVセルをマウスで左クリックすると、そのサウンドを試聴することができますが、これらのボタンで現在選択中のWAVセルを試聴／試聴停止することもできます。
  試聴有効・無効ボタンで、これらの機能の ON/OFF を行うことができます。


画面構成
[BMP]タブ

  BMPタブでは、譜面で使用する画像の一覧（BMPリスト）を管理します。
  BMPリストには最大 1295個の画像（BMPセル）を含めることができます。BMPセルは 01 ～ ZZ （36進数表記）の番号（No）で区別され、１つのラベル名とファイル名を指定することができます。

  BMPセルのこれらの値の設定方法については、「画像プロパティ」の項を参照して下さい。

サーフェイスとテクスチャ

  BMPには、サーフェイスとして表示されるものとテクスチャとして表示されるものの２種類があります。それぞれには以下のような違いがあります。

 | サーフェイス | テクスチャ
使用技術 | DirectDraw | Direct3D
色の透過 | 完全な黒（RGB=0,0,0）を透過 | アルファ情報に従う
対応フォーマット | bmp, jpeg, png | RGB24bit＋透過情報付きのpngのみ

  テクスチャを使用すると半透明画像を使うことができますが、サイズやビデオメモリ等に機種依存の制限があり、多用することは推奨されません。

画面構成

Tex
ラベル
No
ファイル
上移動（ [image] ）
下移動（ [image] ）

Tex

  BMPセルをテクスチャとして扱う場合、ここに「○」印が表示されます。

ラベル

  BMPセルに対して付けられている名前（ラベル）を表示します。
  DTXファイルでは、ラベル文字列は、対応する #BMP 命令へのコメント文として出力されます。

No

  BMPセルの番号です。36進数表記で 01～ZZ と表示されます。
  譜面上に描かれるチップは、この番号により区別されます。

ファイル

  BMPセルに対応する画像ファイル名です。
  作成しているDTXファイルに対する相対パスで表示されます。

上移動（ ）、下移動（ ）

  現在選択中のBMPセルを、１行上または下へ移動します。
  このとき、そのBMPセルの番号（No）は１つ増加または減少し、同時に、譜面上に配置済みのチップの番号も自動的に修正され、セルの移動に追従します。


画面構成
[AVI]タブ

  AVIタブでは、譜面で使用する動画の一覧（AVIリスト）を管理します。
  AVIリストには最大 1295個の画像（AVIセル）を含めることができます。AVIセルは 01 ～ ZZ （36進数表記）の番号（No）で区別され、１つのラベル名とファイル名を指定することができます。

  AVIセルのこれらの値の設定方法については、「動画プロパティ」の項を参照して下さい。

動画とCODEC

  動画を DTXMania で表示するには、どの動画フォーマットに対応した CODEC をパソコンにインストールしておく必要があります。動画の CODEC には大きく VFW （Video for Windows） 形式と DirectShow 形式のものがありますが、DTXMania では VFW のみ対応しています。

画面構成

ラベル
No
ファイル
上移動（ [image] ）
下移動（ [image] ）

ラベル

  AVIセルに対して付けられている名前（ラベル）を表示します。
  DTXファイルでは、ラベル文字列は、対応する #AVI 命令へのコメント文として出力されます。

No

  AVIセルの番号です。36進数表記で 01～ZZ と表示されます。
  譜面上に描かれるチップは、この番号により区別されます。

ファイル

  AVIセルに対応する動画ファイル名です。
  作成しているDTXファイルに対する相対パスで表示されます。

上移動（ ）、下移動（ ）

  現在選択中のAVIセルを、１行上または下へ移動します。
  このとき、そのAVIセルの番号（No）は１つ増加または減少し、同時に、譜面上に配置済みのチップの番号も自動的に修正され、セルの移動に追従します。


画面構成
[自由入力]タブ

  自由入力タブでは、DTXCreator で対応していない命令やコメント文などを自由に記述することができます。DTXファイルには、ここに記述された文はそのまま出力されます。

画面構成


画面構成
メニューバー

画面構成

ファイル(F)

  • 新規作成(N) - 新しい譜面を作成します。
  • 開く(O) - DTXファイルを読み込みます。
  • 上書き保存(S) - 現在編集中の譜面をDTXファイルとして保存します。
  • 名前を付けて保存(A) - 現在編集中の譜面をDTXファイルとして別の名前をつけて保存します。
  • 終了(X) - DTXCreator を終了します。

  また、ファイルメニューの最下層に、これまでに使用したファイルの一覧が表示されます。

編集(E)

  • 元に戻す(U) - 直前に行った作業を取り消して、元に戻します。
  • やり直す(R) - 元に戻した作業を、もう一度実行しなおします。
  • 切り取り(T) - 現在選択中のチップをクリップボードに切り取ります。選択されているチップが１つもない間は、このメニューは使用できません。
  • コピー(C) - 現在選択中のチップをクリップボードにコピーします。選択されているチップが１つもない間は、このメニューは使用できません。
  • 貼り付け(V) - クリップボードにあるチップ群を、現在表示されている譜面の最下層位置を先頭として貼り付けます。クリップボードにチップがない間は、このメニューは使用できません。
  • 削除(D) - 現在選択中のチップを削除します。選択されているチップが１つもない間は、このメニューは使用できません。
  • すべて選択(A) - 譜面上にあるすべてのチップを選択します。
  • 選択モード(S) - 選択モードに切り替えます。
  • 編集モード(E) - 編集モードに切り替えます。
  • モード切替(M) - 選択モードと編集モードを切り替えます。
  • 検索(F) - 条件をつけてチップを検索します。検索されたチップは選択状態となります。
  • 置換(R) - 現在選択中のチップを、条件をつけて置換します。選択されているチップが１つもない場合は、先にすべてのチップが選択状態にされます。

表示(V)

  • チップパレット(P) - チップパレットの表示のON・OFFを指定します。
  • ガイド間隔(G) - ガイド線の間隔を指定します。

再生(P)

  • 先頭から再生 - DTXViewerで、譜面の先頭から再生を開始します。
  • 現在の位置から再生 - DTXViewer で、現在表示されている譜面の最下層の小節から再生を開始します。
  • 現在の位置からBGMのみ再生 - DTXViewer で、現在表示されている譜面の最下層の小節から再生を開始します。 ただし、BGMサウンド以外のWAVセル（チップ）は発音されません。
  • 再生停止 - DTXViewer が再生中であれば、停止します。

  これらの機能は、DTXViewer が DTXCreator と同じフォルダに存在しない場合は使用できません。

ツール(T)

  • オプション(O) - オプション設定を行う画面を開きます。

ヘルプ(H)

  • DTXCreatorマニュアル(H) - 本ヘルプファイルを表示します。
  • バージョン表示(A) - DTXCreator のバージョン情報を表示します。


画面構成
ツールバー

画面構成

  • 新規作成 - 新しい譜面を作成します。
  • 開く - DTXファイルを読み込みます。
  • 上書き保存 - 現在編集中の譜面をDTXファイルとして保存します。

  • 切り取り - 現在選択中のチップをクリップボードに切り取ります。選択されているチップが１つもない間は、このメニューは使用できません。
  • コピー - 現在選択中のチップをクリップボードにコピーします。選択されているチップが１つもない間は、このメニューは使用できません。
  • 貼り付け - クリップボードにあるチップ群を、現在表示されている譜面の最下層位置を先頭として貼り付けます。クリップボードにチップがない間は、このメニューは使用できません。
  • 削除 - 現在選択中のチップを削除します。選択されているチップが１つもない間は、このメニューは使用できません。

  • 元に戻す（Undo） - 直前に行った作業を取り消して、元に戻します。
  • やり直し（Redo） - 元に戻した作業を、もう一度実行し直します。

  • チップパレット - チップパレットの表示のON・OFFを指定します。
  • 縦方向倍率 - 譜面の縦方向の表示倍率を指定します。
  • ガイド幅 - ガイド線の間隔を指定します。

  • 選択モード - 選択モードに切り替えます。
  • 編集モード - 編集モードに切り替えます。

  • 最初から再生 - DTXViewerで、譜面の先頭から再生を開始します。この機能は、DTXViewer が DTXCreator と同じフォルダに存在しない場合は使用できません。
  • 現在位置から再生 - DTXViewer で、現在表示されている譜面の最下層の小節から再生を開始します。この機能は、DTXViewer が DTXCreator と同じフォルダに存在しない場合は使用できません。
  • 現在位置からBGMのみ再生 - DTXViewer で、現在表示されている譜面の最下層の小節から再生を開始します。 ただし、BGMサウンド以外のWAVセル（チップ）は発音されません。またこの機能は、DTXViewer が DTXCreator と同じフォルダに存在しない場合は使用できません。
  • 再生停止 - DTXViewer が再生中であれば、停止します。この機能は、DTXViewer が DTXCreator と同じフォルダに存在しない場合は使用できません。
  • 再生速度 - DTXViewer での再生速度（#DTXVPLAYSPEED）を指定します。


画面構成
サウンドプロパティ画面

  サウンドプロパティ画面では、サウンドに対する様々な属性を設定・変更することができます。

画面構成

WAV番号
背景色、文字色、標準色に戻す
ラベル
ファイル名
このサウンドをBGMとして使用する
音量
位置
試聴

WAV番号

  現在編集しているサウンドの番号（00～ZZ）です。

背景色、文字色、標準色に戻す

  [WAV]タブで表示される行の背景色と文字色を変更します。よく似たサウンドごとに同系色を割り当てておくと、[WAV]タブでの視認性が良くなります。譜面への影響や音的効果は一切ありません。

ラベル

  サウンドに対して、好きな名前をつけることが出来ます。自分がわかりやすい名前をつけておくと、譜面の編集が行いやすくなります。譜面への影響や音的効果は一切ありません。

ファイル名

  サウンドのファイル名を記入します。[参照...] ボタンを押下すると、ファイル選択ダイアログでファイルを選択することができます。ファイル名は、編集中の譜面（DTXファイル）の置かれる位置からの相対パスで記されます（絶対パスでの記述も可能です）。

※なお、編集中の譜面（DTXファイル）がまだ一度も保存されていない状態でサウンドファイルを[参照...]ボタンから選択した場合、表示される ファイル名は絶対パス表記となりますが、譜面（DTXファイル）の初回保存時に、改めてDTXファイルからの相対パスに置換されます。

このサウンドをBGMとして使用する

  このWAVセルをBGMサウンドとして扱う場合には、チェックをオンにします。この機能は、[再生]→[現在の位置からBGMのみ再生] 機能を使用した際に、どのWAVセルがBGMサウンドであるかを判別することに使用されます。

音量

  サウンドの音量を変更します。数値は （無音）0 ～ 100（原音）であり、原音より音量を大きくすることはできないのでご注意下さい。（DirectSoundの仕様…）

位置

  サウンドの再生位置を変更します。数値は （左）-100 ～ （中央）0 ～ （右) 100 です。

  なお、DTXMania での位置の変更はサウンドの左右の音量を別々に増減することにより実現されますので、ステレオサウンドを使用する場合は見かけ（聞きかけ？）の音が変化する場合があります のでご注意下さい。（例：原音が主に「左」方向でなっているステレオシンバル音を、このサウンドプロパティで「右」位置で鳴らそうとすると、単純に左側の音量が下げられるので、結果として聞こえる音は小さくなってしまいます。これもDirectSoundの仕様…）

試聴

  現在の設定状態を試聴して確かめることができます。


画面構成
動画プロパティ画面

  動画プロパティ画面では、動画に対する様々な属性を設定・変更することができます。

画面構成

AVI番号
背景色、文字色、標準色に戻す
ラベル
ファイル名

AVI番号

  現在編集している動画の番号（00～ZZ）です。

背景色、文字色、標準色に戻す

  [AVI]タブで表示される行の背景色と文字色を変更します。よく似た動画や同シーンの動画ごとに同系色を割り当てておくと、[AVI]タブでの視認性が良くなります。譜面への影響や 画像効果は一切ありません。

ラベル

  動画に対して、好きな名前をつけることが出来ます。自分がわかりやすい名前をつけておくと、譜面の編集が行いやすくなります。譜面への影響や画像効果は一切ありません。

ファイル名

  動画のファイル名を記入します。[参照...] ボタンを押下すると、ファイル選択ダイアログでファイルを選択することができます。ファイル名は、編集中の譜面（DTXファイル）の置かれる位置からの相対パスで記されます（絶対パスでの記述も可能です）。

※なお、編集中の譜面（DTXファイル）がまだ一度も保存されていない状態で動画ファイルを[参照...]ボタンから選択した場合、表示されるファイル名は絶対パス表記となりますが、譜面（DTXファイル）の初回保存時に、改めてDTXファイルからの相対パスに置換されます。


画面構成
画像プロパティ画面

  画像プロパティ画面では、画像に対する様々な属性を設定・変更することができます。

画面構成

BMP番号
背景色、文字色、標準色に戻す
ラベル
ファイル名
Texture

BMP番号

  現在編集している画像の番号（00～ZZ）です。

背景色、文字色、標準色に戻す

  [BMP]タブで表示される行の背景色と文字色を変更します。よく似た画像や同シーンの画像ごとに同系色を割り当てておくと、[BMP]タブでの視認性が良くなります。譜面への影響や 画像効果は一切ありません。

ラベル

  画像に対して、好きな名前をつけることが出来ます。自分がわかりやすい名前をつけておくと、譜面の編集が行いやすくなります。譜面への影響や画像効果は一切ありません。

ファイル名

  画像のファイル名を記入します。[参照...] ボタンを押下すると、ファイル選択ダイアログでファイルを選択することができます。ファイル名は、編集中の譜面（DTXファイル）の置かれる位置からの相対パスで記されます（絶対パスでの記述も可能です）。

※なお、編集中の譜面（DTXファイル）がまだ一度も保存されていない状態で画像ファイルを[参照...]ボタンから選択した場合、表示されるファイル名は絶対パス表記となりますが、譜面（DTXファイル）の初回保存時に、改めてDTXファイルからの相対パスに置換されます。

Texture

  画像をテクスチャとして扱う場合にチェックを入れます。テクスチャについては、「サーフェイスとテクスチャ」をご参照下さい。


使い方
使い方

  • 選択モードと編集モード
  • 基本的な使い方
  • 便利な使い方
  • その他


使い方
選択モードと編集モード

  DTXCreator の譜面には、２つのモードがあります。

  • 選択モード（ [image] ）　…　チップを選択して移動したり、小節長を変更したりするモードです。
  • 編集モード（ [image] ）　…　チップを１つ１つ配置して譜面を作り上げるモードです。

  通常は必ずいずれかのモードが有効となっており、その切り替えは、ツールバーのボタンか、メニューバーから行います。


選択モード

使い方
選択モード

主な操作

  • １チップの選択　…　選択したいチップの上で左クリック
  • 複数チップの選択　…　選択したいチップをドラッグで囲む
  • １チップの追加選択　…　選択したいチップの上で Ctrl + 左クリック
  • 複数チップの追加選択　…　選択したいチップを Ctrl を押しながらドラッグで囲む
  • １チップの選択解除　…　選択解除したいチップの上で Ctrl + 右クリック
  • チップの移動　…　選択されているチップの上でドラッグ
  • コンテクストメニューの表示　…　右クリック
  • 選択チップの切り取り、コピー、削除　…　チップを選択 → 右クリックでメニュー表示 → 処理選択
  • チップの貼り付け　…　貼り付けたい位置で右クリックでメニュー表示 → 処理選択
  • 小節長の変更　…　変更したい小節の中で右クリック → 処理選択
  • 小節の挿入、削除　…　挿入、削除したい位置で右クリック → 処理選択


編集モード

使い方
編集モード

主な操作

  • チップの配置（表チャンネル）　…　左クリック
  • チップの配置（裏チャンネル）　…　Ctrl + 左クリック
  • チップの削除（表、裏とも）　…　右クリック
  • チップの配置（レーン割り付け無視、表チャンネル）　…　Shift + 左クリック
  • チップの配置（レーン割り付け無視、裏チャンネル）　…　Shift + Ctrl + 左クリック
  • チップのレーン割り付け（表チャンネル）　…　譜面上部で左クリック
  • チップのレーン割り付け（裏チャンネル）　…　譜面上部で Ctrl + 左クリック
  • チップのレーン割り付け解除（表チャンネル）　…　譜面上部で右クリック
  • チップのレーン割り付け解除（裏チャンネル）　…　譜面上部で Ctrl + 右クリック


基本的な使い方

使い方
基本的な使い方

  • 　チップを置く、削除する
  • 　ギター、ベースチップを作る
  • 　チップを移動する
  • 　チップを切り取り、コピー、削除する
  • 　小節を挿入、削除する
  • 　小節長を変更する
  • 　自由入力 - 未対応の命令を記述する
  • 　DTXViewerで確認する


基本的な使い方
チップを置く、削除する

  • チップをリストから選んで譜面に置く
  • チップを削除する
  • ガイド幅を変更する
  • 裏チャンネルへチップを置く

チップをリストから選んで譜面に置く

① 編集モード（ [image] ）にします。

② 譜面に配置したいチップを、リストから選択します。

③ 譜面上で左クリックすると、チップを譜面に置けます。

チップを削除する

  編集モード（ [image] ）では、チップにマウスを合わせて右クリックするとそのチップを削除できます。

  選択モード（ [image] ）では、ドラッグでチップを選択して Delキーを押下するとチップを削除できます。

ガイド幅を変更する

  ガイド幅を変更すると、チップの配置幅を変えることができます。

ガイド幅 1/4　　 [image] ガイド幅 1/32

裏チャンネルへチップを置く

  Ctrlキーを押したまま左クリックすると、チップを裏チャンネルに置くことができます。このとき、チップは左右が少し短く表示されます。

備考

  • 裏チャンネルについては「レーン」を参照してください。


基本的な使い方
ギター、ベースチップを作る

  • ボイスレーンとパターンレーン

ボイスレーンとパターンレーン

ギター（ベース）譜面は、「ボイスレーン」と「パターンレーン」という２種類のレーンを使って作成します。

ボイスレーン

その位置で再生する音（ボイスサウンド）を指定するレーンです。使い方はドラムレーンの場合と同じです。

パターンレーン

RGBパターンを指定するレーンです。実際に再生する音とは独立して指定することができます。
Ctrl + 左クリックすることで、OPENチップを配置することができます。

備考

パターンレーンにチップがない状態でボイスレーンにチップを置くと、自動的に OPEN チップが配置されます。


基本的な使い方
チップを移動する

① 選択モード（ [image] ）にします。

② 譜面上で、移動したいチップをドラッグして囲みます。これにより、チップが選択されます。

③ 選択されたいずれかのチップをドラッグすると、チップが移動します。


基本的な使い方
チップを切り取り、コピー、削除、貼り付けする

  • チップを切り取り、コピー、削除する
  • チップを貼り付ける

チップを切り取り、コピー、削除する

① 選択モード（ [image] ）にします。

② 譜面上で、移動したいチップをドラッグして囲みます。これにより、チップが選択されます。

③ 譜面上で右クリックしてメニューを出し、行いたい処理を選択します。

備考

  • 「切り取り」または「コピー」したチップは、別の位置で「貼り付け」を行うことができます。次の章を参照下さい。

チップを貼り付ける

  貼り付けたい位置で右クリックしてメニュー出し、「選択チップの貼り付け」を選択します。

備考

  • メニューバーから [編集(E)]→[貼り付け(P)] を選択した場合は、そのとき表示されている譜面領域の一番下から貼り付けられます。


基本的な使い方
小節を挿入、削除する

  • 小節を挿入する
  • 小節を削除する

小節を挿入する

① 選択モード（ [image] ）にします。

② 小節を挿入したい位置（上に押し上げたい小節の中）で右クリックしてメニューを出し、「小節の挿入」を選択します。

小節を削除する

① 選択モード（ [image] ）にします。

② 削除したい小節の中で右クリックしてメニューをだし、「小節の削除」を選択します。

備考

  • 削除した小節に含まれていたチップもすべて削除されます。


基本的な使い方
小節長を変更する

① 選択モード（ [image] ）にします。

② 長さを変更したい小節の中で右クリックしてメニューをだし、「小節長の変更(B)」を選択します。

③ [小節長変更] ダイアログが表示されますので、希望の倍率に変更し、[OK] ボタンを押下します。

備考

  • 小節長を変更しても、チップの見かけ上の位置は変更されません。
  • 小節長を短くした場合、はみだしたチップは削除されます。


基本的な使い方
自由入力 - 未対応の命令を記述する

① 編集タブから [自由入力] タブを選択します。

② 自由に内容を記述します。

備考

  • 自由入力欄に記述された内容は、そのまま DTX ファイルに出力されます。
  • DTX ファイルの読み込み時、DTXCreator で未対応の命令があった場合はすべて自由入力欄に読み込まれます。


基本的な使い方
DTXViewer で確認する

  ある程度譜面を作り終えたら、ときおり DTXViewer で内容を確認することをお勧めします。

最初から再生する

  メニューバーの [再生(P)] → [先頭から再生] を選択するか、あるいはツールバーの [image] ボタンを押下すると、DTXViewer が起動し、現在編集中の譜面を、自動的に最初から再生を開始します。

現在の位置から再生する

  メニューバーの [再生(P)] → [現在の位置から再生] を選択するか、あるいはツールばーの [image] ボタンを押下すると、DTXViewer が起動し、現在変種中の譜面を、現在表示されている小節位置から再生を開始します。

再生速度の変更

  ツールバーから、DTXViewer での再生速度を変更することができます。

現在の位置からBGMのみ再生する

  メニューバーの [再生(P)] → [現在の位置からBGMのみ再生] を選択するか、あるいはツールばーの [image] ボタンを押下すると、DTXViewer が起動し、現在変種中の譜面を、現在表示されている小節位置から再生を開始します。
  ただし、ここでは、BGMサウンド（WAVリストの「BGM」列に○印のあるWAVセル）しか発声されません。

再生を停止する

  メニューバーの [再生(P)] → [再生停止] を選択するか、あるいはツールバーの [image] ボタンを押下すると、DTXViewer の再生が停止します。

備考

  • これらの機能は、DTXCreator と同じフォルダに DTXViewer が入っていなければ、使用することができません。


便利な使い方

使い方
便利な使い方

  • チップをレーンに割り付ける
  • チップパレットを使う
  • 検索する
  • 置換する


便利な使い方
チップをレーンに割り付ける

  各レーンに、よく使うチップを「割り付ける」ことができます。チップをレーンに割り付けると、現在選択しているチップより割り付け済みのチップのほうが優先されるようになります。 この場合、リストでどの番号の行を選択していても、レーンを左クリック（チップ配置）すると優先されているレーン割り付けチップの番号が譜面に描画されます。

  １つのレーンにつき、表チャンネル用と裏チャンネル用の２つのチップを割り付けることが出来ます。

レーンへチップを割り付ける

① 編集モード（ [image] ）にします。

② 割り付けたいチップをリストから選択します。

③ 割り付けたいレーンの上端（レーン名の辺り）で左クリックします。（裏チャンネルに割り当てる場合は Ctrl キーを押しながら左クリックします。）

備考

  • レーン割り付けチップがある状態で、リストで選択したチップのほうを譜面に配置したい場合は、Shiftキー（裏チャンネルへの配置の場合は Ctrl + Shift ）を押しながら左クリックします。

割り付けを解除する

① 編集モード（ [image] ）にします。

② 割り付けを解除したいレーンの上端（レーン名の辺り）で右クリックします。（裏チャンネルを解除したい場合は Ctrl キーを押しながら右クリックします。）


便利な使い方
チップパレットを使う

  チップパレットとは、いくつかのチップをリストから取捨選択して、好きな位置に配置しておけるフローティングウィンドウです。頻繁に使うチップを登録しておくことで、数多いリストの中から探し出す手間を省くことが出来ます。

チップパレットを表示する、隠す

  ツールバーの [image] ボタンを押下するか、あるいはメニューバーから [表示(V)] → [チップパレット(P)] を選択すると、チップパレットの表示の ON / OFF を切り替えることができます。

チップの登録

  登録したいチップを編集タブからチップパレットまでドラッグ＆ドロップします。

チップの削除

① チップパレットの中のチップを選択し、右クリックしてメニューを出します。

② [パレットから削除(D)] を選択します。


便利な使い方
検索する

  メニューバーから [編集(E)] → [検索(F)] を選択すると、検索ダイアログが開きます。

レーン指定
チップ範囲指定
表チップから選択する
裏チップから選択する
小節範囲指定

  検索条件を設定して [検索] ボタンを押下すると、該当するチップが選択された状態となります。

レーン指定

  レーンを限定して検索したい場合に、チェックを入れます。
  その下のレーンリストでは、検索したいレーンにチェックを入れます。[All] ボタン押下で全レーン選択、[None] ボタン押下で全レーン選択解除となります。

チップ範囲指定

  検索するチップ番号の範囲を指定します。
  どちらも３６進数２桁（01～ZZ）で指定し、片方の欄だけに記入した場合はその番号のみを検索対象とし、どちらも空欄にした場合は全チップ（01 ～ ZZ）を設定したものと見なされます（チェックを外したのと同じ）。

表チップから選択する

  表チャンネルのチップを検索したい場合にチェックを入れます。

裏チップから選択する

  裏チャンネルのチップを検索したい場合にチェックを入れます。

小節範囲指定

  検索する小節番号の範囲を指定します。
  小節番号は 000 ～ Z99 （百の位のみ３６進数、十と一の位は１０進数）で指定し、片方の欄だけに記入した場合はその番号のみを検索対象とし、どちらも空欄にした場合は全小節（000～Z99）を設定したものと見なされます（チェックを外したのと同じ）。


便利な使い方
置換する

  メニューバーから [編集(E)] → [置換(R)] を選択すると、置換ダイアログが開きます。

チップの置き換え
チップの表裏を反転

  置換条件を設定して [置換] ボタンを押下すると、選択されているチップに対して置換が適用されます。（チップを選択してなかった場合は、このダイアログが開く直前に、自動的に全チップが選択状態にされます。）

チップの置き換え

  選択されているチップのうち、該当する番号のチップを新しい番号に置換します。チップの表・裏チャンネルは維持されます。

チップの表裏を反転

  選択されているチップについて、すべて表裏チャンネルを入れ替えます。チップ番号は維持されます。


その他

使い方
その他

  • オプション設定


その他
オプション

  メニューバーから [ツール(T)] → [オプション(O)] を選択すると、オプション設定ダイアログが開きます。

オートフォーカス
最近使用したファイルの一覧
BGMサウンドのプレビューは自動再生しない
WAVチップを譜面に配置したときにチップの音を再生する

オートフォーカス

  この項目にチェックを入れると、編集タブと譜面との間でマウスカーソルが移動したとき、フォーカスを自動的に切り替えるようになります。

最近使用したファイルの一覧

  この項目にチェックを入れると、メニューバーの [ファイル(F)] の最下層に、最近使用したファイルの履歴が指定個数だけ表示されるようになります。

BGMサウンドのプレビューは自動再生しない

  試聴（プレビュー）が有効になっている場合、[WAV] タブの任意のWAVセルをクリックすると、そのWAVセルに割り当てられているサウンドのプレビューが自動的に再生されます。この項目にチェックを入れると、WAVセルがBGMサウンドである場合に限り、試聴の有効・無効に関係なく、クリックされてもプレビューを自動で再生しなくなります。（手動で試聴ボタンを押すなどした場合には再生されます。）

WAVチップを譜面に配置したときにチップの音を再生する

  この項目にチェックを入れると、譜面でチップを配置したときにプレビュー音を再生します。


最後に
最後に

免責

  DTXCreator はフリーウェアです。本ソフトウェアの使用による故障その他あらゆる直接的および間接的被害に関して一切の責任を負いません。

連絡先

DTXMania powered by YAMAHA Silent Session Drums
Copyright (C) 2000-2007 FROM/K.YAMAZAKI
URL: http://www.donburi.to/~from/dtxmania/
Mail: from@donburi.to

謝辞

  本ソフトの作成に、GDACreator Professional （J.T.氏作）を参考にさせて頂きました。
  また、動作試験・マニュアル精査にやぎ。氏に多大なご協力を頂きました。

  深く感謝いたします。