OSDN Git Service

luci-app-opkg: fix parsing package dependencies with version constraints
authorJo-Philipp Wich <jo@mein.io>
Fri, 3 Jun 2022 11:36:02 +0000 (13:36 +0200)
committerJo-Philipp Wich <jo@mein.io>
Fri, 3 Jun 2022 11:36:02 +0000 (13:36 +0200)
Due to improper ordering of regexp alternatives, version constraint operators
might get undermatched.

Fixes: https://github.com/openwrt/openwrt/issues/9982
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
applications/luci-app-opkg/htdocs/luci-static/resources/view/opkg.js

index 57f2006..de725ea 100644 (file)
@@ -571,7 +571,7 @@ function renderDependencies(depends, info)
                if (deps[i] === 'libc')
                        continue;
 
-               if (deps[i].match(/^(.+)\s+\((<=|<|>|>=|=|<<|>>)(.+)\)$/)) {
+               if (deps[i].match(/^(.+)\s+\((<=|>=|<<|>>|<|>|=)(.+)\)$/)) {
                        dep = RegExp.$1.trim();
                        vop = RegExp.$2.trim();
                        ver = RegExp.$3.trim();