OSDN Git Service

for Maven 3.3.9
authorOlyutorskii <olyutorskii@users.osdn.me>
Thu, 2 May 2019 15:14:19 +0000 (00:14 +0900)
committerOlyutorskii <olyutorskii@users.osdn.me>
Thu, 2 May 2019 15:14:19 +0000 (00:14 +0900)
CHANGELOG.txt
pom.xml

index aeebde0..c65e899 100644 (file)
@@ -6,7 +6,7 @@ Jovsonz 変更履歴
 
 X.XXX.X (20XX-XX-XX)
     ・Maven3対応。
-    ・JDK1.7が必須となる。
+    ・JDK1.8が必須となる。
     ・SourceForge.JP → OSDN.JP → OSDN.net 対応。
     ・Mercurial(1.101.3-SNAPSHOT)からGit(1.101.103-SNAPSHOT)へSCMを移行。
 
diff --git a/pom.xml b/pom.xml
index 963725a..47ffd7b 100644 (file)
--- a/pom.xml
+++ b/pom.xml
@@ -8,7 +8,7 @@
   xmlns="http://maven.apache.org/POM/4.0.0"
   xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
   xsi:schemaLocation="http://maven.apache.org/POM/4.0.0
-  http://maven.apache.org/maven-v4_0_0.xsd"
+  http://maven.apache.org/xsd/maven-4.0.0.xsd"
 >
     <modelVersion>4.0.0</modelVersion>
     <!--parent/-->
@@ -57,9 +57,7 @@
     <contributors/>
     <mailingLists/>
 
-    <prerequisites>
-        <maven>3.0.1</maven>
-    </prerequisites>
+    <!-- prerequisites/ -->
 
     <modules/>
 
             <plugin>
                 <groupId>org.apache.maven.plugins</groupId>
                 <artifactId>maven-enforcer-plugin</artifactId>
-                <version>1.4.1</version>
-                <configuration>
-                    <rules>
-                        <requireMavenVersion>
-                            <version>[3.0.1,)</version>
-                        </requireMavenVersion>
-                        <requireJavaVersion>
-                            <version>[1.7,)</version>
-                        </requireJavaVersion>
-                    </rules>
-                </configuration>
+                <version>3.0.0-M2</version>
+                <executions>
+                    <execution>
+                        <id>enforce-versions</id>
+                        <goals>
+                            <goal>enforce</goal>
+                        </goals>
+                        <configuration>
+                            <rules>
+                                <requireMavenVersion>
+                                    <version>[3.3.9,)</version>
+                                </requireMavenVersion>
+                                <requireJavaVersion>
+                                    <version>[1.8,)</version>
+                                </requireJavaVersion>
+                            </rules>
+                        </configuration>
+                    </execution>
+                </executions>
             </plugin>
 
             <plugin>
                         <fileset>
                             <directory>${project.basedir}</directory>
                             <includes>
-                                <include>**/.DS_Store</include>
-                                <include>**/_MACOSX</include>
+                                <include>**/*~</include>
+                                <include>**/*.swp</include>
+                                <include>**/*.DS_Store</include>
+                                <include>**/._*</include>
+                                <include>**/__MACOSX</include>
                                 <include>**/Thumbs.db</include>
-                                <include>**/thumbs.db</include>
-                                <include>**/Desktop.ini</include>
                                 <include>**/desktop.ini</include>
                                 <include>**/core</include>
+                                <include>**/hs_err_pid*</include>
                             </includes>
                         </fileset>
                     </filesets>