OSDN Git Service

Enable to track git://github.com/monaka/binutils.git
[pf3gnuchains/pf3gnuchains3x.git] / sid / component / rtc / Makefile.am
diff --git a/sid/component/rtc/Makefile.am b/sid/component/rtc/Makefile.am
new file mode 100644 (file)
index 0000000..633b022
--- /dev/null
@@ -0,0 +1,18 @@
+## Process this with automake to create Makefile.in
+
+AUTOMAKE_OPTIONS = foreign
+
+pkglib_LTLIBRARIES = librtc.la
+
+INCLUDES = -I. -I../../include -I$(srcdir)/../../include
+librtc_la_SOURCES = ds1x42.cxx components.cxx sidrtc.cxx
+librtc_la_LDFLAGS = -module -no-undefined
+
+pkgdata_DATA = hw-visual-clock.tk hw-visual-clock.txt hw-rtc-ds1x42.txt hw-rtc-sid.txt
+
+DEJAGNUTESTS=ds1642.exp ds1742.exp rtcmonkey.exp rtcdocs.exp
+check-local: all
+       (cd ../testsuite ; $(MAKE) check RUNTESTFLAGS="$(RUNTESTFLAGS) $(DEJAGNUTESTS)" )
+
+html_stylesheet=$(srcdir)/../component_html.xsl
+include $(srcdir)/../../config/Makefile.docs