OSDN Git Service

Prepare for rpm build for PostgreSQL 10
[pghintplan/pg_hint_plan.git] / SPECS / pg_hint_plan10.spec
similarity index 87%
rename from SPECS/pg_hint_plan96.spec
rename to SPECS/pg_hint_plan10.spec
index 21a10f8..700d2da 100644 (file)
@@ -1,7 +1,7 @@
 # SPEC file for pg_store_plans
 # Copyright(C) 2017 NIPPON TELEGRAPH AND TELEPHONE CORPORATION
 
-%define _pgdir   /usr/pgsql-9.6
+%define _pgdir   /usr/pgsql-10
 %define _bindir  %{_pgdir}/bin
 %define _libdir  %{_pgdir}/lib
 %define _datadir %{_pgdir}/share
@@ -12,8 +12,8 @@
 %endif
 
 ## Set general information for pg_store_plans.
-Summary:    Optimizer hint on PostgreSQL 9.6
-Name:       pg_hint_plan96
+Summary:    Optimizer hint on PostgreSQL 10
+Name:       pg_hint_plan10
 Version:    1.2.0
 Release:    1%{?dist}
 License:    BSD
@@ -24,8 +24,8 @@ BuildRoot:  %{_tmppath}/%{name}-%{version}-%{release}-%(%{__id_u} -n)
 Vendor:     NIPPON TELEGRAPH AND TELEPHONE CORPORATION
 
 ## We use postgresql-devel package
-BuildRequires:  postgresql96-devel
-Requires:  postgresql96-libs
+BuildRequires:  postgresql10-devel
+Requires:  postgresql10-libs
 
 ## Description for "pg_hint_plan"
 %description
@@ -33,11 +33,11 @@ Requires:  postgresql96-libs
 pg_hint_plan provides capability to tweak execution plans to be
 executed on PostgreSQL.
 
-Note that this package is available for only PostgreSQL 9.6.
+Note that this package is available for only PostgreSQL 10.
 
 ## pre work for build pg_hint_plan
 %prep
-PATH=/usr/pgsql-9.6/bin:$PATH
+PATH=/usr/pgsql-10/bin:$PATH
 if [ "${MAKE_ROOT}" != "" ]; then
   pushd ${MAKE_ROOT}
   make clean %{name}-%{version}.tar.gz
@@ -48,7 +48,7 @@ if [ ! -d %{_rpmdir} ]; then mkdir -p %{_rpmdir}; fi
 
 ## Set variables for build environment
 %build
-PATH=/usr/pgsql-9.6/bin:$PATH
+PATH=/usr/pgsql-10/bin:$PATH
 make USE_PGXS=1 %{?_smp_mflags}
 
 ## Set variables for install