OSDN Git Service

Support PostgreSQL 14
[pghintplan/pg_hint_plan.git] / SPECS / pg_hint_plan14.spec
similarity index 74%
rename from SPECS/pg_hint_plan13.spec
rename to SPECS/pg_hint_plan14.spec
index ee01413..91c54d0 100644 (file)
@@ -1,7 +1,7 @@
 # SPEC file for pg_store_plans
 # Copyright(C) 2020 NIPPON TELEGRAPH AND TELEPHONE CORPORATION
 
-%define _pgdir   /usr/pgsql-13
+%define _pgdir   /usr/pgsql-14
 %define _bindir  %{_pgdir}/bin
 %define _libdir  %{_pgdir}/lib
 %define _datadir %{_pgdir}/share
@@ -15,8 +15,8 @@
 
 ## Set general information for pg_store_plans.
 Summary:    Optimizer hint on PostgreSQL 12
-Name:       pg_hint_plan13
-Version:    1.3.7
+Name:       pg_hint_plan14
+Version:    1.4
 Release:    1%{?dist}
 License:    BSD
 Group:      Applications/Databases
@@ -26,8 +26,8 @@ BuildRoot:  %{_tmppath}/%{name}-%{version}-%{release}-%(%{__id_u} -n)
 Vendor:     NIPPON TELEGRAPH AND TELEPHONE CORPORATION
 
 ## We use postgresql-devel package
-BuildRequires:  postgresql13-devel
-Requires:  postgresql13-server
+BuildRequires:  postgresql14-devel
+Requires:  postgresql14-server
 
 ## Description for "pg_hint_plan"
 %description
@@ -35,19 +35,19 @@ Requires:  postgresql13-server
 pg_hint_plan provides capability to tweak execution plans to be
 executed on PostgreSQL.
 
-Note that this package is available for only PostgreSQL 13.
+Note that this package is available for only PostgreSQL 14.
 
 %package llvmjit
-Requires: postgresql13-server, postgresql13-llvmjit
-Requires: pg_hint_plan13 = 1.3.7
-Summary:  Just-in-time compilation support for pg_hint_plan13
+Requires: postgresql14-server, postgresql14-llvmjit
+Requires: pg_hint_plan14 = 1.4
+Summary:  Just-in-time compilation support for pg_hint_plan14
 
 %description llvmjit
-Just-in-time compilation support for pg_hint_plan13
+Just-in-time compilation support for pg_hint_plan14
 
 ## pre work for build pg_hint_plan
 %prep
-PATH=/usr/pgsql-13/bin:$PATH
+PATH=/usr/pgsql-14/bin:$PATH
 if [ "${MAKE_ROOT}" != "" ]; then
   pushd ${MAKE_ROOT}
   make clean %{name}-%{version}.tar.gz
@@ -58,7 +58,7 @@ if [ ! -d %{_rpmdir} ]; then mkdir -p %{_rpmdir}; fi
 
 ## Set variables for build environment
 %build
-PATH=/usr/pgsql-13/bin:$PATH
+PATH=/usr/pgsql-14/bin:$PATH
 make USE_PGXS=1 %{?_smp_mflags}
 
 ## Set variables for install
@@ -73,7 +73,7 @@ rm -rf %{buildroot}
 %defattr(0755,root,root)
 %{_libdir}/pg_hint_plan.so
 %defattr(0644,root,root)
-%{_datadir}/extension/pg_hint_plan--1.3.7.sql
+%{_datadir}/extension/pg_hint_plan--1.4.sql
 %{_datadir}/extension/pg_hint_plan.control
 
 %files llvmjit
@@ -85,5 +85,5 @@ rm -rf %{buildroot}
 
 # History of pg_hint_plan.
 %changelog
-* Thu Oct 29 2020 Kyotaro Horiguchi
-- First release of pg_hint_plan13.
+* Tue Oct 05 2021 Kyotaro Horiguchi
+- Support PostgreSQL 14.