OSDN Git Service

1.2.1
[pydun/Pydun.git] / pydun.spec
index 3fc0277..63d81c0 100644 (file)
@@ -1,4 +1,4 @@
-# -*- mode: python -*-\r
+# -*- mode: python ; coding: utf-8 -*-\r
 \r
 block_cipher = None\r
 \r
@@ -10,7 +10,7 @@ a = Analysis(['D:\\users\\pydun\\trunk\\Pydun.py'],
              hiddenimports=[],\r
              hookspath=[],\r
              runtime_hooks=[],\r
-             excludes=[],\r
+             excludes=['tkinter'],\r
              win_no_prefer_redirects=False,\r
              win_private_assemblies=False,\r
              cipher=block_cipher,\r
@@ -19,14 +19,19 @@ pyz = PYZ(a.pure, a.zipped_data,
              cipher=block_cipher)\r
 exe = EXE(pyz,\r
           a.scripts,\r
-          a.binaries,\r
-          a.zipfiles,\r
-          a.datas,\r
           [],\r
+          exclude_binaries=True,\r
           name='Pydun',\r
           debug=False,\r
           bootloader_ignore_signals=False,\r
           strip=False,\r
           upx=True,\r
-          runtime_tmpdir=None,\r
           console=False )\r
+coll = COLLECT(exe,\r
+               a.binaries,\r
+               a.zipfiles,\r
+               a.datas,\r
+               strip=False,\r
+               upx=True,\r
+               upx_exclude=[],\r
+               name='Pydun')\r