OSDN Git Service

rectool: improve rpm's spec file to include version string (git rev) in generated...
[rec10/rec10-git.git] / rectool / rectool.spec
1 %define         gitrev  %(git rev-list HEAD | wc | awk '{print $1}')
2
3 Name:           rec10-rectool
4 Version:        0.0.1
5 Release:        git%{gitrev}%{?dist}
6 Summary:        rec10 web interface
7
8 Group:          Utilities
9 License:        Unknown
10 URL:            http://www.rec10.org/
11 Source0:        rectool.pl
12 Source1:        rec10.conf
13 BuildArch:      noarch
14 BuildRoot:      %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
15
16 BuildRequires:  make
17 Requires:       perl-Algorithm-Diff perl-Archive-Zip perl-CGI perl-Config-Simple perl-Data-Dumper-Concise
18 Requires:       perl-Date-Simple perl-DateTime perl-DBI perl-File-Slurp perl-Sort-Naturally perl-SVG
19 Requires:       perl-Time-Piece perl-Tie-IxHash perl-List-Compare perl-XML-Atom perl-XML-Generator-DBI perl-XML-SAX-Writer perl-XML-TreePP
20
21 %description
22 rectool-0.0.1
23
24 %prep
25 rm -rf $RPM_BUILD_ROOT
26
27 %build
28
29
30 %install
31 #rm -rf $RPM_BUILD_ROOT
32 %__mkdir -p $RPM_BUILD_ROOT/usr/share/rec10/rectool/
33 %__mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d/
34 %__mkdir -p $RPM_BUILD_ROOT/var/www/html/rec10/
35 %__cp $RPM_SOURCE_DIR/rectool.pl $RPM_BUILD_ROOT/usr/share/rec10/rectool/
36 %__cp $RPM_SOURCE_DIR/rec10.conf $RPM_BUILD_ROOT/etc/httpd/conf.d/
37 ln -sf /usr/share/rec10/rectool/rectool.pl $RPM_BUILD_ROOT/var/www/html/rec10/
38
39 %clean
40 rm -rf $RPM_BUILD_ROOT
41
42
43 %files
44 %defattr(-,root,root,-)
45 %doc
46 %{_datadir}/rec10/rectool/rectool.pl
47 /etc/httpd/conf.d/rec10.conf
48 /var/www/html/rec10/rectool.pl
49
50
51 %changelog
52