OSDN Git Service

added pm-wrapper-interface
[alterlinux/alterlinux-pkgbuilds.git] / alter-stable / any / compiz / PKGBUILD
1 # Maintainer: Charles Bos <charlesbos1 AT gmail>
2 # Contributor: Rob McCathie <archaur at rmcc dot com dot au
3 # Contributor: /dev/rs0 <rs0@secretco.de.com>
4 # Contributor: Iven Hsu <ivenvd AT gmail>
5 # Contributor: Nathan Hulse <nat.hulse@gmail.com>
6
7 pkgname=compiz
8 pkgver=0.9.14.1
9 pkgrel=3
10 pkgdesc="Composite manager for Aiglx and Xgl, with plugins and CCSM"
11 arch=('i686' 'x86_64')
12 url="https://launchpad.net/compiz"
13 license=('GPL' 'LGPL' 'MIT')
14 depends=('boost-libs' 'xorg-server' 'fuse2' 'glibmm' 'libwnck3' 'python-gobject' 'python-cairo' 'protobuf' 'metacity' 'glu')
15 makedepends=('boost' 'cmake' 'intltool' 'cython')
16 optdepends=(
17   'xorg-xprop: grab various window properties for use in window matching rules'
18 )
19 conflicts=('compiz-core' 'compiz-gtk' 'compiz-bcop' 'ccsm' 'compiz-fusion-plugins-main' 'compiz-fusion-plugins-extra' 'compiz-fusion-plugins-experimental' 'compizconfig-python' 'libcompizconfig' 'simple-ccsm')
20 provides=("compiz-core=${pkgver}" "compiz-bcop=${pkgver}" "ccsm=${pkgver}" "compiz-plugins-main=${pkgver}" "compiz-plugins-extra=${pkgver}" "compizconfig-python=${pkgver}" "libcompizconfig=${pkgver}")
21 source=("https://launchpad.net/${pkgname}/${pkgver:0:6}/${pkgver}/+download/${pkgname}-${pkgver}.tar.xz"
22         "focus-prevention-disable.patch"
23         "gtk-extents.patch"
24         "reverse-unity-config.patch"
25         "screenshot-launch-fix.patch"
26         "no-compile-gschemas.patch"
27         "gcc10_common_fix.patch")
28 sha256sums=('2505602b6c93d6565e681473df4157634268533c6874c3cdc9493b73b301ac52'
29             'f4897590b0f677ba34767a29822f8f922a750daf66e8adf47be89f7c2550cf4b'
30             '16ddb6311ce42d958505e21ca28faae5deeddce02cb558d55e648380274ba4d9'
31             '6ec9c04540ca1649c687d9ab2c8311caea7075831e2cffe719ec7958c9ebab7b'
32             '89ee91a8ea6b1424ef76661ea9a2db43412366aacddc12d24a7adf5e04bfbc61'
33             '4ab3277da201314b3f65e30128bc30704ddee584fdbbfc8d0d83c7e0de91fa9a'
34             '6268dfaaf72957388b6324f8cfac1daaa32a453e8f3b377dd522a38e6bf55469')
35
36 prepare() {
37   cd "${pkgname}-${pkgver}"
38
39   # Reverse Unity specific configuration patches
40   patch -p1 -i "${srcdir}/reverse-unity-config.patch"
41
42   # Set focus prevention level to off which means that new windows will always get focus
43   patch -p1 -i "${srcdir}/focus-prevention-disable.patch"
44
45   # Fix incorrect extents for GTK+ tooltips, csd etc
46   patch -p1 -i "${srcdir}/gtk-extents.patch"
47
48   # Fix application launching for the screenshot plugin
49   patch -p1 -i "${srcdir}/screenshot-launch-fix.patch"
50
51   # Don't try to compile gschemas during make install
52   patch -p1 -i "${srcdir}/no-compile-gschemas.patch"
53
54   # Fix linker error that gets raised with gcc 10 due to multiple definitions
55   patch -p1 -i "${srcdir}/gcc10_common_fix.patch"
56 }
57
58 build() {
59   cd "${pkgname}-${pkgver}"
60
61   mkdir build; cd build
62
63   cmake .. \
64     -DCMAKE_BUILD_TYPE="Release" \
65     -DCMAKE_INSTALL_PREFIX="/usr" \
66     -DCMAKE_INSTALL_LIBDIR="/usr/lib" \
67     -DCOMPIZ_DISABLE_SCHEMAS_INSTALL=On \
68     -DCOMPIZ_BUILD_WITH_RPATH=Off \
69     -DCOMPIZ_PACKAGING_ENABLED=On \
70     -DBUILD_GTK=On \
71     -DBUILD_METACITY=On \
72     -DBUILD_KDE4=Off \
73     -DCOMPIZ_BUILD_TESTING=Off \
74     -DCOMPIZ_WERROR=Off \
75     -DCOMPIZ_DEFAULT_PLUGINS="composite,opengl,decor,resize,place,move,compiztoolbox,staticswitcher,regex,animation,wall,ccp"
76
77     make
78 }
79
80 package() {
81   cd "${pkgname}-${pkgver}/build"
82   make DESTDIR="${pkgdir}" install
83
84   # findcompiz_install needs COMPIZ_DESTDIR and install needs DESTDIR
85   # make findcompiz_install
86   CMAKE_DIR=$(cmake --system-information | grep '^CMAKE_ROOT' | awk -F\" '{print $2}')
87   install -dm755 "${pkgdir}${CMAKE_DIR}/Modules/"
88   install -m644 ../cmake/FindCompiz.cmake "${pkgdir}${CMAKE_DIR}/Modules/"
89
90   # Add documentation
91   install -dm755 "${pkgdir}/usr/share/doc/compiz/"
92   install ../{AUTHORS,NEWS,README} "${pkgdir}/usr/share/doc/compiz/"
93
94   # Add the gsettings schema files
95   if ls generated/glib-2.0/schemas/ | grep -qm1 .gschema.xml; then
96     install -dm755 "${pkgdir}/usr/share/glib-2.0/schemas/"
97     install -m644 generated/glib-2.0/schemas/*.gschema.xml "${pkgdir}/usr/share/glib-2.0/schemas/"
98   fi
99
100   # Install licenses
101   install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}"
102   install -m644 "${srcdir}/${pkgname}-${pkgver}"/{COPYING,COPYING.GPL,COPYING.LGPL,COPYING.MIT} "${pkgdir}/usr/share/licenses/${pkgname}"
103 }