OSDN Git Service

[update] : Filesystem 20210821
[alterlinux/alterlinux-pkgbuilds.git] / alter-stable / any / filesystem / PKGBUILD
1 # Maintainer : Yamada Hayao <hayao@fascode.net>
2 # Contributer: Sébastien Luttringer
3 # Contributor: Tom Gundersen <teg@jklm.no>
4
5 pkgname=filesystem
6 pkgver=2021.08.21
7 pkgrel=1
8 pkgdesc='Base Alter Linux files'
9 arch=('x86_64' 'i686')
10 license=('GPL')
11 url='https://alter.fascode.net'
12 depends=('iana-etc')
13 backup=('etc/crypttab' 'etc/fstab' 'etc/group' 'etc/gshadow' 'etc/host.conf'
14         'etc/hosts' 'etc/issue' 'etc/ld.so.conf' 'etc/motd' 'etc/nsswitch.conf'
15         'etc/passwd' 'etc/profile' 'etc/resolv.conf' 'etc/securetty'
16         'etc/shadow' 'etc/shells')
17 source=('crypttab' 'env-generator' 'fstab' 'group' 'gshadow' 'host.conf' 'hosts'
18         'issue' 'ld.so.conf' 'letter-to-you' 'locale.sh' 'motd' 'nsswitch.conf'
19         'os-release' 'passwd' 'profile' 'resolv.conf' 'securetty' 'shadow' 'shells'
20         'sysctl' 'sysusers' 'tmpfiles' 'archlinux.svg' 'archlinux.png'
21         'archlinux-logo.svg' 'archlinux-logo.png')
22 sha256sums=('e03bede3d258d680548696623d5979c6edf03272e801a813c81ba5a5c64f4f82'
23             'ed0cb4f1db4021f8c3b5ce78fdf91d2c0624708f58f36c9cf867f4d93c3bc6da'
24             'e54626e74ed8fee4173b62a545ab1c3a3a069e4217a0ee8fc398d9933e9c1696'
25             '244f0718ee2a9d6862ae59d6c18c1dd1568651eada91a704574fa527fbac2b3a'
26             '90d879374f77bac47f132164c1e7fc4892e994ff1d1ac376efa0c1c26ea37273'
27             '4d7b647169063dfedbff5e1e22cee77bd1a4183dbcfd5e802e68939da4bbf733'
28             'd9cd8a77d9e0aa5e90d7f4ed74c8745c17b525e720e28e4c44364150003c35f9'
29             'c774dbbcaea38ee1c1141d0daf82aa8177bfb26aca896d6f0c4ccdc902f6ac42'
30             'dad04a370e488aa85fb0a813a5c83cf6fd981ce01883fc59685447b092de84b5'
31             'a1f3f02b099239ddea5f9da0028bd53c04fbee9b1cc9f4d1c7bea7567e8d4249'
32             '8ca2d8eef6fb5143c9ef7e9174ccfef59ac7ad2deee243574cd10c763156cc10'
33             'e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855'
34             '3b821d881a147977e251c522d722626881229d8bc150447673f39f28876ac749'
35             'be420dbdfef122fcef1f2260f86f4409346320a7665019258a9acedef28249d6'
36             '5e06477834f51abf42ea4e8dc199632afc6afbfd8c44354685a271e9a48d2c0a'
37             '5e4088ad8d0853d390fa303f6be8c3f69c33834200cba9e90f7849f1993ca8d0'
38             '5557d8e601b17a80d1ea7de78a9869be69637cb6a02fbfe334e22fdf64e61d4c'
39             'd88be2b45b43605ff31dd83d6a138069b6c2e92bc8989b7b9ab9eba8da5f8c7b'
40             '6e13705ac4d6f69cdba118c6b70c722346fd3c45224133e6bbfe28aca719563c'
41             '2602314182524eab5655634fb4030213d3d63f66bf7b9287850bab76944315cf'
42             '89e43a0b7028f52d5c8e7fb961d962c4b4f4e9595880a6157274ddb2c7c0b6b4'
43             'b5b28f395583d141d88c0b955cd05124f9b8cdf003feab01e55885b8e8c1303e'
44             '618ac097441c1f2daffc9967e5c3cd18ea8866f776db62d04bf401c53907b1c9'
45             '450a4fd61a58af97329241ef2e199a68ab07ea2937c73c968469afc52fd9bc8d'
46             '889c92e34d11d2dada952adb1c364a48b7fdfcdc381cfff865ff96a348d19e80'
47             '51da5fdeaa2b56c1730e7a2abb46b956500368f6f563bf38a5979be8d9d28d33'
48             '290fc432fc3b4748acca48639538fa5c101d9d344911882c7952d83651cd57ad')
49
50 package() {
51   cd "$pkgdir"
52
53   # setup root filesystem
54   for d in boot dev etc home mnt usr var opt srv/http run; do
55     install -d -m755 $d
56   done
57   install -d -m555 proc
58   install -d -m555 sys
59   install -d -m0750 root
60   install -d -m1777 tmp
61   # vsftpd won't run with write perms on /srv/ftp
62   # ftp (uid 14/gid 11)
63   install -d -m555 -g 11 srv/ftp
64
65   # setup /etc and /usr/share/factory/etc
66   install -d etc/{ld.so.conf.d,skel,profile.d} usr/share/factory/etc
67   for f in fstab group host.conf hosts issue ld.so.conf motd nsswitch.conf \
68   passwd resolv.conf securetty shells profile letter-to-you; do
69     install -m644 "$srcdir"/$f etc/
70     install -m644 "$srcdir"/$f usr/share/factory/etc/
71   done
72   ln -s ../proc/self/mounts etc/mtab
73   for f in gshadow shadow crypttab; do
74     install -m600 "$srcdir"/$f etc/
75     install -m600 "$srcdir"/$f usr/share/factory/etc/
76   done
77   install -m644 "$srcdir"/locale.sh etc/profile.d/locale.sh
78   install -Dm644 "$srcdir"/os-release usr/lib/os-release
79
80   # setup /var
81   for d in cache local opt log/old lib/misc empty; do
82     install -d -m755 var/$d
83   done
84   install -d -m1777 var/{tmp,spool/mail}
85
86   # allow setgid games (gid 50) to write scores
87   install -d -m775 -g 50 var/games
88   ln -s spool/mail var/mail
89   ln -s ../run var/run
90   ln -s ../run/lock var/lock
91
92   # setup /usr hierarchy
93   for d in bin include lib share/{misc,pixmaps} src; do
94     install -d -m755 usr/$d
95   done
96   for d in {1..8}; do
97     install -d -m755 usr/share/man/man$d
98   done
99
100   # add lib symlinks
101   ln -s usr/lib lib
102   [[ $CARCH = 'x86_64' ]] && {
103     ln -s usr/lib lib64
104     ln -s lib usr/lib64
105   }
106
107   # add bin symlinks
108   ln -s usr/bin bin
109   ln -s usr/bin sbin
110   ln -s bin usr/sbin
111
112   # setup /usr/local hierarchy
113   for d in bin etc games include lib man sbin share src; do
114     install -d -m755 usr/local/$d
115   done
116   ln -s ../man usr/local/share/man
117
118   # setup systemd-sysctl
119   install -D -m644 "$srcdir"/sysctl usr/lib/sysctl.d/10-arch.conf
120
121   # setup systemd-sysusers
122   install -D -m644 "$srcdir"/sysusers usr/lib/sysusers.d/arch.conf
123
124   # setup systemd-tmpfiles
125   install -D -m644 "$srcdir"/tmpfiles usr/lib/tmpfiles.d/arch.conf
126
127   # setup systemd.environment-generator
128   install -D -m755 "$srcdir"/env-generator usr/lib/systemd/system-environment-generators/10-arch
129
130   # add logo
131   install -D -m644 "$srcdir"/archlinux{,-logo}.{svg,png} usr/share/pixmaps
132 }
133
134 # vim:set ts=2 sw=2 et: