OSDN Git Service

[update] : gconf
[alterlinux/alterlinux-pkgbuilds.git] / alter-stable / any / gconf / PKGBUILD
1 # Maintainer: João Figueiredo <jf dot mundox at gmail dot com>
2 # Contributor: Jan de Groot <jan@archlinux.org>
3
4 pkgname=gconf
5 pkgver=3.2.6+11+g07808097
6 pkgrel=9
7 pkgdesc="An obsolete configuration database system"
8 url="https://projects-old.gnome.org/gconf/"
9 arch=(x86_64)
10 license=(LGPL)
11 depends=(libxml2 polkit libldap dbus-glib python)
12 makedepends=(intltool gtk-doc gobject-introspection git gnome-common)
13 install=gconf.install
14 _commit=0780809731c8ab1c364202b1900d3df106b28626 # The latest and last commit, dug out from deep within the waves of time...
15 source=("git+https://gitlab.gnome.org/Archive/gconf.git#commit=$_commit"
16         01_xml-gettext-domain.patch gconf-reload.patch
17         gconf-merge-schema gconfpkg gconf-{install,remove}.hook)
18 sha256sums=('SKIP'
19             'c883dec2b96978874a53700cfe7f26f24f8296767203e970bc6402b4b9945eb8'
20             '567b78d8b4b4bbcb77c5f134d57bc503c34867fcc6341c0b01716bcaa4a21694'
21             'ee6b6e6f4975dad13a8c45f1c1f0547a99373bdecdcd6604bfc12965c328a028'
22             'bf1928718caa5df2b9e54a13cfd0f15a8fe0e09e86b84385ce023616a114e898'
23             '2732b2a6b187c5620105a036bde12edee99669605f70cbde56fe5f39619c3dc0'
24             '436a65ff290095bc3d35d7d6297cf4d647f61e9f9922cea7ef9f1e251b447ff7')
25
26 prepare() {
27   cd $pkgname
28
29   # Patch from fedora - reloads gconf after installing schemas
30   patch -Np1 -i ../gconf-reload.patch
31
32   # http://bugzilla.gnome.org/show_bug.cgi?id=568845
33   patch -Np1 -i ../01_xml-gettext-domain.patch
34
35   # The following line copied from Fedora
36   # https://src.fedoraproject.org/rpms/GConf2/blob/70ed26d67b563d858a84505622d11f41879a6b37/f/GConf2.spec#_90
37   2to3 --write --nobackup gsettings/gsettings-schema-convert
38
39   sed -i '1s|#!/usr/bin/env python$|#!/usr/bin/python|' gsettings/gsettings-schema-convert
40
41   NOCONFIGURE=1 ./autogen.sh
42 }
43
44 build() {
45   cd $pkgname
46   ./configure \
47     --prefix=/usr \
48     --sysconfdir=/etc \
49     --localstatedir=/var \
50     --libexecdir=/usr/lib \
51     --enable-defaults-service \
52     --disable-gtk-doc \
53     --disable-static \
54     --disable-orbit
55   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
56   make
57 }
58
59 check() {
60   cd $pkgname
61   make check
62 }
63
64 package() {
65   DESTDIR="$pkgdir" make -C $pkgname install
66
67   install -d "$pkgdir/etc/gconf/gconf.xml.system"
68   install -Dt "$pkgdir/usr/bin" gconf-merge-schema gconfpkg
69   install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 ./*.hook
70
71   # fix dbus policy location - --with-dbusdir doens't work
72   install -dm755 "$pkgdir/usr/share/dbus-1/system.d"
73   mv "$pkgdir"/etc/dbus-1/system.d/* "$pkgdir/usr/share/dbus-1/system.d"
74   rm -rf "$pkgdir/etc/dbus-1"
75 }