OSDN Git Service

added pm-wrapper-interface
[alterlinux/alterlinux-pkgbuilds.git] / alter-stable / any / gnome-shell-extension-dash-to-dock / PKGBUILD
1 # Maintainer: drakkan <nicola dot murino at gmail dot com>
2 # Contributor: XZS <d dot f dot fischer at web dot de>
3 # Contributor: Carl George < arch at cgtx dot us >
4 # Contributor: Janne Haapsaari <haaja@iki.fi>
5 # Contributor: Christopher Krooß <didi2002 at web.de>
6
7 pkgname=gnome-shell-extension-dash-to-dock
8 _pkgname=dash-to-dock
9 pkgver=69
10 pkgrel=1
11 pkgdesc="Move the dash out of the overview transforming it in a dock"
12 arch=('any')
13 url="https://micheleg.github.io/dash-to-dock/"
14 license=('GPL')
15 depends=('gnome-shell')
16 makedepends=('intltool' 'gettext' 'git')
17 _commit=71abe800b2bc0bca60c63c8e646db2a8a9827ddf
18 source=("git+https://github.com/micheleg/dash-to-dock.git#commit=$_commit")
19 sha256sums=('SKIP')
20
21 pkgver() {
22   cd "${srcdir}"/${_pkgname}
23   git describe --tags | sed 's/^extensions\.gnome\.org-v//g' | sed 's/-/+/g'
24 }
25
26 build() {
27   cd "${srcdir}"/${_pkgname}
28   make
29 }
30
31 package() {
32   cd "${srcdir}"/${_pkgname}
33   make DESTDIR="${pkgdir}" VERSION="${pkgver}" install
34 }
35
36 # vim:set ts=2 sw=2 et: