OSDN Git Service

19d9714d03f1b8e39a143dc3e2291d7db8ebf6c7
[alterlinux/alterlinux-pkgbuilds.git] / alter-stable / any / gnome-shell-extension-topicons-redux / PKGBUILD
1 # Maintainer: Leonidas spyropoulos <artafinde AT gmail DOT com>
2
3 pkgname=gnome-shell-extension-topicons-redux
4 _projectName=TopIcons-Redux
5 pkgver=6
6 pkgrel=1
7 pkgdesc='TopIcons Redux is a fork of TopIcons Plus'
8 arch=('any')
9 url="https://gitlab.com/pop-planet/${_projectName}"
10 license=('GPL')
11 depends=('gnome-shell')
12 makedepends=('git')
13 provides=('gnome-shell-extension-topicons-redux')
14 groups=('gnome-shell-extensions')
15 source=("git+https://gitlab.com/pop-planet/${_projectName}.git#tag=${pkgver}")
16 sha256sums=('SKIP')
17
18 build() {
19         cd "${_projectName}"
20         make build
21 }
22
23 package() {
24         cd "${_projectName}"
25         local uuid=$(grep -Po '(?<="uuid": ")[^"]*' _build/metadata.json)
26         local destdir="$pkgdir/usr/share/gnome-shell/extensions/$uuid"
27         install -dm755 "$destdir"
28         cp -r _build/* "$destdir"
29 }