OSDN Git Service

[add] : Added packages
[alterlinux/hayao-aur-packages.git] / indicator-kdeconnect / PKGBUILD
1 # Maintainer: aimileus <me at aimileus dot nl>
2 # Contributor: Sebastian Gumprich <aur at gumpri dot ch>
3 # Contributor: twa022
4 # Contributor: shimi <shimi.chen@gmail.com>
5 # Contributor: Gustavo Castro <gustawho at gmail dot com>
6 pkgname=indicator-kdeconnect
7 pkgver=0.9.4
8 pkgrel=1
9 epoch=1
10 pkgdesc="Integrate KDEConnect on desktop environments that use AppIndicators (e.g. Unity)"
11 arch=('x86_64')
12 url="https://github.com/bajoja/indicator-kdeconnect"
13 license=('LGPL')
14 depends=('libappindicator-gtk3' 'kdeconnect' 'python-requests-oauthlib' 'python-gobject')
15 makedepends=('cmake' 'vala')
16 source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Bajoja/indicator-kdeconnect/archive/${pkgver}.tar.gz")
17 sha256sums=('416510171e6c2a7a87f7b0b43e2ddf135b152952c5032aecd82880ba88f9c2e0')
18
19 build() {
20   cd "${pkgname}-${pkgver}"
21   [ ! -d build ] && mkdir build
22   cd build
23   cmake .. -DCMAKE_INSTALL_PREFIX=/usr
24   make
25 }
26
27 package() {
28   cd "${pkgname}-${pkgver}"/build
29   make DESTDIR="${pkgdir}" install
30 }