OSDN Git Service

57a09509377080f655fcb76c9d19704b0c33088c
[alterlinux/hayao-aur-packages.git] / pulseaudio-modules-bt / PKGBUILD
1 # Maintainer : Yamada Hayao <hayao@fascode.net>
2 # Contributor: EHfive <eh5@sokka.cn>
3
4 pkgname="pulseaudio-modules-bt"
5 pkgver="1.4"
6 pulseaudio_ver="13.99.2"
7 pkgrel="3"
8 pkgdesc="PulseAudio Bluetooth modules with SBC, AAC, APTX, APTX-HD, Sony LDAC (A2DP codec) support"
9 arch=("i686" "x86_64" "arm" "armv6h" "armv7h" "aarch64")
10 url="https://github.com/EHfive/pulseaudio-modules-bt"
11 license=('GPL3')
12 depends=("pulseaudio>=12.0" "bluez" "bluez-libs" "sbc" "libfdk-aac.so")
13 makedepends=("cmake>=3.0" "libavcodec.so>=58" "libldac" "git")
14 optdepends=("libavcodec.so>=58: aptX Classic, aptX HD support"
15             "libldac: LDAC support")
16 provides=("pulseaudio-bluetooth" "pulseaudio-modules-bt-git")
17 conflicts=("pulseaudio-bluetooth" "pulseaudio-modules-bt-git")
18
19 source=("https://github.com/EHfive/pulseaudio-modules-bt/archive/v${pkgver}.zip"
20         "https://github.com/pulseaudio/pulseaudio/archive/v${pulseaudio_ver}.zip")
21
22 md5sums=(
23     '711a7f930321e56706acdb441de0e432'
24     '6f04e194199f39ffba0b026a770e990d'
25 )
26
27 sha512sums=(
28     "5c3ed59dec46a1a9cc2f359ac1d28a82a50a5dea47a268a10601b95a8e17a68dd00ba7628c429271349bae290f461abeb1a4a3715b1833c71d7f82f9a902fe2d"
29     "61b24aac1b722cd611be88241551e6b345532b55d9f718ae784ec6eee135d7ba8460ea83b4c2de5b970e8af4af39c32255ff170f026156b0d22c988bc5499a6a"
30 )
31
32 prepare() {
33     cd "$srcdir/pulseaudio-modules-bt-${pkgver}"
34     rm -rf pa
35     ln -sf -T "../pulseaudio-${pulseaudio_ver}" "pa"
36     # git -C pa checkout v`pkg-config libpulse --modversion|sed 's/[^0-9.]*\([0-9.]*\).*/\1/'`
37 }
38
39 build() {
40     cd "$srcdir/pulseaudio-modules-bt-${pkgver}"
41     cmake \
42         -DCMAKE_BUILD_TYPE=Release \
43         .
44     make
45 }
46
47 package() {
48     cd "$srcdir/pulseaudio-modules-bt-${pkgver}"
49     make DESTDIR="$pkgdir" install
50 }