OSDN Git Service

Upload latest libVA library
[android-x86/hardware-intel-common-libva.git] / libva / debian / rules
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
8
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
11
12
13 # These are used for cross-compiling and for saving the configure script
14 # from having to guess our platform (since we know it already)
15 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
16 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
17
18
19 CFLAGS = -Wall -g
20
21 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
22         CFLAGS += -O0
23 else
24         CFLAGS += -O2
25 endif
26
27 # shared library versions, option 1
28 #version=2.0.5
29 #major=2
30 # option 2, assuming the library is created as src/.libs/libfoo.so.2.0.5 or so
31 version=`ls src/.libs/lib*.so.* | \
32  awk '{if (match($$0,/[0-9]+\.[0-9]+\.[0-9]+$$/)) print substr($$0,RSTART)}'`
33 #major=`ls src/.libs/lib*.so.* | \
34 # awk '{if (match($$0,/\.so\.[0-9]+$$/)) print substr($$0,RSTART+4)}'`
35
36 config.status: configure
37         dh_testdir
38         # Add here commands to configure the package.
39 ifneq "$(wildcard /usr/share/misc/config.sub)" ""
40         cp -f /usr/share/misc/config.sub config.sub
41 endif
42 ifneq "$(wildcard /usr/share/misc/config.guess)" ""
43         cp -f /usr/share/misc/config.guess config.guess
44 endif
45         ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info CFLAGS="$(CFLAGS)" LDFLAGS="-Wl,-z,defs"
46
47
48 build: build-stamp
49 build-stamp:  config.status
50         dh_testdir
51
52         # Add here commands to compile the package.
53         $(MAKE)
54
55         touch $@
56
57 clean:
58         dh_testdir
59         dh_testroot
60         rm -f build-stamp 
61
62         # Add here commands to clean up after the build process.
63         -$(MAKE) distclean
64         rm -f config.sub config.guess
65
66         dh_clean 
67
68 install: build
69         dh_testdir
70         dh_testroot
71         dh_clean -k 
72         dh_installdirs
73
74         # Add here commands to install the package into debian/tmp
75         $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
76
77
78 # Build architecture-independent files here.
79 binary-indep: build install
80 # We have nothing to do by default.
81
82 # Build architecture-dependent files here.
83 binary-arch: build install
84         dh_testdir
85         dh_testroot
86         dh_installchangelogs 
87         dh_installdocs
88         dh_installexamples
89         dh_install
90 #       dh_installmenu
91 #       dh_installdebconf       
92 #       dh_installlogrotate
93 #       dh_installemacsen
94 #       dh_installpam
95 #       dh_installmime
96 #       dh_installinit
97 #       dh_installcron
98 #       dh_installinfo
99         dh_installman
100         dh_link
101         dh_strip
102         dh_compress
103         dh_fixperms
104 #       dh_perl
105 #       dh_python
106 #       dh_makeshlibs
107         dh_installdeb
108         dh_shlibdeps
109         dh_gencontrol
110         dh_md5sums
111         dh_builddeb
112
113 binary: binary-indep binary-arch
114 .PHONY: build clean binary-indep binary-arch binary install