OSDN Git Service

Remove the set cpu count option as it doesn't do anything now
[handbrake-jp/handbrake-jp-git.git] / gtk / ghb.spec
1
2 Name:           %{name}
3 Version:        %{version}
4 Release:        %{release}%{?dist}
5 Summary:        A program to transcode DVDs and other sources to MPEG-4
6
7 Group:          Applications/Multimedia
8 License:        GPLv2
9 URL:            http://handbrake.fr/
10 Source0:        %{name}-%{version}.tar.bz2
11 Prefix:         %{_prefix}
12 BuildRoot:      %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
13 BuildRequires: glib2-devel, gtk2-devel, webkitgtk-devel
14 BuildRequires: gstreamer-devel, gstreamer-plugins-base-devel, libgudev1-devel
15 BuildRequires: bzip2-devel, intltool, libnotify-devel, libtool, yasm
16 Requires:       gtk2, coreutils
17
18 %define debug_package %{nil}
19
20 %description
21 HandBrake is an open-source, GPL-licensed, multi-platform, multi-threaded 
22 transcoder, available for MacOS X, Linux and Windows.
23
24 %package gui
25 Summary:        A program to transcode DVDs and other sources to MPEG-4
26 Group:          Applications/Multimedia
27
28 %package cli
29 Summary:        A program to transcode DVDs and other sources to MPEG-4
30 Group:          Applications/Multimedia
31
32 %description gui
33 HandBrake is an open-source, GPL-licensed, multi-platform, multi-threaded 
34 transcoder, available for MacOS X, Linux and Windows.
35
36 %description cli
37 HandBrake is an open-source, GPL-licensed, multi-platform, multi-threaded 
38 transcoder, available for MacOS X, Linux and Windows.
39
40 %prep
41 %setup -q
42 cd %{_builddir}/%{name}-%{version}
43
44
45 %build
46 ./configure --debug=std --prefix=%{_prefix}
47 make %{?_smp_mflags} -C build
48
49
50 %install
51 make -C build DESTDIR=$RPM_BUILD_ROOT install-strip
52
53 ## blow away stuff we don't want
54 /bin/rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
55
56 %clean
57 rm -rf %{buildroot}
58
59 %post gui
60 touch --no-create %{_datadir}/icons/hicolor
61 if [ -x /usr/bin/gtk-update-icon-cache ]; then
62   gtk-update-icon-cache -q %{_datadir}/icons/hicolor
63 fi
64
65 %postun gui
66 touch --no-create %{_datadir}/icons/hicolor
67 if [ -x /usr/bin/gtk-update-icon-cache ]; then
68   gtk-update-icon-cache -q %{_datadir}/icons/hicolor
69 fi
70
71 %files gui
72 %defattr(-,root,root,-)
73 %doc NEWS AUTHORS CREDITS THANKS COPYING
74 %{_datadir}/icons/hicolor
75 %{_datadir}/applications
76 %{_bindir}/ghb
77
78 %files cli
79 %defattr(-,root,root,-)
80 %doc NEWS AUTHORS CREDITS THANKS COPYING
81 %{_bindir}/HandBrakeCLI
82
83 %changelog
84 * Sun Apr 11 2010 John Stebbins <jstebbins@jetheaddev.com> - svn
85 - Snapshot release
86
87