OSDN Git Service

v3.0.0 Alpha5 OSDN最終版
[hengband/hengband.git] / src / Makefile.am
index c4e6f3a..a564cee 100644 (file)
@@ -20,26 +20,20 @@ hengband_SOURCES = \
        \
        artifact/artifact-info.c artifact/artifact-info.h \
        artifact/fixed-art-generator.c artifact/fixed-art-generator.h \
+       artifact/fixed-art-types.h \
        artifact/random-art-activation.c artifact/random-art-activation.h \
        artifact/random-art-bias-types.h \
        artifact/random-art-characteristics.c artifact/random-art-characteristics.h \
+       artifact/random-art-effects.h \
        artifact/random-art-generator.c artifact/random-art-generator.h \
        artifact/random-art-misc.c artifact/random-art-misc.h \
        artifact/random-art-pval-investor.c artifact/random-art-pval-investor.h \
        artifact/random-art-resistance.c artifact/random-art-resistance.h \
        artifact/random-art-slay.c artifact/random-art-slay.h \
        \
-       art-definition/art-accessory-types.h \
-       art-definition/art-armor-types.h \
-       art-definition/art-bow-types.h \
-       art-definition/art-protector-types.h \
-       art-definition/art-sword-types.h \
-       art-definition/art-weapon-types.h \
-       art-definition/random-art-effects.h \
-       \
        autopick/autopick.c autopick/autopick.h \
        autopick/autopick-commands-table.h autopick/autopick-dirty-flags.h \
-       autopick/autopick-editor-table.h autopick/autopick-flags-table.h \
+       autopick/autopick-flags-table.h \
        autopick/autopick-key-flag-process.h autopick/autopick-keys-table.h \
        autopick/autopick-menu-data-table.c autopick/autopick-menu-data-table.h \
        autopick/autopick-methods-table.h \
@@ -158,6 +152,7 @@ hengband_SOURCES = \
        core/hp-mp-processor.c core/hp-mp-processor.h \
        core/hp-mp-regenerator.c core/hp-mp-regenerator.h \
        core/magic-effects-timeout-reducer.c core/magic-effects-timeout-reducer.h \
+       core/object-compressor.c core/object-compressor.h \
        core/output-updater.c core/output-updater.h \
        core/player-processor.c core/player-processor.h \
        core/player-redraw-types.h \
@@ -166,7 +161,6 @@ hengband_SOURCES = \
        core/show-file.c core/show-file.h \
        core/special-internal-keys.h \
        core/speed-table.c core/speed-table.h \
-       core/status-reseter.c core/status-reseter.h \
        core/stuff-handler.c core/stuff-handler.h \
        core/turn-compensator.c core/turn-compensator.h \
        core/visuals-reseter.c core/visuals-reseter.h \
@@ -215,7 +209,6 @@ hengband_SOURCES = \
        floor/cave-generator.c floor/cave-generator.h \
        floor/dungeon-tunnel-util.c floor/dungeon-tunnel-util.h \
        floor/fixed-map-generator.c floor/fixed-map-generator.h \
-       floor/floor.c floor/floor.h \
        floor/floor-allocation-types.h \
        floor/floor-base-definitions.h \
        floor/floor-changer.c floor/floor-changer.h \
@@ -261,6 +254,8 @@ hengband_SOURCES = \
        grid/feature.c grid/feature.h \
        grid/grid.c grid/grid.h \
        grid/lighting-colors-table.c grid/lighting-colors-table.h \
+       grid/object-placer.c grid/object-placer.h \
+       grid/stair.c grid/stair.h \
        grid/trap.c grid/trap.h \
        \
        info-reader/artifact-reader.c info-reader/artifact-reader.h \
@@ -295,7 +290,6 @@ hengband_SOURCES = \
        inventory/player-inventory.c inventory/player-inventory.h \
        inventory/recharge-processor.c inventory/recharge-processor.h \
        \
-       io/chuukei.c io/chuukei.h \
        io/command-repeater.c io/command-repeater.h \
        io/cursor.c io/cursor.h \
        io/exit-panic.c io/exit-panic.h \
@@ -309,6 +303,7 @@ hengband_SOURCES = \
        io/mutations-dump.c io/mutations-dump.h \
        io/pref-file-expressor.c io/pref-file-expressor.h \
        io/read-pref-file.c io/read-pref-file.h \
+       io/record-play-movie.c io/record-play-movie.h \
        io/report.c io/report.h \
        io/screen-util.c io/screen-util.h \
        io/signal-handlers.c io/signal-handlers.h \
@@ -377,7 +372,11 @@ hengband_SOURCES = \
        \
        main.c main-x11.c main-gcu.c \
        \
-       main/init.c main/init.h \
+       main/angband-headers.c main/angband-headers.h \
+       main/angband-initializer.c main/angband-initializer.h \
+       main/game-data-initializer.c main/game-data-initializer.h \
+       main/info-initializer.c main/info-initializer.h \
+       main/init-error-messages-table.c main/init-error-messages-table.h \
        main/music-definitions-table.c main/music-definitions-table.h \
        main/sound-definitions-table.c main/sound-definitions-table.h \
        main/sound-of-music.c main/sound-of-music.h \
@@ -385,6 +384,7 @@ hengband_SOURCES = \
        main/x11-type-string.c main/x11-type-string.h \
        \
        market/arena-info-table.c market/arena-info-table.h \
+       market/building-initializer.c market/building-initializer.h \
        market/building-util.c market/building-util.h \
        market/play-gamble.c market/play-gamble.h \
        market/poker.c market/poker.h \
@@ -412,13 +412,17 @@ hengband_SOURCES = \
        melee/melee-util.c melee/melee-util.h \
        \
        mind/drs-types.h \
+       mind/mind-archer.c mind/mind-archer.h \
        mind/mind-berserker.c mind/mind-berserker.h \
        mind/mind-blue-mage.c mind/mind-blue-mage.h \
        mind/mind-cavalry.c mind/mind-cavalry.h \
+       mind/mind-chaos-warrior.c mind/mind-chaos-warrior.h \
        mind/mind-explanations-table.c mind/mind-explanations-table.h \
        mind/mind-force-trainer.c mind/mind-force-trainer.h \
        mind/mind-info.c mind/mind-info.h \
+       mind/mind-hobbit.c mind/mind-hobbit.h \
        mind/mind-mage.c mind/mind-mage.h \
+       mind/mind-magic-eater.c mind/mind-magic-eater.h \
        mind/mind-magic-resistance.c mind/mind-magic-resistance.h \
        mind/mind-mindcrafter.c mind/mind-mindcrafter.h \
        mind/mind-mirror-master.c mind/mind-mirror-master.h \
@@ -426,6 +430,7 @@ hengband_SOURCES = \
        mind/mind-ninja.c mind/mind-ninja.h \
        mind/mind-numbers.h \
        mind/mind-power-getter.c mind/mind-power-getter.h \
+       mind/mind-priest.c mind/mind-priest.h \
        mind/mind-samurai.c mind/mind-samurai.h \
        mind/mind-sniper.c mind/mind-sniper.h \
        mind/mind-types.h \
@@ -455,6 +460,7 @@ hengband_SOURCES = \
        monster-attack/insults-moans.c monster-attack/insults-moans.h \
        monster-attack/monster-attack-describer.c monster-attack/monster-attack-describer.h \
        monster-attack/monster-attack-effect.h \
+       monster-attack/monster-attack-lose.c monster-attack/monster-attack-lose.h \
        monster-attack/monster-attack-player.c monster-attack/monster-attack-player.h \
        monster-attack/monster-attack-processor.c monster-attack/monster-attack-processor.h \
        monster-attack/monster-attack-status.c monster-attack/monster-attack-status.h \
@@ -464,6 +470,7 @@ hengband_SOURCES = \
        monster-attack/monster-eating.c monster-attack/monster-eating.h \
        \
        monster-floor/monster-death.c monster-floor/monster-death.h \
+       monster-floor/monster-death-util.c monster-floor/monster-death-util.h \
        monster-floor/monster-direction.c monster-floor/monster-direction.h \
        monster-floor/monster-dist-offsets.c monster-floor/monster-dist-offsets.h \
        monster-floor/monster-generator.c monster-floor/monster-generator.h \
@@ -479,6 +486,7 @@ hengband_SOURCES = \
        monster-floor/one-monster-placer.c monster-floor/one-monster-placer.h \
        monster-floor/place-monster-types.h \
        monster-floor/quantum-effect.c monster-floor/quantum-effect.h \
+       monster-floor/special-death-switcher.c monster-floor/special-death-switcher.h \
        \
        monster-race/monster-race.c monster-race/monster-race.h \
        monster-race/monster-race-hook.c monster-race/monster-race-hook.h \
@@ -553,6 +561,7 @@ hengband_SOURCES = \
        object-activation/activation-resistance.c object-activation/activation-resistance.h \
        object-activation/activation-switcher.c object-activation/activation-switcher.h \
        object-activation/activation-teleport.c object-activation/activation-teleport.h \
+       object-activation/activation-util.c object-activation/activation-util.h \
        \
        object-enchant/activation-info-table.c object-enchant/activation-info-table.h \
        object-enchant/apply-magic.c object-enchant/apply-magic.h \
@@ -591,7 +600,6 @@ hengband_SOURCES = \
        pet/pet-util.c pet/pet-util.h \
        \
        player/attack-defense-types.h \
-       player/avatar.h player/avatar.c \
        player/eldritch-horror.c player/eldritch-horror.h \
        player/mimic-info-table.c player/mimic-info-table.h \
        player/patron.c player/patron.h \
@@ -614,10 +622,10 @@ hengband_SOURCES = \
        player/player-status.c player/player-status.h \
        player/player-status-flags.c player/player-status-flags.h \
        player/player-status-table.c player/player-status-table.h \
+       player/player-status-resist.c player/player-status-resist.h \
        player/player-personalities-types.h \
        player/player-sex.c player/player-sex.h \
        player/player-view.c player/player-view.h \
-       player/selfinfo.c player/selfinfo.h \
        player/special-defense-types.h \
        \
        player-attack/player-attack-util.h \
@@ -625,6 +633,18 @@ hengband_SOURCES = \
        player-attack/blood-sucking-processor.c player-attack/blood-sucking-processor.h \
        player-attack/player-attack.c player-attack/player-attack.h \
        \
+       player-info/avatar.h player-info/avatar.c \
+       player-info/base-status-info.c player-info/base-status-info.h \
+       player-info/base-status-types.h \
+       player-info/body-improvement-info.c player-info/body-improvement-info.h \
+       player-info/class-ability-info.c player-info/class-ability-info.h \
+       player-info/mutation-info.c player-info/mutation-info.h \
+       player-info/race-ability-info.c player-info/race-ability-info.h \
+       player-info/resistance-info.c player-info/resistance-info.h \
+       player-info/self-info.c player-info/self-info.h \
+       player-info/self-info-util.c player-info/self-info-util.h \
+       player-info/weapon-effect-info.c player-info/weapon-effect-info.h \
+       \
        racial/class-racial-switcher.c racial/class-racial-switcher.h \
        racial/mutation-racial-selector.c racial/mutation-racial-selector.h \
        racial/race-racial-command-setter.c racial/race-racial-command-setter.h \
@@ -703,6 +723,7 @@ hengband_SOURCES = \
        spell/spells-summon.c spell/spells-summon.h \
        spell/spells-status.c spell/spells-status.h \
        spell/spell-types.h spell/spells-util.h \
+       spell/summon-types.h \
        spell/technic-info-table.c spell/technic-info-table.h \
        \
        spell-kind/blood-curse.c spell-kind/blood-curse.h \
@@ -730,11 +751,13 @@ hengband_SOURCES = \
        spell-kind/spells-teleport.c spell-kind/spells-teleport.h \
        spell-kind/spells-world.c spell-kind/spells-world.h \
        \
+       spell-realm/spells-arcane.c spell-realm/spells-arcane.h \
        spell-realm/spells-chaos.c spell-realm/spells-chaos.h \
        spell-realm/spells-craft.c spell-realm/spells-craft.h \
        spell-realm/spells-crusade.c spell-realm/spells-crusade.h \
        spell-realm/spells-demon.c spell-realm/spells-demon.h \
        spell-realm/spells-hex.c spell-realm/spells-hex.h \
+       spell-realm/spells-nature.c spell-realm/spells-nature.h \
        spell-realm/spells-song.c spell-realm/spells-song.h \
        spell-realm/spells-sorcery.c spell-realm/spells-sorcery.h \
        spell-realm/spells-trump.c spell-realm/spells-trump.h \
@@ -776,7 +799,8 @@ hengband_SOURCES = \
        \
        system/alloc-entries.c system/alloc-entries.h \
        system/alloc-entry-definition.h \
-       system/angband.h system/angband-version.h \
+       system/angband.h \
+       system/angband-version.c system/angband-version.h \
        system/artifact-type-definition.c system/artifact-type-definition.h \
        system/building-type-definition.c system/building-type-definition.h \
        system/dungeon-data-definition.h \
@@ -791,7 +815,7 @@ hengband_SOURCES = \
        system/gamevalue.h \
        \
        target/grid-selector.c target/grid-selector.h \
-       target/projection-path-calculator.c target/projection-path-calculator.h
+       target/projection-path-calculator.c target/projection-path-calculator.h \
        target/target-checker.c target/target-checker.h \
        target/target-describer.c target/target-describer.h \
        target/target-getter.c target/target-getter.h \
@@ -832,6 +856,7 @@ hengband_SOURCES = \
        view/display-player-misc-info.c view/display-player-misc-info.h \
        view/display-player-middle.c view/display-player-middle.h \
        view/display-player.c view/display-player.h \
+       view/display-self-info.c view/display-self-info.h \
        view/display-store.c view/display-store.h \
        view/display-util.c view/display-util.h \
        view/object-describer.c view/object-describer.h \
@@ -874,70 +899,9 @@ EXTRA_hengband_SOURCES = \
 EXTRA_DIST = \
        gcc-wrap
 
-DEFAULT_INCLUDES = -I$(srcdir) \
-       -I$(srcdir)/artifact \
-       -I$(srcdir)/art-definition \
-       -I$(srcdir)/autopick \
-       -I$(srcdir)/birth \
-       -I$(srcdir)/blue-magic \
-       -I$(srcdir)/cmd-action \
-       -I$(srcdir)/cmd-building \
-       -I$(srcdir)/cmd-io \
-       -I$(srcdir)/cmd-item \
-       -I$(srcdir)/cmd-visual \
-       -I$(srcdir)/combat \
-       -I$(srcdir)/core \
-       -I$(srcdir)/dungeon \
-       -I$(srcdir)/effect \
-       -I$(srcdir)/flavor \
-       -I$(srcdir)/floor \
-       -I$(srcdir)/game-option \
-       -I$(srcdir)/grid \
-       -I$(srcdir)/info-reader \
-       -I$(srcdir)/inventory \
-       -I$(srcdir)/io \
-       -I$(srcdir)/io-dump \
-       -I$(srcdir)/knowledge \
-       -I$(srcdir)/load \
-       -I$(srcdir)/lore \
-       -I$(srcdir)/market \
-       -I$(srcdir)/melee \
-       -I$(srcdir)/mind \
-       -I$(srcdir)/monster \
-       -I$(srcdir)/monster-attack \
-       -I$(srcdir)/monster-floor \
-       -I$(srcdir)/monster-race \
-       -I$(srcdir)/mspell \
-       -I$(srcdir)/mutation \
-       -I$(srcdir)/object \
-       -I$(srcdir)/object-activation \
-       -I$(srcdir)/object-enchant \
-       -I$(srcdir)/object-hook \
-       -I$(srcdir)/object-use \
-       -I$(srcdir)/pet \
-       -I$(srcdir)/player \
-       -I$(srcdir)/player-attack \
-       -I$(srcdir)/racial \
-       -I$(srcdir)/realm \
-       -I$(srcdir)/room \
-       -I$(srcdir)/save \
-       -I$(srcdir)/specific-object \
-       -I$(srcdir)/spell \
-       -I$(srcdir)/spell-kind \
-       -I$(srcdir)/spell-realm \
-       -I$(srcdir)/status \
-       -I$(srcdir)/sv-definition \
-       -I$(srcdir)/system \
-       -I$(srcdir)/target \
-       -I$(srcdir)/term \
-       -I$(srcdir)/util \
-       -I$(srcdir)/view \
-       -I$(srcdir)/window \
-       -I$(srcdir)/wizard \
-       -I$(srcdir)/world \
-       -I$(top_builddir)/src 
-CFLAGS += $(XFT_CFLAGS)
-LIBS += $(XFT_LIBS)
+DEFAULT_INCLUDES = -I$(srcdir) -I$(top_builddir)/src 
+CFLAGS += $(XFT_CFLAGS) $(libcurl_CFLAGS)
+LIBS += $(XFT_LIBS) $(libcurl_LIBS)
 COMPILE = $(srcdir)/gcc-wrap $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
        $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)