OSDN Git Service

v3.0.0 Alpha5 OSDN最終版
[hengband/hengband.git] / src / Makefile.am
index dc778dd..a564cee 100644 (file)
@@ -20,26 +20,20 @@ hengband_SOURCES = \
        \
        artifact/artifact-info.c artifact/artifact-info.h \
        artifact/fixed-art-generator.c artifact/fixed-art-generator.h \
+       artifact/fixed-art-types.h \
        artifact/random-art-activation.c artifact/random-art-activation.h \
        artifact/random-art-bias-types.h \
        artifact/random-art-characteristics.c artifact/random-art-characteristics.h \
+       artifact/random-art-effects.h \
        artifact/random-art-generator.c artifact/random-art-generator.h \
        artifact/random-art-misc.c artifact/random-art-misc.h \
        artifact/random-art-pval-investor.c artifact/random-art-pval-investor.h \
        artifact/random-art-resistance.c artifact/random-art-resistance.h \
        artifact/random-art-slay.c artifact/random-art-slay.h \
        \
-       art-definition/art-accessory-types.h \
-       art-definition/art-armor-types.h \
-       art-definition/art-bow-types.h \
-       art-definition/art-protector-types.h \
-       art-definition/art-sword-types.h \
-       art-definition/art-weapon-types.h \
-       art-definition/random-art-effects.h \
-       \
        autopick/autopick.c autopick/autopick.h \
        autopick/autopick-commands-table.h autopick/autopick-dirty-flags.h \
-       autopick/autopick-editor-table.h autopick/autopick-flags-table.h \
+       autopick/autopick-flags-table.h \
        autopick/autopick-key-flag-process.h autopick/autopick-keys-table.h \
        autopick/autopick-menu-data-table.c autopick/autopick-menu-data-table.h \
        autopick/autopick-methods-table.h \
@@ -296,7 +290,6 @@ hengband_SOURCES = \
        inventory/player-inventory.c inventory/player-inventory.h \
        inventory/recharge-processor.c inventory/recharge-processor.h \
        \
-       io/chuukei.c io/chuukei.h \
        io/command-repeater.c io/command-repeater.h \
        io/cursor.c io/cursor.h \
        io/exit-panic.c io/exit-panic.h \
@@ -310,6 +303,7 @@ hengband_SOURCES = \
        io/mutations-dump.c io/mutations-dump.h \
        io/pref-file-expressor.c io/pref-file-expressor.h \
        io/read-pref-file.c io/read-pref-file.h \
+       io/record-play-movie.c io/record-play-movie.h \
        io/report.c io/report.h \
        io/screen-util.c io/screen-util.h \
        io/signal-handlers.c io/signal-handlers.h \
@@ -466,6 +460,7 @@ hengband_SOURCES = \
        monster-attack/insults-moans.c monster-attack/insults-moans.h \
        monster-attack/monster-attack-describer.c monster-attack/monster-attack-describer.h \
        monster-attack/monster-attack-effect.h \
+       monster-attack/monster-attack-lose.c monster-attack/monster-attack-lose.h \
        monster-attack/monster-attack-player.c monster-attack/monster-attack-player.h \
        monster-attack/monster-attack-processor.c monster-attack/monster-attack-processor.h \
        monster-attack/monster-attack-status.c monster-attack/monster-attack-status.h \
@@ -627,6 +622,7 @@ hengband_SOURCES = \
        player/player-status.c player/player-status.h \
        player/player-status-flags.c player/player-status-flags.h \
        player/player-status-table.c player/player-status-table.h \
+       player/player-status-resist.c player/player-status-resist.h \
        player/player-personalities-types.h \
        player/player-sex.c player/player-sex.h \
        player/player-view.c player/player-view.h \
@@ -803,7 +799,8 @@ hengband_SOURCES = \
        \
        system/alloc-entries.c system/alloc-entries.h \
        system/alloc-entry-definition.h \
-       system/angband.h system/angband-version.h \
+       system/angband.h \
+       system/angband-version.c system/angband-version.h \
        system/artifact-type-definition.c system/artifact-type-definition.h \
        system/building-type-definition.c system/building-type-definition.h \
        system/dungeon-data-definition.h \
@@ -902,71 +899,9 @@ EXTRA_hengband_SOURCES = \
 EXTRA_DIST = \
        gcc-wrap
 
-DEFAULT_INCLUDES = -I$(srcdir) \
-       -I$(srcdir)/artifact \
-       -I$(srcdir)/art-definition \
-       -I$(srcdir)/autopick \
-       -I$(srcdir)/birth \
-       -I$(srcdir)/blue-magic \
-       -I$(srcdir)/cmd-action \
-       -I$(srcdir)/cmd-building \
-       -I$(srcdir)/cmd-io \
-       -I$(srcdir)/cmd-item \
-       -I$(srcdir)/cmd-visual \
-       -I$(srcdir)/combat \
-       -I$(srcdir)/core \
-       -I$(srcdir)/dungeon \
-       -I$(srcdir)/effect \
-       -I$(srcdir)/flavor \
-       -I$(srcdir)/floor \
-       -I$(srcdir)/game-option \
-       -I$(srcdir)/grid \
-       -I$(srcdir)/info-reader \
-       -I$(srcdir)/inventory \
-       -I$(srcdir)/io \
-       -I$(srcdir)/io-dump \
-       -I$(srcdir)/knowledge \
-       -I$(srcdir)/load \
-       -I$(srcdir)/lore \
-       -I$(srcdir)/market \
-       -I$(srcdir)/melee \
-       -I$(srcdir)/mind \
-       -I$(srcdir)/monster \
-       -I$(srcdir)/monster-attack \
-       -I$(srcdir)/monster-floor \
-       -I$(srcdir)/monster-race \
-       -I$(srcdir)/mspell \
-       -I$(srcdir)/mutation \
-       -I$(srcdir)/object \
-       -I$(srcdir)/object-activation \
-       -I$(srcdir)/object-enchant \
-       -I$(srcdir)/object-hook \
-       -I$(srcdir)/object-use \
-       -I$(srcdir)/pet \
-       -I$(srcdir)/player \
-       -I$(srcdir)/player-attack \
-       -I$(srcdir)/player-info \
-       -I$(srcdir)/racial \
-       -I$(srcdir)/realm \
-       -I$(srcdir)/room \
-       -I$(srcdir)/save \
-       -I$(srcdir)/specific-object \
-       -I$(srcdir)/spell \
-       -I$(srcdir)/spell-kind \
-       -I$(srcdir)/spell-realm \
-       -I$(srcdir)/status \
-       -I$(srcdir)/sv-definition \
-       -I$(srcdir)/system \
-       -I$(srcdir)/target \
-       -I$(srcdir)/term \
-       -I$(srcdir)/util \
-       -I$(srcdir)/view \
-       -I$(srcdir)/window \
-       -I$(srcdir)/wizard \
-       -I$(srcdir)/world \
-       -I$(top_builddir)/src 
-CFLAGS += $(XFT_CFLAGS)
-LIBS += $(XFT_LIBS)
+DEFAULT_INCLUDES = -I$(srcdir) -I$(top_builddir)/src 
+CFLAGS += $(XFT_CFLAGS) $(libcurl_CFLAGS)
+LIBS += $(XFT_LIBS) $(libcurl_LIBS)
 COMPILE = $(srcdir)/gcc-wrap $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
        $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)