OSDN Git Service

Merge branch 'master' of https://github.com/hengband/hengband
[hengbandforosx/hengbandosx.git] / hengband.spec
1 %define version 3.0.1.6
2 %define release 1
3
4 Summary: hengband %{version}
5 Name: hengband
6 Version: %{version}
7 Release: %{release}
8 License: unknown
9 Group: Amusements/Games
10 Url: https://hengband.github.io
11 Source: hengband-%{version}.tar.gz
12 Requires: ncurses-libs libstdc++ libcurl libX11
13 BuildRequires: autoconf automake gcc-c++ ncurses-devel libcurl-devel nkf libX11-devel
14
15 %description
16 Hengband is a variant of ZAngband.
17
18 Official page is this,
19 https://hengband.github.io
20
21 More infomation is /usr/share/doc/hengband/readme-eng.md
22
23 Summary(ja): 変愚蛮怒 %{version}
24
25 %description -l ja
26 変愚蛮怒は Angband のバリアントです。
27
28 本ソフトウェアの最新版は以下の場所から入手できます。
29 https://hengband.github.io
30
31 詳しくは /usr/share/doc/hengband/readme.md を参照。
32
33 %prep
34 rm -rf %{buildroot}
35
36 %setup -n %{name}-%{version}
37 ./bootstrap
38
39 %build
40 %configure --with-libpath=%{_datadir}/games/hengband/lib
41 %make_build
42
43 %install
44 mkdir -p %{buildroot}/%{_bindir}
45 mkdir -p %{buildroot}/%{_datadir}/games/hengband
46 %make_install bindir=%{_bindir}
47 cp -R lib/ -p %{buildroot}/%{_datadir}/games/hengband/
48 find %{buildroot}/%{_datadir}/games/hengband/ -type f -name "Makefile*" -exec rm {} \;
49 find %{buildroot}/%{_datadir}/games/hengband/ -type f -name "delete.me*" -exec rm {} \;
50 find %{buildroot}/%{_datadir}/games/hengband/ -name ".git*" -exec rm -rf {} \;
51 rm -rf %{buildroot}/%{_datadir}/games/hengband/lib/xtra/{sound,music}
52 touch %{buildroot}/%{_datadir}/games/hengband/lib/apex/scores.raw
53
54 %clean
55 rm -rf %{buildroot}
56
57 %preun
58 if [ -e %{_datadir}/games/hengband/lib/data/f_info_j.raw ]
59 then
60 rm -rf %{_datadir}/games/hengband/lib/data/*.raw
61 fi
62 exit 0
63
64 %files
65 %defattr(-,root,root)
66 %attr(2755,root,games) %{_bindir}/hengband
67 %dir %{_datadir}/games/hengband/lib
68 %attr(775,root,games) %dir %{_datadir}/games/hengband/lib/apex
69 %attr(775,root,games) %dir %{_datadir}/games/hengband/lib/bone
70 %attr(775,root,games) %dir %{_datadir}/games/hengband/lib/data
71 %dir %{_datadir}/games/hengband/lib/edit
72 %dir %{_datadir}/games/hengband/lib/file
73 %dir %{_datadir}/games/hengband/lib/file/books
74 %dir %{_datadir}/games/hengband/lib/help
75 %dir %{_datadir}/games/hengband/lib/info
76 %dir %{_datadir}/games/hengband/lib/pref
77 %attr(775,root,games) %dir %{_datadir}/games/hengband/lib/save
78 %dir %{_datadir}/games/hengband/lib/script
79 %dir %{_datadir}/games/hengband/lib/user
80 %dir %{_datadir}/games/hengband/lib/xtra
81 %dir %{_datadir}/games/hengband/lib/xtra/graf
82 %{_datadir}/games/hengband/lib/apex/h_scores.raw
83 %{_datadir}/games/hengband/lib/apex/readme.txt
84 %attr(664 root,games) %config(noreplace) %{_datadir}/games/hengband/lib/apex/scores.raw
85 %{_datadir}/games/hengband/lib/edit/*.txt
86 %{_datadir}/games/hengband/lib/edit/quests/*.txt
87 %{_datadir}/games/hengband/lib/edit/towns/*.txt
88 %{_datadir}/games/hengband/lib/file/*.txt
89 %{_datadir}/games/hengband/lib/file/books/*.txt
90 %{_datadir}/games/hengband/lib/help/*.hlp
91 %{_datadir}/games/hengband/lib/help/*.txt
92 %{_datadir}/games/hengband/lib/pref/*.prf
93 %{_datadir}/games/hengband/lib/xtra/graf/8x8.bmp
94 %doc readme.md readme_angband readme-eng.md
95 %license lib/help/jlicense.txt
96
97 %changelog
98 * Mon Jan 22 2024 Shiro Hara <white@vx-xv.com>
99 - hengband RPM 3.0.1.6(Beta)
100
101 * Tue Jan 09 2024 Shiro Hara <white@vx-xv.com>
102 - hengband RPM 3.0.1.5(Beta)
103
104 * Wed Dec 27 2023 Shiro Hara <white@vx-xv.com>
105 - hengband RPM 3.0.1.4(Beta)
106
107 * Mon Dec 11 2023 Shiro Hara <white@vx-xv.com>
108 - hengband RPM 3.0.1.3(Beta)
109
110 * Mon Nov 27 2023 Shiro Hara <white@vx-xv.com>
111 - hengband RPM 3.0.1.2(Beta)
112
113 * Fri Nov 17 2023 Shiro Hara <white@vx-xv.com>
114 - hengband RPM 3.0.1.1(Beta)
115
116 * Mon Oct 30 2023 Shiro Hara <white@vx-xv.com>
117 - hengband RPM 3.0.1.0(Beta)
118
119 * Sun Oct 22 2023 Shiro Hara <white@vx-xv.com>
120 - Fix the graphic mode is not available on X11
121
122 * Wed Oct 18 2023 Shiro Hara <white@vx-xv.com>
123 - hengband RPM 3.0.0.91(Alpha)
124
125 * Mon Oct 16 2023 Shiro Hara <white@vx-xv.com>
126 - hengband RPM 3.0.0.90(Alpha)
127
128 * Tue Aug 8 2023 Shiro Hara <white@vx-xv.com>
129 - hengband RPM 3.0.0.89(Alpha)
130
131 * Mon Jul 24 2023 Shiro Hara <white@vx-xv.com>
132 - Enable X11
133
134 * Sun Jul 23 2023 Shiro Hara <white@vx-xv.com>
135 - hengband RPM 3.0.0.88(Alpha)
136
137 * Sun Jul 09 2023 Shiro Hara <white@vx-xv.com>
138 - hengband RPM 3.0.0.87(Alpha)
139
140 * Mon Jun 26 2023 Shiro Hara <white@vx-xv.com>
141 - hengband RPM 3.0.0.86(Alpha)
142
143 * Wed Jun 14 2023 Shiro Hara <white@vx-xv.com>
144 - hengband RPM 3.0.0.85(Alpha)
145
146 * Mon May 29 2023 Shiro Hara <white@vx-xv.com>
147 - hengband RPM 3.0.0Alpha release 84
148
149 * Wed May 17 2023 Shiro Hara <white@vx-xv.com>
150 - hengband RPM 3.0.0Alpha release 83
151 - Replace RPM_BUILD_ROOT to builddir macro
152
153 * Sat May 06 2023 Shiro Hara <white@vx-xv.com>
154 - hengband RPM 3.0.0Alpha release 82
155
156 * Thu May 04 2023 Shiro Hara <white@vx-xv.com>
157 - hengband RPM 3.0.0Alpha release 81
158
159 * Mon Feb 20 2023 Shiro Hara <white@vx-xv.com>
160 - hengband RPM 3.0.0Alpha release 78
161
162 * Sun Feb 19 2023 Shiro Hara <white@vx-xv.com>
163 - hengband RPM 3.0.0Alpha release 77
164 - Remove Packacger
165 - Remove Buildroot
166 - Add %license
167 - Fix Version and Release
168
169 * Fri Feb 17 2023 Shiro Hara <white@vx-xv.com>
170 - hengband RPM 3.0.0Alpha release 76
171 - Renew Url
172 - Renew Packager
173 - Change Copyright to License
174 - Change readme.txt to readme.md
175
176 * Fri Jul 05 2002 Takahiro MIZUNO <tow@plum.freemail.ne.jp>
177 - hengband RPM 1.0.0b release 3
178 - Add %preun script.
179 - Change source extension. (tar.gz -> bz2)
180 - Fix Copyright.
181 - Fix simply %files.
182 - Fix %description.
183
184 * Mon Jun 17 2002 Takahiro MIZUNO <tow@plum.freemail.ne.jp>
185 - hengband RPM 1.0.0b release 2
186 - Fix setgid permission. (Mogamiさん多謝)
187
188 * Sun Jun 16 2002 Takahiro MIZUNO <tow@plum.freemail.ne.jp>
189 - hengband RPM 1.0.0b release 1
190
191 * Sun Jun 16 2002 Takahiro MIZUNO <tow@plum.freemail.ne.jp> 
192 - hengband RPM 1.0.0 release 1