OSDN Git Service

[Release] 3.0.1.11-Beta
[hengbandforosx/hengbandosx.git] / hengband.spec
1 %define version 3.0.1.10
2 %define release 1
3
4 Summary: hengband %{version}
5 Name: hengband
6 Version: %{version}
7 Release: %{release}
8 License: unknown
9 Group: Amusements/Games
10 Url: https://hengband.github.io
11 Source: hengband-%{version}.tar.gz
12 Requires: ncurses-libs libstdc++ libcurl libX11
13 BuildRequires: autoconf automake gcc-c++ ncurses-devel libcurl-devel nkf libX11-devel
14
15 Requires: %{name}-data
16
17 %package data
18
19 Summary: %{name}-data %{version}
20
21 %package en
22
23 Requires: ncurses-libs libstdc++ libcurl libX11
24 Requires: %{name}-data
25 Summary: %{name}-en %{version}
26
27 %description
28 Hengband is a variant of ZAngband.
29
30 Official page is this,
31 https://hengband.github.io
32
33 More infomation is /usr/share/doc/hengband/readme-eng.md
34 This is a Japanese version.
35
36 Summary(ja): 変愚蛮怒 %{version}
37
38 %description -l ja
39 変愚蛮怒は Angband のバリアントです。
40
41 本ソフトウェアの最新版は以下の場所から入手できます。
42 https://hengband.github.io
43
44 詳しくは /usr/share/doc/hengband/readme.md を参照。
45 このパッケージは日本語版です。
46
47 %description data
48 Hengband is a variant of ZAngband.
49
50 Official page is this,
51 https://hengband.github.io
52
53 More infomation is /usr/share/doc/hengband/readme-eng.md
54 This packages contains common data files.
55
56 Summary(ja): 変愚蛮怒 %{version}
57
58 %description data -l ja
59 変愚蛮怒は Angband のバリアントです。
60
61 本ソフトウェアの最新版は以下の場所から入手できます。
62 https://hengband.github.io
63
64 詳しくは /usr/share/doc/hengband/readme.md を参照。
65 このパッケージはゲーム用データです。
66
67 %description en
68 Hengband is a variant of ZAngband.
69
70 Official page is this,
71 https://hengband.github.io
72
73 More infomation is /usr/share/doc/hengband/readme-eng.md
74 This is a English version.
75
76 Summary(ja): 変愚蛮怒 %{version}
77
78 %prep
79 rm -rf %{buildroot}
80
81 %setup -n %{name}-%{version}
82 ./bootstrap
83
84 %build
85 %configure --with-libpath=%{_datadir}/games/%{name}/lib --disable-japanese
86 %make_build
87 cp src/hengband src/hengband-en
88 %configure --with-libpath=%{_datadir}/games/%{name}/lib
89 %make_build
90
91 %install
92 mkdir -p %{buildroot}/%{_bindir}
93 mkdir -p %{buildroot}/%{_datadir}/games/%{name}
94 %make_install bindir=%{_bindir}
95 cp src/hengband-en %{buildroot}/%{_bindir}
96 cp -R lib/ -p %{buildroot}/%{_datadir}/games/%{name}/
97 find %{buildroot}/%{_datadir}/games/%{name}/ -type f -name "Makefile*" -exec rm {} \;
98 find %{buildroot}/%{_datadir}/games/%{name}/ -type f -name "delete.me*" -exec rm {} \;
99 find %{buildroot}/%{_datadir}/games/%{name}/ -name ".git*" -exec rm -rf {} \;
100 rm -rf %{buildroot}/%{_datadir}/games/%{name}/lib/xtra/{sound,music}
101 touch %{buildroot}/%{_datadir}/games/%{name}/lib/apex/scores.raw
102
103 %clean
104 rm -rf %{buildroot}
105
106 %preun
107 if [ -e %{_datadir}/games/%{name}/lib/data/f_info_j.raw ]
108 then
109 rm -rf %{_datadir}/games/%{name}/lib/data/*.raw
110 fi
111 exit 0
112
113 %files
114 %defattr(-,root,root)
115 %attr(2755,root,games) %{_bindir}/%{name}
116
117 %files en
118 %defattr(-,root,root)
119 %attr(2755,root,games) %{_bindir}/%{name}-en
120
121 %files data
122 %dir %{_datadir}/games/%{name}/lib
123 %attr(775,root,games) %dir %{_datadir}/games/%{name}/lib/apex
124 %attr(775,root,games) %dir %{_datadir}/games/%{name}/lib/bone
125 %attr(775,root,games) %dir %{_datadir}/games/%{name}/lib/data
126 %dir %{_datadir}/games/%{name}/lib/edit
127 %dir %{_datadir}/games/%{name}/lib/file
128 %dir %{_datadir}/games/%{name}/lib/file/books
129 %dir %{_datadir}/games/%{name}/lib/help
130 %dir %{_datadir}/games/%{name}/lib/info
131 %dir %{_datadir}/games/%{name}/lib/pref
132 %attr(775,root,games) %dir %{_datadir}/games/%{name}/lib/save
133 %dir %{_datadir}/games/%{name}/lib/script
134 %dir %{_datadir}/games/%{name}/lib/user
135 %dir %{_datadir}/games/%{name}/lib/xtra
136 %dir %{_datadir}/games/%{name}/lib/xtra/graf
137 %{_datadir}/games/%{name}/lib/apex/h_scores.raw
138 %{_datadir}/games/%{name}/lib/apex/readme.txt
139 %attr(664 root,games) %config(noreplace) %{_datadir}/games/%{name}/lib/apex/scores.raw
140 %{_datadir}/games/%{name}/lib/edit/*.txt
141 %{_datadir}/games/%{name}/lib/edit/quests/*.txt
142 %{_datadir}/games/%{name}/lib/edit/towns/*.txt
143 %{_datadir}/games/%{name}/lib/file/*.txt
144 %{_datadir}/games/%{name}/lib/file/books/*.txt
145 %{_datadir}/games/%{name}/lib/help/*.hlp
146 %{_datadir}/games/%{name}/lib/help/*.txt
147 %{_datadir}/games/%{name}/lib/pref/*.prf
148 %{_datadir}/games/%{name}/lib/xtra/graf/8x8.bmp
149 %doc readme.md readme_angband readme-eng.md
150 %license lib/help/jlicense.txt
151
152 %changelog
153 * Mon Apr 01 2024 Shiro Hara <white@vx-xv.com>
154 - hengband RPM 3.0.1.10(Beta)
155
156 * Sun Mar 10 2024 Shiro Hara <white@vx-xv.com>
157 - Add en(English version), data(common data files) subpakages
158 - hengband RPM 3.0.1.9(Beta)
159
160 * Mon Mar 04 2024 Shiro Hara <white@vx-xv.com>
161 - hengband RPM 3.0.1.8(Beta)
162
163 * Mon Feb 05 2024 Shiro Hara <white@vx-xv.com>
164 - hengband RPM 3.0.1.7(Beta)
165
166 * Mon Jan 22 2024 Shiro Hara <white@vx-xv.com>
167 - hengband RPM 3.0.1.6(Beta)
168
169 * Tue Jan 09 2024 Shiro Hara <white@vx-xv.com>
170 - hengband RPM 3.0.1.5(Beta)
171
172 * Wed Dec 27 2023 Shiro Hara <white@vx-xv.com>
173 - hengband RPM 3.0.1.4(Beta)
174
175 * Mon Dec 11 2023 Shiro Hara <white@vx-xv.com>
176 - hengband RPM 3.0.1.3(Beta)
177
178 * Mon Nov 27 2023 Shiro Hara <white@vx-xv.com>
179 - hengband RPM 3.0.1.2(Beta)
180
181 * Fri Nov 17 2023 Shiro Hara <white@vx-xv.com>
182 - hengband RPM 3.0.1.1(Beta)
183
184 * Mon Oct 30 2023 Shiro Hara <white@vx-xv.com>
185 - hengband RPM 3.0.1.0(Beta)
186
187 * Sun Oct 22 2023 Shiro Hara <white@vx-xv.com>
188 - Fix the graphic mode is not available on X11
189
190 * Wed Oct 18 2023 Shiro Hara <white@vx-xv.com>
191 - hengband RPM 3.0.0.91(Alpha)
192
193 * Mon Oct 16 2023 Shiro Hara <white@vx-xv.com>
194 - hengband RPM 3.0.0.90(Alpha)
195
196 * Tue Aug 8 2023 Shiro Hara <white@vx-xv.com>
197 - hengband RPM 3.0.0.89(Alpha)
198
199 * Mon Jul 24 2023 Shiro Hara <white@vx-xv.com>
200 - Enable X11
201
202 * Sun Jul 23 2023 Shiro Hara <white@vx-xv.com>
203 - hengband RPM 3.0.0.88(Alpha)
204
205 * Sun Jul 09 2023 Shiro Hara <white@vx-xv.com>
206 - hengband RPM 3.0.0.87(Alpha)
207
208 * Mon Jun 26 2023 Shiro Hara <white@vx-xv.com>
209 - hengband RPM 3.0.0.86(Alpha)
210
211 * Wed Jun 14 2023 Shiro Hara <white@vx-xv.com>
212 - hengband RPM 3.0.0.85(Alpha)
213
214 * Mon May 29 2023 Shiro Hara <white@vx-xv.com>
215 - hengband RPM 3.0.0Alpha release 84
216
217 * Wed May 17 2023 Shiro Hara <white@vx-xv.com>
218 - hengband RPM 3.0.0Alpha release 83
219 - Replace RPM_BUILD_ROOT to builddir macro
220
221 * Sat May 06 2023 Shiro Hara <white@vx-xv.com>
222 - hengband RPM 3.0.0Alpha release 82
223
224 * Thu May 04 2023 Shiro Hara <white@vx-xv.com>
225 - hengband RPM 3.0.0Alpha release 81
226
227 * Mon Feb 20 2023 Shiro Hara <white@vx-xv.com>
228 - hengband RPM 3.0.0Alpha release 78
229
230 * Sun Feb 19 2023 Shiro Hara <white@vx-xv.com>
231 - hengband RPM 3.0.0Alpha release 77
232 - Remove Packacger
233 - Remove Buildroot
234 - Add %license
235 - Fix Version and Release
236
237 * Fri Feb 17 2023 Shiro Hara <white@vx-xv.com>
238 - hengband RPM 3.0.0Alpha release 76
239 - Renew Url
240 - Renew Packager
241 - Change Copyright to License
242 - Change readme.txt to readme.md
243
244 * Fri Jul 05 2002 Takahiro MIZUNO <tow@plum.freemail.ne.jp>
245 - hengband RPM 1.0.0b release 3
246 - Add %preun script.
247 - Change source extension. (tar.gz -> bz2)
248 - Fix Copyright.
249 - Fix simply %files.
250 - Fix %description.
251
252 * Mon Jun 17 2002 Takahiro MIZUNO <tow@plum.freemail.ne.jp>
253 - hengband RPM 1.0.0b release 2
254 - Fix setgid permission. (Mogamiさん多謝)
255
256 * Sun Jun 16 2002 Takahiro MIZUNO <tow@plum.freemail.ne.jp>
257 - hengband RPM 1.0.0b release 1
258
259 * Sun Jun 16 2002 Takahiro MIZUNO <tow@plum.freemail.ne.jp> 
260 - hengband RPM 1.0.0 release 1