OSDN Git Service

upg
[joborun/jobcore.git] / dbus / PKGBUILD
1 #!/usr/bin/bash
2 # JOBoRun               : Jwm OpenBox Obarun RUNit
3 # Maintainer            : Joe Bo Run <joborun@disroot.org>
4 # PkgSource             : url="https://gittea.disroot.org/joborun-pkg/jobcore/$pkgname"
5 #-----------------------------------------| DESCRIPTION |---------------------------------------
6
7 pkgbase=dbus
8 pkgname=(dbus dbus-docs)
9 pkgver=1.14.0
10 pkgrel=01
11 pkgdesc="Freedesktop.org message bus system"
12 url="https://wiki.freedesktop.org/www/Software/dbus/"
13 arch=(x86_64)
14 depends=(expat audit)
15 makedepends=(xmlto docbook-xsl python yelp-tools doxygen git autoconf-archive automake)
16 source=("git+https://gitlab.freedesktop.org/dbus/dbus.git?signed#tag=dbus-$pkgver"
17         no-fatal-warnings.diff dbus.tmpfiles)
18
19 prepare() {
20   cd dbus
21
22   # Allow us to enable checks without them being fatal
23   patch -Np1 -i ../no-fatal-warnings.diff
24
25   NOCONFIGURE=1 ./autogen.sh
26 }
27
28 build() {
29   cd dbus
30   ./configure \
31     --prefix=/usr \
32     --sysconfdir=/etc \
33     --localstatedir=/var \
34     --libexecdir=/usr/lib/dbus-1.0 \
35     --runstatedir=/run \
36     --with-console-auth-dir=/run/console/ \
37     --with-dbus-user=dbus \
38     --with-system-pid-file=/run/dbus/pid \
39     --with-system-socket=/run/dbus/system_bus_socket \
40     --without-systemdsystemunitdir \
41     --enable-inotify \
42     --enable-libaudit \
43     --disable-systemd \
44     --disable-user-session \
45     --enable-xml-docs \
46     --enable-doxygen-docs \
47     --enable-ducktype-docs \
48     --disable-static \
49     --disable-asserts \
50     --disable-x11-autolaunch \
51     --disable-checks \
52     --without-x
53   make
54 }
55
56 check() {
57   make -C dbus -j1 check
58 }
59
60 package_dbus() {
61   depends+=(libaudit.so)
62   provides=(libdbus libdbus-1.so)
63   conflicts=(libdbus)
64   replaces=(libdbus)
65
66   DESTDIR="$pkgdir" make -C dbus install
67
68   rm -r "$pkgdir"/{etc,var}
69
70 #  # We have a pre-assigned uid (81)
71 #  echo 'u dbus 81 "System Message Bus"' |
72 #  install -Dm644 /dev/stdin "$pkgdir/usr/lib/sysusers.d/dbus.conf"
73   install -D -m0644 "$srcdir"/dbus.tmpfiles "$pkgdir"/usr/lib/tmpfiles.d/dbus.conf
74 #  install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 *.hook
75
76   # Split docs
77   mkdir -p doc/usr/share
78   mv {"$pkgdir",doc}/usr/share/doc
79
80   install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 dbus/COPYING
81 }
82
83 package_dbus-docs() {
84    pkgdesc+=" (documentation)"
85    depends=()
86  
87    mv doc/* "$pkgdir"
88
89    install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 dbus/COPYING
90 }
91
92
93
94
95 #---- license gpg-key sha256sums ----
96
97 license=(GPL custom)
98
99 validpgpkeys=('DA98F25C0871C49A59EAFF2C4DE8FF2A63C7CC90') # Simon McVittie <simon.mcvittie@collabora.co.uk>
100
101 sha256sums=(SKIP
102         6958eeec07557b92a28419eb1702331ee2f0a6fd17285e37dfb6130b9fa4cf6e # no-fatal-warnings.diff
103         965cef20cce35819e89c65f06a931a38bea2119b0ae9c259b5d7f9cfc3edd6d7) # dbus.tmpfiles