OSDN Git Service

upg
[joborun/jobcore.git] / gettext / PKGBUILD-arch
1 # Maintainer:
2
3 pkgname=gettext
4 pkgver=0.21
5 pkgrel=2
6 pkgdesc="GNU internationalization library"
7 url="https://www.gnu.org/software/gettext/"
8 arch=(x86_64)
9 license=(GPL)
10 groups=(base-devel)
11 depends=(gcc-libs acl sh libunistring libxml2)
12 makedepends=(gettext emacs git)
13 optdepends=('git: for autopoint infrastructure updates')
14 options=(!docs)
15 source=(https://ftp.gnu.org/pub/gnu/gettext/$pkgname-$pkgver.tar.gz{,.sig}
16         gettext-0.21-disable-libtextstyle.patch)
17 sha256sums=('c77d0da3102aec9c07f43671e60611ebff89a996ef159497ce8e59d075786b12'
18             'SKIP'
19             '544ce0589e9c70f4f75d77c76fd36f88d009ac9cfecb4812a67f878e38ac6418')
20 validpgpkeys=('462225C3B46F34879FC8496CD605848ED7E69871'  # Daiki Ueno
21               '68D94D8AAEEAD48AE7DC5B904F494A942E4616C2'
22               '9001B85AF9E1B83DF1BDA942F5BE8B267C6A406D') # Bruno Haible (Open Source Development)
23
24
25 prepare() {
26   cd $pkgname-$pkgver
27
28   # Do not build libtextstyle, as it depends on libcroco
29   # which is now unmaintained and has known security bugs.
30   # patch from Fedora   
31   patch -p1 -i $srcdir/gettext-0.21-disable-libtextstyle.patch
32 }
33
34 build() {
35   cd $pkgname-$pkgver
36
37   autoreconf --force
38
39   ./configure \
40     --prefix=/usr \
41     --enable-csharp \
42     --enable-nls \
43     --with-xz \
44     --without-included-gettext
45
46   sed -e 's/ -shared / -Wl,-O1,--as-needed\0/g' \
47       -i gettext-{tools,runtime,runtime/libasprintf}/libtool
48
49   make
50 }
51
52 check() {
53   cd $pkgname-$pkgver
54   make check
55 }
56
57 package() {
58   cd $pkgname-$pkgver
59   make DESTDIR="$pkgdir" install
60 }