OSDN Git Service

upg
[joborun/jobcore.git] / pciutils / PKGBUILD-arch
1 # Maintainer: Tobias Powalowski <tpowa@archlinux.org>
2 pkgname=pciutils
3 pkgver=3.7.0
4 pkgrel=1
5 pkgdesc="PCI bus configuration space access library and tools"
6 arch=(x86_64)
7 license=('GPL2')
8 url="https://mj.ucw.cz/sw/pciutils/"
9 depends=('glibc' 'hwids' 'kmod')
10 makedepends=('git')
11 source=(#ftp://ftp.kernel.org/pub/software/utils/${pkgname}/${pkgname}-${pkgver}.tar.bz2
12         https://mj.ucw.cz/download/linux/pci/${pkgname}-${pkgver}.tar.gz{,.sign})
13         #git+https://github.com/pciutils/pciutils.git#tag=v$pkgver?signed)
14 validpgpkeys=(
15               '5558F9399CD7836850553C6EC28E7847ED70F82D' # Martin Mares <mj@ucw.cz>
16              )
17
18 md5sums=('51554c538b5a57b61123326e14ea28a1'
19          'SKIP')
20
21 build() {
22   cd $pkgname-$pkgver
23   make OPT="${CFLAGS} -fPIC -DPIC" ZLIB=no SHARED=no PREFIX=/usr SHAREDIR=/usr/share/hwdata MANDIR=/usr/share/man SBINDIR=/usr/bin lib/libpci.a 
24   cp lib/libpci.a "${srcdir}/"
25   make clean
26   make OPT="${CFLAGS}" ZLIB=no SHARED=yes PREFIX=/usr SBINDIR=/usr/bin SHAREDIR=/usr/share/hwdata MANDIR=/usr/share/man all
27 }
28
29 package() {
30   cd $pkgname-$pkgver
31   make SHARED=yes PREFIX=/usr SBINDIR=/usr/bin SHAREDIR=/usr/share/hwdata MANDIR=/usr/share/man DESTDIR="${pkgdir}" install install-lib
32   # this is now supplied by the hwids package
33   rm -rf "$pkgdir"/usr/{sbin/update-pciids,share/{man/man8/update-pciids.8,hwdata}}
34 }