OSDN Git Service

PG93対応に必要なヘッダファイルを追加した。
[pghintplan/pg_hint_plan.git] / SPECS / pg_hint_plan92.spec
1 # SPEC file for pg_hint_plan
2 # Copyright(C) 2013 NIPPON TELEGRAPH AND TELEPHONE CORPORATION
3
4 %define _pgdir   /usr/pgsql-9.2
5 %define _bindir  %{_pgdir}/bin
6 %define _libdir  %{_pgdir}/lib
7 %define _datadir %{_pgdir}/share
8
9 ## Set general information for pg_hint_plan.
10 Summary:    Optimizer hint for PostgreSQL 9.2
11 Name:       pg_hint_plan92
12 Version:    1.1.0
13 Release:    1%{?dist}
14 License:    BSD
15 Group:      Applications/Databases
16 Source0:    %{name}-%{version}.tar.gz
17 #URL:        http://example.com/pg_hint_plan/
18 BuildRoot:  %{_tmppath}/%{name}-%{version}-%{release}-%(%{__id_u} -n)
19 Vendor:     NIPPON TELEGRAPH AND TELEPHONE CORPORATION
20
21 ## We use postgresql-devel package
22 BuildRequires:  postgresql92-devel
23 Requires:  postgresql92-libs
24
25 ## Description for "pg_hint_plan"
26 %description
27 pg_hint_plan provides capability to force arbitrary plan to PostgreSQL' planner
28 to optimize queries by hand directly.
29
30 If you have query plan better than which PostgreSQL chooses, you can force your
31 plan by adding special comment block with optimizer hint before the query you
32 want to optimize.  You can control scan method, join method, join order, and
33 planner-related GUC parameters during planning.
34
35 Note that this package is available for only PostgreSQL 9.2.
36
37 ## pre work for build pg_hint_plan
38 %prep
39 %setup -q
40
41 ## Set variables for build environment
42 %build
43 make %{?_smp_mflags}
44
45 ## Set variables for install
46 %install
47 rm -rf %{buildroot}
48 install -d %{buildroot}%{_libdir}
49 install pg_hint_plan.so %{buildroot}%{_libdir}/pg_hint_plan.so
50 install -d %{buildroot}%{_datadir}/extension
51 install -m 644 pg_hint_plan--1.0.sql %{buildroot}%{_datadir}/extension/pg_hint_plan--1.0.sql
52 install -m 644 pg_hint_plan.control %{buildroot}%{_datadir}/extension/pg_hint_plan.control
53
54 %clean
55 rm -rf %{buildroot}
56
57 %files
58 %defattr(0755,root,root)
59 %{_libdir}/pg_hint_plan.so
60 %defattr(0644,root,root)
61 %{_datadir}/extension/pg_hint_plan--1.0.sql
62 %{_datadir}/extension/pg_hint_plan.control
63
64 # History of pg_hint_plan.
65 %changelog
66 * Mon Sep 02 2013 Takashi Suzuki
67 - Initial cut for 1.1.0
68 * Mon Sep 24 2012 Shigeru Hanada <shigeru.hanada@gmail.com>
69 - Initial cut for 1.0.0
70