OSDN Git Service

e28e5ae0f60f39b359e80648fc460be1aa1cba96
[serene/serene-bodhibuilder.git] / etc / bodhibuilder / ubiquity / apt-setup.bb
1 #! /bin/sh -e
2
3 . /usr/share/debconf/confmodule
4
5 if CODENAME="$(lsb_release -cs)"; then
6   # TODO cjwatson 2006-04-07: wrong for Debian, I think
7   db_set mirror/suite "$CODENAME"
8   db_set mirror/codename "$CODENAME"
9 fi
10
11 rm -f /target/etc/apt/sources.list
12 rm -f /target/etc/apt/sources.list.d/dvd.list
13 PATH="/usr/lib/ubiquity/apt-setup:/usr/lib/ubiquity/choose-mirror:$PATH" \
14   OVERRIDE_BASE_INSTALLABLE=1 OVERRIDE_LEAVE_CD_MOUNTED=1 \
15   /usr/lib/ubiquity/apt-setup/apt-setup --log-output /target
16
17 # UEFI support for VM's:
18 if [ -e /target/boot/efi ] ; then
19   rm -f /target/boot/efi/startup.nsh*
20   touch /target/boot/efi/startup.nsh
21   ARCH=`archdetect | cut -d/ -f1`
22   if [ "${ARCH}" = "amd64" ] ; then
23     echo "fs0:\EFI\ubuntu\grubx64.efi" >> /target/boot/efi/startup.nsh
24   else
25     echo "fs0:\EFI\ubuntu\grubia32.efi" >> /target/boot/efi/startup.nsh
26   fi
27 fi
28 #~ #   ^ replaced ^ by ^ section ^ below ^
29
30 #~ yes | rm -f /target/boot/efi/startup.nsh*
31 #~ mkdir -p /target/boot/efi
32 #~ touch /target/boot/efi/startup.nsh
33 #~ ARCH=`archdetect | cut -d/ -f1`
34 #~ if [ "${ARCH}" = "amd64" ] ; then
35   #~ echo "fs0:\EFI\ubuntu\grubx64.efi" >> /target/boot/efi/startup.nsh
36 #~ else
37   #~ echo "fs0:\EFI\ubuntu\grubia32.efi" >> /target/boot/efi/startup.nsh
38 #~ fi
39
40
41 rm -f /target/etc/gdm/custom.conf
42 rm -f /target/etc/mdm/mdm.conf