OSDN Git Service

2013.10.24
[uclinux-h8/uClinux-dist.git] / user / e2fsprogs / e2fsprogs.spec
1 %define _root_sbindir   /sbin
2 %define _root_libdir    /%{_lib}
3 %define _root_localedir /usr/share/locale
4
5 Summary: Utilities for managing the second extended (ext2) filesystem.
6 Name: e2fsprogs
7 Version: 1.39-WIP
8 Release: 0
9 Copyright: GPL
10 Group: System Environment/Base
11 Source:  ftp://download.sourceforge.net/pub/sourceforge/e2fsprogs/e2fsprogs-%{version}.tar.gz
12 Url: http://e2fsprogs.sourceforge.net/
13 Prereq: /sbin/ldconfig
14 BuildRoot: %{_tmppath}/%{name}-root
15
16 %description
17 The e2fsprogs package contains a number of utilities for creating,
18 checking, modifying, and correcting any inconsistencies in second
19 extended (ext2) filesystems.  E2fsprogs contains e2fsck (used to
20 repair filesystem inconsistencies after an unclean shutdown), mke2fs
21 (used to initialize a partition to contain an empty ext2 filesystem),
22 debugfs (used to examine the internal structure of a filesystem, to
23 manually repair a corrupted filesystem or to create test cases for
24 e2fsck), tune2fs (used to modify filesystem parameters), resize2fs to
25 grow and shrink unmounted ext2 filesystems, and most of the other core
26 ext2fs filesystem utilities.
27
28 You should install the e2fsprogs package if you are using any ext2
29 filesystems (if you're not sure, you probably should install this
30 package).  You may also need to install it (even if you don't use
31 ext2) for the libuuid and libblkid libraries and fsck tool that are
32 included here.
33
34 %package devel
35 Summary: Ext2 filesystem-specific static libraries and headers.
36 Group: Development/Libraries
37 Requires: e2fsprogs = %{version}
38 Prereq: /sbin/install-info
39
40 %description devel
41 E2fsprogs-devel contains the libraries and header files needed to
42 develop second extended (ext2) filesystem-specific programs.
43
44 You should install e2fsprogs-devel if you want to develop ext2
45 filesystem-specific programs.  If you install e2fsprogs-devel, you'll
46 also want to install e2fsprogs.
47
48 %prep
49 %setup
50
51 %build
52 %configure --enable-elf-shlibs --enable-nls
53 make
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 export PATH=/sbin:$PATH
58 make install install-libs DESTDIR="$RPM_BUILD_ROOT" \
59         root_sbindir=%{_root_sbindir} root_libdir=%{_root_libdir}
60 /sbin/ldconfig -n ${RPM_BUILD_ROOT}%{_libdir}
61 %find_lang %{name}
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %post -p /sbin/ldconfig
67
68 %postun -p /sbin/ldconfig
69
70 %post devel
71 if [ -x /sbin/install-info -a -f %{_infodir}/libext2fs.info.gz ]; then
72     /sbin/install-info %{_infodir}/libext2fs.info.gz %{_infodir}/dir
73 fi
74 exit 0
75
76 %postun devel
77 if [ $1 = 0 -a -x /sbin/install-info -a -f %{_infodir}/libext2fs.info.gz ]; then
78    /sbin/install-info --delete %{_infodir}/libext2fs.info.gz %{_infodir}/dir
79 fi
80 exit 0
81
82 %files -f %{name}.lang
83 %defattr(-,root,root)
84 %doc README RELEASE-NOTES
85
86 %{_root_sbindir}/badblocks
87 %{_root_sbindir}/blkid
88 %{_root_sbindir}/debugfs
89 %{_root_sbindir}/dumpe2fs
90 %{_root_sbindir}/e2fsck
91 %{_root_sbindir}/e2image
92 %{_root_sbindir}/e2label
93 %{_root_sbindir}/findfs
94 %{_root_sbindir}/fsck
95 %{_root_sbindir}/fsck.ext2
96 %{_root_sbindir}/fsck.ext3
97 %{_root_sbindir}/logsave
98 %{_root_sbindir}/mke2fs
99 %{_root_sbindir}/mkfs.ext2
100 %{_root_sbindir}/mkfs.ext3
101 %{_root_sbindir}/resize2fs
102 %{_root_sbindir}/tune2fs
103 %{_sbindir}/filefrag
104 %{_sbindir}/mklost+found
105
106 %{_root_libdir}/libblkid.so.*
107 %{_root_libdir}/libcom_err.so.*
108 %{_root_libdir}/libe2p.so.*
109 %{_root_libdir}/libext2fs.so.*
110 %{_root_libdir}/libss.so.*
111 %{_root_libdir}/libuuid.so.*
112
113 %{_libdir}/e2initrd_helper
114
115 %{_bindir}/chattr
116 %{_bindir}/lsattr
117 %{_bindir}/uuidgen
118 %{_mandir}/man1/chattr.1*
119 %{_mandir}/man1/lsattr.1*
120 %{_mandir}/man1/uuidgen.1*
121
122 %{_mandir}/man8/badblocks.8*
123 %{_mandir}/man8/blkid.8*
124 %{_mandir}/man8/debugfs.8*
125 %{_mandir}/man8/dumpe2fs.8*
126 %{_mandir}/man8/e2fsck.8*
127 %{_mandir}/man8/findfs.8*
128 %{_mandir}/man8/fsck.ext2.8*
129 %{_mandir}/man8/fsck.ext3.8*
130 %{_mandir}/man8/e2image.8*
131 %{_mandir}/man8/e2label.8*
132 %{_mandir}/man8/fsck.8*
133 %{_mandir}/man8/logsave.8*
134 %{_mandir}/man8/mke2fs.8*
135 %{_mandir}/man8/mkfs.ext2.8*
136 %{_mandir}/man8/mkfs.ext3.8*
137 %{_mandir}/man8/mklost+found.8*
138 %{_mandir}/man8/resize2fs.8*
139 %{_mandir}/man8/tune2fs.8*
140 %{_mandir}/man8/filefrag.8*
141
142 %{_root_localedir}/cs/LC_MESSAGES/e2fsprogs.mo
143 %{_root_localedir}/de/LC_MESSAGES/e2fsprogs.mo
144 %{_root_localedir}/es/LC_MESSAGES/e2fsprogs.mo
145 %{_root_localedir}/it/LC_MESSAGES/e2fsprogs.mo
146 %{_root_localedir}/pl/LC_MESSAGES/e2fsprogs.mo
147 %{_root_localedir}/sv/LC_MESSAGES/e2fsprogs.mo
148 %{_root_localedir}/tr/LC_MESSAGES/e2fsprogs.mo
149
150 %files devel
151 %defattr(-,root,root)
152 %{_infodir}/libext2fs.info*
153 %{_bindir}/compile_et
154 %{_bindir}/mk_cmds
155
156 %{_libdir}/libblkid.a
157 %{_libdir}/libblkid.so
158 %{_libdir}/libcom_err.a
159 %{_libdir}/libcom_err.so
160 %{_libdir}/libe2p.a
161 %{_libdir}/libe2p.so
162 %{_libdir}/libext2fs.a
163 %{_libdir}/libext2fs.so
164 %{_libdir}/libss.a
165 %{_libdir}/libss.so
166 %{_libdir}/libuuid.a
167 %{_libdir}/libuuid.so
168
169 %{_libdir}/pkgconfig/blkid.pc
170 %{_libdir}/pkgconfig/com_err.pc
171 %{_libdir}/pkgconfig/e2p.pc
172 %{_libdir}/pkgconfig/ext2fs.pc
173 %{_libdir}/pkgconfig/ss.pc
174 %{_libdir}/pkgconfig/uuid.pc
175
176 %{_datadir}/et
177 %{_datadir}/ss
178 %{_includedir}/blkid
179 %{_includedir}/e2p
180 %{_includedir}/et
181 %{_includedir}/ext2fs
182 %{_includedir}/ss
183 %{_includedir}/uuid
184 %{_includedir}/e2p/e2p.h
185 %{_mandir}/man1/compile_et.1*
186 %{_mandir}/man1/mk_cmds.1*
187 %{_mandir}/man3/com_err.3*
188 %{_mandir}/man3/libblkid.3*
189 %{_mandir}/man3/uuid.3*
190 %{_mandir}/man3/uuid_clear.3*
191 %{_mandir}/man3/uuid_compare.3*
192 %{_mandir}/man3/uuid_copy.3*
193 %{_mandir}/man3/uuid_generate.3*
194 %{_mandir}/man3/uuid_generate_random.3*
195 %{_mandir}/man3/uuid_generate_time.3*
196 %{_mandir}/man3/uuid_is_null.3*
197 %{_mandir}/man3/uuid_parse.3*
198 %{_mandir}/man3/uuid_time.3*
199 %{_mandir}/man3/uuid_unparse.3*
200