OSDN Git Service

Rename log4cxx => apache-log4cxx
[ultramonkey-l7/log4cxx.git] / apache-log4cxx.spec
1 Name: log4cxx
2 Version: 0.10.0
3 Release: 1%{?dist}
4 Summary: A port to C++ of the Log4j project
5
6 Group: System Environment/Libraries
7 License: ASL 2.0
8 URL: http://logging.apache.org/log4cxx/index.html
9 Source0: http://www.apache.org/dist/logging/log4cxx/%{version}/apache-%{name}-%{version}.tar.gz
10 # Filed into upstream bugtracker at:
11 # https://issues.apache.org/jira/browse/LOGCXX-332
12 Patch0: log4cxx-gcc4.4.patch
13 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
14
15 BuildRequires: apr-devel,apr-util-devel,doxygen
16
17 %description
18 Log4cxx is a popular logging package written in C++. One of its distinctive
19 features is the notion of inheritance in loggers. Using a logger hierarchy it
20 is possible to control which log statements are output at arbitrary
21 granularity. This helps reduce the volume of logged output and minimize the
22 cost of logging.
23
24 %prep
25 %setup -q -n apache-%{name}-%{version}
26 %patch0 -p1
27
28 %build
29 sed -i.libdir_syssearch -e \
30  '/sys_lib_dlsearch_path_spec/s|/usr/lib |/usr/lib /usr/lib64 /lib /lib64 |' \
31  configure
32 %configure
33 make -k %{?_smp_mflags}
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37 make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
38 mv $RPM_BUILD_ROOT%{_datadir}/%{name}/html .
39
40 %clean
41 rm -rf $RPM_BUILD_ROOT
42
43 %post -p /sbin/ldconfig
44 %postun -p /sbin/ldconfig
45
46 %files
47 %defattr(-,root,root,-)
48 %{_libdir}/liblog4cxx.so.10.0.0
49 %{_libdir}/liblog4cxx.so.10
50
51 %doc NOTICE LICENSE KEYS
52
53 %package devel
54 Requires: %{name} = %{version}-%{release},pkgconfig,apr-devel
55 Group: Development/Libraries
56 Summary: Header files for Log4xcc - a port to C++ of the Log4j project
57
58 %description devel
59 Header files and documentation you can use to develop with log4cxx
60
61 %files devel
62 %defattr(-,root,root,-)
63 %exclude %{_libdir}/*.la
64 %exclude %{_libdir}/*.a
65 %{_includedir}/log4cxx
66 %{_libdir}/liblog4cxx.so
67 %{_libdir}/pkgconfig/liblog4cxx.pc
68
69 %doc html/
70
71 %changelog
72 * Fri Nov 9 2012 HIBARI Michiro <hibari.michiro@lab.ntt.co.jp> - 0.10.0-1
73 - Initial package.
74 - Patched log4cxx-gcc4.4.patch for provide gcc 4.4 compatibility.
75
76