OSDN Git Service

v2raya2: Update to 2.0.1 v2raya-2.0.1
authorTianling Shen <cnsztl@immortalwrt.org>
Sat, 24 Dec 2022 03:10:29 +0000 (11:10 +0800)
committerTianling Shen <cnsztl@immortalwrt.org>
Sat, 24 Dec 2022 03:10:29 +0000 (11:10 +0800)
Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
v2raya2/Makefile
v2raya2/patches/010-fix-check-the-transport-type-to-avoid-abnormal-exit-.patch [deleted file]

index dff240b..e22bc42 100644 (file)
@@ -5,12 +5,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=v2rayA
-PKG_VERSION:=2.0.0
+PKG_VERSION:=2.0.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/v2rayA/v2rayA/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=857600f5f2b47e4df9f360b88df6b373425c1f7e2bec5d9a3f15938903410f1c
+PKG_HASH:=5f79a42c4a720dec778a5c03c925dbbeb8d0fedebbb38ddf90d2d9712480b6a4
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)/service
 
 PKG_LICENSE:=AGPL-3.0-only
@@ -64,7 +64,7 @@ define Download/v2raya-web
        URL:=https://codeload.github.com/v2rayA/v2raya-web/tar.gz/v$(PKG_VERSION)?
        URL_FILE:=$(WEB_FILE)
        FILE:=$(WEB_FILE)
-       HASH:=3132020db37e165e8c65fe343168f989fe4334549459289110960cc27b0c6c00
+       HASH:=a327170bea7a1e68bd7016815840f02f0505ee721a45573cc538bd2bc5e5503f
 endef
 
 GO_PKG_TARGET_VARS:=$(filter-out CGO_ENABLED=%,$(GO_PKG_TARGET_VARS)) CGO_ENABLED=0
diff --git a/v2raya2/patches/010-fix-check-the-transport-type-to-avoid-abnormal-exit-.patch b/v2raya2/patches/010-fix-check-the-transport-type-to-avoid-abnormal-exit-.patch
deleted file mode 100644 (file)
index ee03538..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-From 38afbd4f03a7b1816b7da30e7c5f5f9eb167f222 Mon Sep 17 00:00:00 2001
-From: mzz2017 <mzz@tuta.io>
-Date: Sun, 11 Dec 2022 19:17:20 +0800
-Subject: [PATCH] fix: check the transport type to avoid abnormal exit of core
-
----
- service/core/serverObj/v2ray.go | 2 ++
- 1 file changed, 2 insertions(+)
-
---- a/core/serverObj/v2ray.go
-+++ b/core/serverObj/v2ray.go
-@@ -333,6 +333,8 @@ func (v *V2Ray) Configuration(info Prior
-                                       Path: v.Path,
-                               }
-                       }
-+              default:
-+                      return Configuration{}, fmt.Errorf("unexpected transport type: %v", v.Net)
-               }
-               if strings.ToLower(v.TLS) == "tls" {
-                       core.StreamSettings.Security = "tls"